PHPStorm mit Xdebug und NGINX

Hallo zusammen, ich versuche krampfhaft in meiner Entwicklungsumgebung das Debuggen einzurichten. Nach erfolgreichem Installieren von Xdebug auf meinem NGINX Server, konnte ich auch den ersten Breakpoint in PHPStorm ansteuern. Soweit so gut. Allerdings kann ich hier nur einen Breakpoint in der shopware.php oder der Application.php ansteuern. Der Breakpoint in einem Plugin (Bootstrap.php) wird getrost ignoriert und ich bekomme einen 502er-Bad Gateway vom Server zurĂŒck. :frowning: Was muss ich tun, damit ich den Breakpoint auch im Plugin nutzen kann? Gibt doch sicher einige hier, die schon per Xdebug und PHPStorm gearbeitet haben :wink: Noch kurz ein paar Eckdaten: SW: 5.0.2 PHPStorm: 8.0.3 PHP Version auf dem Server: 5.6.11 Xdebug: 2.3.3 Benutzter Browser: Firefox 40.0.3 Ich habe bereits die Timeouts von 30 auf 300 gesetzt, da ich vorher einen 504 - Gateway Timeout bekommen habe. Der 502er gefĂ€llt mir aber auch nicht so gut :wtf: Alle Dateien liegen sowohl auf dem Remote Server als auch lokal, das automatische Uploaden von gespeicherten Dateien funktioniert einwandfrei. Gruß Markus

*push* Gibt’s hier jemand, der mir eventuell einen Lösungsansatz bieten kann? Immer den Code aus einem Plugin in eine gesonderte php Datei im root-Verzeichnis zu kopieren finde ich sehr umstĂ€ndlich. Das muss doch auch besser gehen :frowning:

Sind im Shop Premium-Plugins installiert? Ich habe das gleiche Problem auch in einem 5er Shop. Sobald ich die Premium-Plugins und den Lizenzmanager deaktiviere, funktioniert XDebug wieder. Ich bin mir nicht sicher, ob das Absicht von Shopware ist oder ein Problem mit Ioncube besteht


Hallo, erstmal danke fĂŒr deine Antwort! Leider fĂŒhrt das nicht zur Lösung. Ich habe den Lizenzmanager sowie alle Plugins von :shopware: deaktiviert, jedoch bekomme ich noch immer einen 502er. Selbst wenn dies die Lösung gewesen wĂ€re, wĂ€re es nicht akzeptabel alle Plugins zu deaktivieren um zu debuggen. Das wĂŒrde ja bedeuten, dass ich die Premiumplugins z.B. nicht debuggen könnte bzw eigene Plugins, welche auf diesen aufsetzen. :frowning: Da wir in unserem Shop sehr viel auch selbst angepasst haben, kann ich auch nicht komplett alle Plugins deaktivieren, da sonst der Shop kaum noch laufen wĂŒrde, auch wenn es sich hierbei nur um eine Entwicklungsumgebung handelt. Dann brauche ich auch nicht mehr zu debuggen, wenn alles aus ist :smiley: Hat noch jemand eine andere Idee? Google und Co. habe ich schon durchforstet, diverse Tipps und Tricks ausprobiert und stehe leider noch immer vor diesem Problem.

Hi, das Problem ist, dass man mit Ioncube verschlĂŒsselte Scripte nicht mit xDebug debuggen kann. D.h. sobald man eine Debugsession laufen hat und ein mit Ioncube verschlĂŒsseltes Script aufgerufen wird, lĂ€uft sich alles tot. Daran lĂ€sst sich leider nichts Ă€ndern. (Meines Wissens nach jedenfalls)

1 Like

Vielen Dank fĂŒr deine Antwort! Ich habe nun alle verschlĂŒsselten Plugins deaktiviert (von >60 aktiven sind dies 14) und nun wird an den Breakpoints in den Plugins auch angehalten. Super! Ist zwar nicht so schön, so viele Plugins zu deaktivieren, aber zu Debug-Zwecken, vorallem um eigene Plugins zu debuggen ist es besser als nichts :slight_smile: Danke und Gruß Markus

Bei Shopware 4 war es bei mir bisher so, dass verschlĂŒsselte Teile einfach ĂŒbersprungen wurden. Vielleicht kann jemand von Shopware etwas dazu sagen, ob das neue Verhalten Absicht ist oder warum es dazu kommt.