PayPal Produkte: Zahlung bei eigenen Versandkostenberechnung nur per PayPal Plus & Express

Wir haben hier das selbe Problem,

aber keine eigene Versandkostenberechnung

und PayPal ist auf sortierung 1
Vorkasse mit 5% rabatt auf der 2

und alle anderen auch nach PayPal

Gibt es hierzu bereits Lösungen?
 

@8mylez schrieb:

@Zwerg69‍

PayPal war bei uns mit einem Abschlag von 2% versehen. Vorkasse mit 3%. 

Das Problem bei uns war, dass Vorkasse auf Platz 1 der Zahlungsarten gelistet war.

Ich vermute das Problem ist, dass der Warenkorb nicht passt beim Uebertragen. Daher auch die Fehler mit den Versandkostenberechnungen.

Wir haben also PayPal ueber die Positon auf Platz 1 befoerdert und koennten ohne Probleme bestellen.

Moeglicherweise hilft es euch auch!

Die Änderung der Platzierung hat nichts geändert (auch das Abschalten des Cookie Hinweises hat nichts gebracht). Es liegt bei uns definitiv an der Berechnung der Versandkosten.

Summe: 12,90 €
Versandkosten: 5,13 € (5€ + 1%)
Gesamtsumme: 18,03 €

Gehe ich nun zu PayPal werde ich gebeten 17,90 € (Summe + Versandkosten ohne 1%) zu zahlen. In der Bestätigungsmail aus Shopware wird die Gesamtsumme aber korrekt mit 18,03 € angegeben. Woher das PayPalUnified Plugin die Versandkosten von 5€ nimmt, ist mir schleierhaft. Die Berechnungsformel lautet:

 (5 + SUM(b.quantity \* b.price) / 100)

Es gibt nur eine einzige Versandkostenart die tatsächlich 5€ Versandkosten berechnet, für diese ist PayPal jedoch nicht als erlaubte Zahlungsart hinterlegt.

 

 

Bei uns scheint es definitiv auch an den Versandkosten zu liegen, da der Fehler nur bei ausländischen Bestellungen auftritt. Bis auf die Versandkosten ist nämlich bei Bestellungen ins Ausland sonst in der Regel alles identisch. Hier wurde ebenfalls bereits eifrig darüber diskutiert:

https://forum.shopware.com/discussion/54212/wichtig-paypal-produkte

1 Like

Alles probiert, alle Kombinationen durch.

Es bleibt trotzdem bei dem Fehler " Der Warenkorb hat sich während des Bezahlvorganges geändert. Bitte führen Sie den Zahlungsvorgang erneut aus."

Wir haben sogar versucht über unsere Platin Subsciption bei Shopware unser Kontingent an Entwickler Stunden für die Allgemeinheit zu opfern und auf diesen Bug hingewiesen. Shopware lehnt es jedoch ab, sich darum zu kümmern.

Was soll man jetzt noch tun?! Das Plugin ist damit nutzlos, ein Risiko, Conversionkiller und vergrault die Kunden.

1 Like

Hallo @don‍,

ein Techniker von Shopware hat sich heute unsere Testumgebung angesehen und entdeckt, dass es bei uns daran liegt dass sich durch die Auswahl der Zahlungsart PayPal auch die Versandkostenart ändert. Dadurch fällt das Plugin auf die Standard Versandkostenregel zurück und dadurch kommt es zu einer Differenz bei der tatsächlichen Gesamtsumme.

Ticket: https://issues.shopware.com/issues/PT-9604

An einer Lösung wird wohl bereits gearbeitet.

Beste Grüße,

Dennis

1 Like

Sehr interessant. Danke für die Info. Wir haben auch eine 0€ Abholung vor Ort Versandart. Ich habe diese mal testweise deaktiviert, mal schauen ob das Problem zumindest als hot-fix damit behoben worden ist.

Hallo zusammen,

wie Dennis schon schrieb, arbeiten wir gerade an der Problematik Versandkostenberechnung, auch eine individuelle Berechnung wird berücksichtigt. 

Mit dem nächsten Update sollte das Problem dann behoben sein. 

Viele Grüße aus Schöppingen

cool Michael Telgmann

2 Likes

So zum Verstehen, da ich gerade vor dem Update auf 5.5.1 stehe und das “Alte Paypal” gegen das “Neue” austauschen muss:
Ich habe zwei Versandarten - Versandkostenfrei für bestimmte Artikel und Standardversand. Wählt Kunde nun solch einen Artikel, dann wäre das ja obiges Problem und PayPal fliegt mir um die Ohren => “Neues Paypal” also Unbrauchbar und damit erstmal auf SW 5.4.6 festgenagelt?

1 Like

@sonic schrieb:

So zum Verstehen, da ich gerade vor dem Update auf 5.5.1 stehe und das „Alte Paypal“ gegen das „Neue“ austauschen muss:
Ich habe zwei Versandarten - Versandkostenfrei für bestimmte Artikel und Standardversand. Wählt Kunde nun solch einen Artikel, dann wäre das ja obiges Problem und PayPal fliegt mir um die Ohren => „Neues Paypal“ also Unbrauchbar und damit erstmal auf SW 5.4.6 festgenagelt?

 Sollte am Montag gefixt/released werden. Die Kollegen sind da ja schon dran.

2 Likes

*Push*

Montag ist ja schon was her, und bei Git hat sich auch seit 5 Tagen nichts mehr getan.
Ein Shop mit nicht funtionierendem Zahlungs-Plugin ist auf Dauer dann doch ein wenig sinnfrei  Wink

1 Like

@sonic schrieb:

*Push*

Montag ist ja schon was her, und bei Git hat sich auch seit 5 Tagen nichts mehr getan.
Ein Shop mit nicht funtionierendem Zahlungs-Plugin ist auf Dauer dann doch ein wenig sinnfrei  Wink

Die Änderungen sind auf Github soweit ich weiß schon mit drin.
Wir haben das lediglich noch nicht released, da hier noch ein paar intensivere Tests durchgeführt werden. 

Edit: Ok, also Release kommt zwar jetzt zeitnah eines, weil viele Änderungen schon drin sind. Die Sache mit den Versandkosten ist noch nicht auf Github, da noch nicht komplett. Wird dann kurzfristig nachgeschoben.

2 Likes

Version 1.0.7 ist vor 10 Minuten veröffentlicht worden und hat das Problem bei uns behoben. Ich habe eben eine Testbestellung durchgeführt und die Versandkosten wurden korrekt an PayPal übergeben. Danke @designerno1‍

Hallo,

wir haben auch das update gefahren - soweit so gut (unser Fehler wurde zwar anscheinden noch nicht behoben aber gut) nun haben wir wieder Kauf auf Rechnung (paypalplus) aktiviert - soweit auch gut - er sagt auch in dem kleinen schwarzen Fenster das der webhooks gemacht wurde etc. doch wenn ich in das Logfile schaue kommt der Fehler

PayPal: Could not register webhooks due to a communication failure {„message“:"Client error response

Zahlungen gehen wohl auch durch aber Abbrüche sind wieder da !

Jemand eine Idee was die schöne Meldung heißt - bedeutet

 

Der Webhook ist ja nur für die Synchronisation des Zahlungsstatus, das hat erstmal nichts mit den Abbrüchen im Checkout zu tun. Hier müsstest du selbst einmal checken, in welchem Case es bei dir nicht funktioniert.

Hallo Moritz,

gut das mit den Abbrüchen ist nicht so ganz einfach - ich werde es mal beobachten.

Der Fehler https://issues.shopware.com/issues/PT-9408?search=Paypal&status=1,3,10001,4,10010,10025,10017  war die ganze Zeit auf geplant - jetzt lese ich das er nicht mehr gemacht wird da Ihr es nicht nachstellen könnt. Laut Paypal liegt aber der Fehler im Plugin - gerne sende ich die Kommunikation zu Euch aber dann bitte per Mail :slight_smile:

DANKE

Hallo Matthias,

ich hatte dir dazu ja schon im Ticket einen Kommentar geschrieben  Smile

Leider kam dort keine Rückmeldung. Wir können das Ticket gerne wieder öffnen, wenn wir das Problem nachstellen können, bzw. wenn wir mitgeteilt bekommen, wie man es nachstellen kann. 

Viele Grüße aus Schöppingen

cool Michael Telgmann

Ich habe mal eine Nachricht an dich geschickt mit weiteren Infos usw von Paypal

Danke

Matthias