Paypal Checkout Plugin 4.3.2 und 4.3.3 Abbrüche

Hi,

also jetzt bin ich wirklich langsam am verzweifeln… mir ist soeben wieder aufgefallen das von 4 angemeldeten Benutzern nur einer bestellt hat, was sehr außergewöhnlich ist und die Conversionrate war heute morgen sogar unter 1% was auch sehr seltsam ist.

Also habe ich wieder alles geprüft (ich habe ja sonst nicht zu tun…), dann habe ich das Kaufverhalten in Google Analytics beobachtet und siehe da ein Kunde ist wieder zum Warenkorb und anschließend gab es eine Error Meldung wie folgt:

/checkout/shippingPayment…ypal_unified_error_code/1

Kann mir hier eventuell jemand weiterhelfen ?

PayPal Express ist deaktiviert
Consent Mode ist deaktiviert
Warenkorb übertragen ist deaktiviert
Bestellnummer an PayPal übertragen ist deaktiviert

Das einzige was ich seit gestern Abend wieder aktiv gesetzt habe nachdem laut PayPal das Problem behoben wurde ist der Rechnungskauf.

Das ganze ist wirklich sowas von frustrierenden, da man sozusagen blind fährt und man nicht weiß ob die nächste Zahlung vom Kunden funktionieren wird oder dieser Vorgang abrechen wird. Das einzige was sich ganz sicher berichten kann das seit meiner Umstellung von PayPal Plus auf PayPal Checkout meine Conversionrate um 50% gefallen ist und das ist wirklich heftig !

Bestellnummer übertragen würde ich aktivieren, sonst hast Du keine angelegten Bestellungen im System und kommst nur über Umwege bzw. Plugins schlecht und recht wieder zu einer neuen Bestellbestätigung sollte wer was bestellt haben, bezahlt, das aber bei Dir nicht aufscheinen. und Bestellungen aus den „Abgebrochenen Warenkorb“ wiederherzustellen ist ungenau.

Es kann ja sein dass es lt. Paypal von deren Seite behoben wurde, aber ev. nicht seiten Shopware.

Das mit den Prozentsatz ist wahrscheinlich dem aktuelle Börsenkurs von Paypal geschuldet :slight_smile:

1 Like

Hinweis an die Entwickler:

bei einem meiner WC-Shops ist mir am WE aufgefallen, dass die IPN von Ratepay aka Kauf auf Rechnung NICHT instant erfolgt!

Ich hatte teilweise einen Zeitversatz von 3 Minuten, bis der webhook angesprochen wurde. Das Plugin von Woocommerce ist auch so konzipiert, dass die IPN eben NICHT als instant erwartet wird.

Ich hab jetzt noch nicht in das SW-Plugin reingegeuckt diesbezüglich aber evtl. sollte das Team hier ggf. mal Nachforschungen anstellen.

Hi,

und direkt der nächste Fehler… Kunde hat die Kreditkartenzahlung von PayPal genutzt und eine Bestellung aufgegeben, die Bestellung ist in Shopware vorhanden aber bei PayPasl befindet sich kein Zahlungseingang.

Ich habe den Zahlungsstatus auf Shopware geprüft dieser steht ebenfalls noch auf „offen“ , also habe ich versucht soeben eine Testbestellung auszuführen.

Browser Firefox
Kreditinstitut Deutsche Bank

ich wurde nach dem Kaufvorgang aufgefordert das gaze per Push TAN zu bestätigen, was ich auch gemacht habe und dann sollte man auf der Seite auf weiter klicken, der Button versagt jedoch an dieser Stelle und man wird nicht weitergeleitet.

Das gleiche mit dem Internet Explorer getestet, da hat es dann funktioniert und in Shopware ist der Status bei diesem Vorgang nun auf „komplett bezahlt“ .

Sollte aber eigentlich trotzdem mit beiden Browsern funktionieren und kann mir vielleicht jemand erklären wieso ein Kauf zustande kommt bei welcher der Zahlunsstatus bei Kreditkartenzahlen auf offen steht … ?

Das habe ich nicht ganz verstanden, es gibt meiner Meinung nach nur 2 Möglichkeiten, die Bezahlung funktioniert und der Verkauf wird angelegt oder die Zahlung funktioniert nicht und der Verkauf wird auch nicht angelegt aber das der Verkauf mit einem Zahlungsstatus „offen“ angelegt wird wäre mir jetzt neu.

Bei einem meiner 3 Shops hatte ich vor ca. 1 Woche die Plugins aktualisiert. Unter anderem auch das Paypal 4.3.3. Gestern ist mir erst aufgefallen, dass keine Bestellungen seitdem mehr mit Paypal bezahlt wurden. Bei den anderen beiden Shops mit dem 3.2.0. läuft alles wunderprächtig. Gut dass ich nicht die auch noch vor einer Woche upgedatet habe.
Bei mir läuft Paypal nur komplett im Normalmodus, also kein Express, Rechnung, Raten und das ganze andere Gedöns. Braucht eh kein Mensch.
Ich habe nun die beiden Haken aus „In-Context-Modus verwenden“ und „Warenkorb übertragen“ rausgemacht. Bestellnummer übertragen ist sowieso schon viele Jahre lang deaktiv. :wink:
Habe soeben eine Testbestellung mit Zahlung gemacht. Klappt. Nur der Kundenkommentar aus dem Textfeld der Shopware Bestellabschlussseite wird nicht übertragen. Nicht gut, da dort oftmals Firmen Ihre internen Bestellnummern eintragen, die dann ja automatisch auf den Rechnungsbelegen mit abgedruckt werden. Auch im Backend unter der jeweiligen Bestellung ist im Reiter „Kommunikation“ Kundenkommentare nix drin. Aber wenigstens klappt die Zahlung und Bestellung dann wieder. Als Notlösung vorerst ausreichend. :wink:

Das nur zur Info, dass das deaktivieren der beiden Haken doch was bringt.

Viele Grüße
Matthias

Hallo,
bez. der Kommentare s. den Thread

Das funktioniert hier problemlos
Gruß Helmut

@Balu2020 und @teichpflege
Welche SW Version läuft bei euch bitte?

Hallo Tex,

Bei mir läuft aufgrund einer speziellen Schnittstelle zur Warenwirtschaft gezwungenermaßen noch die Shopware 5.5.3 Build Rev 201810301443 , habe das Security Plugin aktiv was die Patches einspielt.

Moin Sonic,

sorry für die späte Antwort. Gerade getestet und funktioniert einwandfrei

Viele Grüße aus Schöppingen
Michael Telgmann

1 Like

@tex

Ich nutze in allen 3 Shops 5.6.6.
Wir gehen erst auf 5.7. wenn alle Updates durch sind und es mit 5.8. weitergeht.
Auf jeden Fall klappt es mit den 2 ausgeblendeten Haken. Hatte seitdem wieder Bestellungen in dem einen Shop die mit Paypal bezahlt wurden, ohne Probleme. Allerdings hatte sich im Backend nach dem paypal Update auch einiges in den Grundeinstellungen der Zahlarten selber umgestellt. Alles durcheinander. Jede Menge Zahlarten, die zwar inaktiv sind, aber bei den aktiven Zahlarten hat es von selber die Ländereinstellungen durcheinandergeschmissen und auch die Positionsnummer von Paypal war nicht bei 2 sondern -100. Ebenfalls dubios.
Ich werde mich aktuell hüten, bei den anderen beiden Shops auf das neue Paypal upzudaten. Da warten wir lieber ab.
Viele Grüße
Matthias

Was macht Dich so sicher dass 5.8 kommt?

Absolut offtopic, aber zum Thema SW 5.8 bitte folgendes lesen :slightly_smiling_face:

Ich frage gerne nochmals: wann wird es hierfür eine Lösung geben?

1 Like

Hätte ich auch gerne gewusst. Ich habe das Gefühl das die Probleme mit dem Paypal Plugin einfach totgeschwiegen werden, solange bis Niemand mehr fragt. Dazu würde mich mal interessieren wie viele User Shopware 5 einsetzen und wer dann noch von Diesen mit ruhigem Gewissen auf Shopware 6 umsteigt.

Wir nicht. Was ich sehr sehr schade finde. Ehrlich. Ich hab ganz früh angefangen, unser Projekt zu migrieren. Bzw. ich hab’s versucht.

Ich bin seinerzeit an gravierenden Fehlern im Code (Doctrine) und einer löchrigen und fehlerhaften Doku gescheitert.

Wäre spannend gewesen … ich hab für dieses Projekt Plugins mit mehr als 10k Lines of Code geschrieben (nebst Bugfixes am Core - Code!) … aber als die ersten 100 Stunden versenkt waren, war das Thema Shopware 6 bei uns abgehakt.

Wir werden dann zu gegebener Zeit auf ein anderes System umsteigen.

Hallo in die Runde,

SW 5.7.14, PayPal 4.3.3
Vor 4 Wochen SW Cookie Consent durch Plugin von MND ersetzt.
Wegen der Kommentare noch auf 4.3.3 aktualisiert.
Seither keine 404 oder 422.

Jetzt würde mich stark interessieren, ob das Ersetzen des Cookie Consent bei euch auch zum Erfolg führt.
Vielleicht kann das mal jemand im Staging testen und Rückmeldung geben?

Danke

Hallo zusammen,

die Änderungen befinden sich bereits auf GitHub Commits · shopwareLabs/SwagPaymentPayPalUnified · GitHub

Wer mag, kann diese schon testen. Wir sind auch gerade in der QA-Phase und werden ein Update sobald wie möglich releasen.

Viele Grüße aus Schöppingen
Michael Telgmann

Hallo zusammen,

wir haben soeben die Version 5.0.0 der PayPal Integration veröffentlicht.
Die Problematik der doppelten Bestellungen sollte nun nicht mehr auftreten.
Ebenso werden die PAYER_ACTION_REQUIRED Fehler abgefangen.

Viele Grüße aus Schöppingen
Michael Telgmann

Hallo Zusammen,

wir haben heute das PayPal Plugin auf Version 5 geupdatet, und erhalten nun dauerhafte Fehler Mails mit dem selben Inhalt.

Property SwagPaymentPayPalUnified\Models\Settings\General::$sendOrderNumber does not exist

Dieser Fehler kommt beim Kaufabbruch, und beim Löschen eines Artikels im Warenkorb wenn PayPal als Zahlungsmethode ausgewählt wurde.

Ich schau mir das mal von der Seitenlinie an.

image

2 Likes