PayPal 2.7.0 - Fehler nach Update (Shopware 5.5.7)

Hallo

nach Update auf 2.7.0 erscheint folgender Fehler im Frontend. Hat jemand eine Idee? ([@Shopware Developer](http://forum.shopware.com/profile/18563/Shopware Developer “Shopware Developer”)‍)

Ups! Ein Fehler ist aufgetreten!
Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

Property SwagPaymentPayPalUnified\Models\Settings\General::$advertiseReturns does not exist in vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/RuntimeReflectionService.php on line 80
Stack trace:
#0 vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/RuntimeReflectionService.php(80): ReflectionProperty->__construct('SwagPaymentPayP...', 'advertiseReturn...')
#1 vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataInfo.php(964): Doctrine\Common\Persistence\Mapping\RuntimeReflectionService->getAccessibleProperty('SwagPaymentPayP...', 'advertiseReturn...')
#2 vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataFactory.php(721): Doctrine\ORM\Mapping\ClassMetadataInfo->wakeupReflection(Object(Doctrine\Common\Persistence\Mapping\RuntimeReflectionService))
#3 vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/AbstractClassMetadataFactory.php(214): Doctrine\ORM\Mapping\ClassMetadataFactory->wakeupReflection(Object(Doctrine\ORM\Mapping\ClassMetadata), Object(Doctrine\Common\Persistence\Mapping\RuntimeReflectionService))
#4 vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(281): Doctrine\Common\Persistence\Mapping\AbstractClassMetadataFactory->getMetadataFor('SwagPaymentPayP...')
#5 engine/Shopware/Components/Model/ProxyAwareRepositoryFactory.php(56): Doctrine\ORM\EntityManager->getClassMetadata('SwagPaymentPayP...')
#6 vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(698): Shopware\Components\Model\ProxyAwareRepositoryFactory->getRepository(Object(Shopware\Components\Model\ModelManager), 'SwagPaymentPayP...')
#7 custom/plugins/SwagPaymentPayPalUnified/Components/Services/SettingsService.php(73): Doctrine\ORM\EntityManager->getRepository('SwagPaymentPayP...')
#8 custom/plugins/SwagPaymentPayPalUnified/Subscriber/InContext.php(82): SwagPaymentPayPalUnified\Components\Services\SettingsService->getSettings()
#9 engine/Library/Enlight/Event/Handler/Default.php(91): SwagPaymentPayPalUnified\Subscriber\InContext->addInContextButton(Object(Enlight_Controller_ActionEventArgs))
#10 engine/Library/Enlight/Event/EventManager.php(220): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs))
#11 engine/Library/Enlight/Controller/Action.php(208): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs))
#12 engine/Library/Enlight/Controller/Dispatcher/Default.php(563): Enlight_Controller_Action->dispatch('confirmAction')
#13 engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#14 engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch()
#15 vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#16 vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true)
#17 engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#18 vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#19 vendor/symfony/http-kernel/HttpCache/HttpCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#20 engine/Shopware/Components/HttpCache/AppCache.php(143): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#21 vendor/symfony/http-kernel/HttpCache/HttpCache.php(181): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#22 engine/Shopware/Components/HttpCache/AppCache.php(116): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#23 shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))

 

Hallo Max,

kannst du mal versuchen den Cache zu leeren?

Viele Grüße aus Schöppingen

cool Michael Telgmann

Hi Max, 

du solltest mal versuche den CacheOrdner zu löschen. 

Viele Grüße aus Schöppingen

Dennis Garding

 

Hi und danke für die schnelle Antwort,

wir haben jemand rangesetzt, weil es wirklich eilte:

Es scheint, als würde das löschen aller Caches+Kompilieren über das Performance Modul, was meiner Meinung nach der Standardweg für viele Nutzer ist (bzw. nach Update), nicht ausreichen. Es musste über die Console geleert werden + Models update. Vielleicht solltet ihr doch nochmal schauen, ob das ein Problem ist.

VG

Hallo Max,

wir haben hier genau das gleiche Problem nachdem wir gestern das PayPal Update auf die Version 2.7.0 gemacht haben. Wie hast Du das Models Update gemacht?

 

Viele Grüße,

 

Christian

Hallo Christian

Ich habe nur vom Techniker ohne Wissen nachgeplaudert, es sollte aber sein:

php bin/console sw:generate:attributes

gefolgt von

php bin/console sw:cache:clear

1 Like

Hallo Max,

vielen Dank für die schnelle Antwort. Das werde ich gleich ausprobieren.

[@Michael Telgmann](http://forum.shopware.com/profile/17553/Michael Telgmann “Michael Telgmann”)‍ Gibt es hierzu schon eine Lösung von eurer Seite? Das Problem scheint ja kein Einzelfall zu sein.

Viele Grüße,

Christian

Hallo,
aktuell gibt es dazu noch keine Lösung ausser den Inhalt des CacheOrdners zu löschen und eben die Models neu zu generieren.

Wir können momentan das Problem nicht nachstellen. Wenn Alle Update-Schritte durchgeführt werden, also
Update Starten, auf Anfrage Cache leeren und Themes Compilieren Funktioniert es immer.

Sobald wir das Problem nachstellen können wird es natürlich einen Patch geben.

Viele Grüße aus Schöppingen

Dennis Garding

Das klingt nach dem Verhalten was wir auch festgestellt haben bei einem Shop unseres Kunden. Dies tritt nur auf, wenn APCu aktiv ist. ohne APCu no problem.

Übrigens: Das tritt auch bei anderen Plugins auf, z.B. beim deinstallieren. Und anschließend dort, wo das Freitextfeld genutzt wurde, crasht es.

1 Like

Danke für die Info  Thumb-Up
Klingt für mich aber momentan nach einem generellen Problem, als ein spezielles vom PayPal Plugin. Vermutlich müssen wir das im Core beheben.

Viele Grüße aus Schöppingen

cool Michael Telgmann

@codeenterprise‍

Vielen Dank für die APCu-Info. Wir hatten nach einem PayPal-Update ebenfalls den  Fehler

Property SwagPaymentPayPalUnified\Models\Settings\General::$advertiseReturns does not exist ...

und in der Folge weitere Störungen auf der Site. Models neu generieren und Cache löschen per console änderte nichts, ohne APCu läuft alles problemlos.
VG