Noch mehr Fehlermeldungen in 5.1 :(

leider bekomme ich noch immer fehlermeldungen beim cache aufwärmen von artikeln die deaktiviert sind: Warm up http-cache error with shopId 1 Client error response [url] https://XXX/dekoration/98/teelichthalter-set-mit-deko-steinen-hoehe-8-cm [status code] 404 [reason phrase] Not Found 2015-10-20T06:19:56.348268+0200 core { "uri": "/backend/Performance/warmUpCache/resource/article", "method": "POST", "query": { "module": "backend", "controller": "Performance", "action": "warmUpCache", "resource": "article" }, "post": { "shopId": "1", "offset": "1910", "limit": "10" } } { "userId": "50", "roleId": "1" } No shop data available es handelt sich hierbei um artikel die erst später aktiviert werden sollen und aus diesem grund schon angelegt sind. leider kommen mit dem update auch neue fehlermeldungen hinzu: Legacy media url detected. 2015-10-20T06:23:54.117808+0200 core { "requestedUrl": "/media/image/thumbnail/17-611956-00\_1280x1280.jpg", "redirectedTo": "https://xxx/media/image/f9/02/97/17-611956-00\_1280x1280.jpg" } { "uri": "/media/image/thumbnail/17-611956-00\_1280x1280.jpg", "method": "GET", "query": { "controller": "Media", "action": "fallback", "module": "frontend", "thumbnail": "17-611956-00\_1280x1280.jpg" }, "post": [] } { "sessionId": "1aad15b48eac9a5383b13425565a5d160b937a81", "Bot": null } 1 Hauptshop Deutsch obwohl es die bilder dort gibt. auch stört es mich, dass ich im backend in der artikelübersicht nicht nach EAN suchen kann. warum kann ich denn nicht in den feldern suchen, die ich in der anzeige aktiviert habe… gibt es da ne lösung?

Die Fehlermeldungen von deaktivierten Artikeln, erhalte ich leider auch immer noch sobald der warm up cache angestoßen wird. Gesendet von meinem MX4 mit Tapatalk

Zur Info: Bei mir ist es auch so ;( SW 5.1.0

Ja, beide Meldungen haben nicht viel zu bedeuten. Die 2. Meldung wurde extra in Shopware 5.1 hinzugefügt, damit man die alten Bild-Links auf die neue Struktur migrieren kann. :wink: Das passiert nicht überall automatisch und daher bekommt man am Anfang noch die genannten Meldungen. Mit der Zeit sollten es weniger werden, da z.B. mit dem Speichern des TinyMCE-Felds die Bilder automatisch migriert werden. Es ist aber nicht nur der TinyMCE. Es kann genauso gut von eigene Plugin/Template-Anpassungen kommen. :slight_smile: Gruß Heiner

Hallo, ich möchte noch etwas anfügen, das wird hier gerne falsch verstanden. Die Funktion “Fehler an Shopbetreiber senden” ist für ein Debugging gedacht und nicht um den Shop zu überwachen. Ihr werdet immer wieder Meldungen bekommen die den Shopablauf in keinster Weise beeinflussen, aber im Hintergrund erzeugt werden. Nicht jede Mail die dann kommt, bedeutet auch gleichzeitig, dass ein Fehler vorliegt! Um einen spezifischen Fehler zu debuggen ist es natürlich dennoch wichtig, dass diese Meldungen ausgegeben werden. Es macht keinen Sinn, die Funktion ständig aktiv zu haben. Moritz

ist ja alles schön und gut, aber da ich solche meldungen nicht an eine andere mail schicken kann, landen die fehlermeldungen samt bestellungen bei unseren damen im büro. wenn es hier die möglichkeit geben würde fehlermeldungen an eine andere mailadresse schicken zu können wäre das schon ein fortschritt und hilfe für mich (vielleicht auch für andere).

1 Like

Hallo, du musst das ja nicht nutzen. Du kannst auch in den Log Ordner schauen. Shopware schreibt Meldungen auch in die Logs. Wenn du dennoch die Mail haben möchtest, so kannst du bei den meisten Mailprogrammen auch Verteil-/Weiterleitungsregeln anlegen. Sebastian

da bin ich bestimmt der einzige der fehlermeldungen gerne per mail hätte. für wen programmiert ihr denn shopware? ich bin noch nicht überzeugt den shop zu kaufen. ganz ehrlich wäre die zusendung von fehlermails zu einer wunschadresse in meinen augen auch kein riesen ding. in der tabelle s_core_config_values als element_id 954 steht ja (bzw. ist dort hinterlegt) ob fehlermeldungen an den shopbetreiber gesendet werden sollen oder nicht. den eintrag entsprechend mit ner eMail zu erweitern die zum versenden verwendet werden kann, ist doch nun wirklich kein grosser aufwand. für webmaster aber ne erleichterung, wie ich finde. shopbetreiber die lediglich bestellungen, also tagesgeschäft, erledigen und den shop von einer agentur oder was auch immer betreuen lassen wollen diese fehlermeldungen nicht. und agenturen oder was auch immer wollen diese tagesgeschäfts-mails nicht. ich kann im outlook lediglich regeln erstellen zum verteilen in jeweilige ordner, aber nicht das die jeweilige mail woanders hin geschickt wird. serverseitig kann ich mails lediglich global weiterleiten… und nun?

Hallo Wenna, meine Anwort bezieht sich nur auf die aktuellen Möglichkeiten. Der Versand ist ja eine optionale zusätzliche Funktion. Zum Aufwand das zu ändern habe ich nichts gesagt, Wir sind da ja total offen was Änderungen/Verbesserungen angeht. Schlag das doch gerne als Verbesserung vor unter http://jira.shopware.de Dann haben wir das richtig vorliegen Sebastian