Neue Version Migrationsassistent

Ich habe gerade die neue Version des Migrationsassistenten PlugIns installiert. Nun ist meine Konfiguration weg. In der Datenbank noch vorhanden im BE aber weg.

Ist das so gewollt?

Grüsse

 

und eine neue Verbindung kann ich auch nicht anlegen, da kommt:

  1. {errors: [{code: “0”, status: “500”, title: “Internal Server Error”,…}]}
  2. errors: [{code: “0”, status: “500”, title: “Internal Server Error”,…}]
    1. 0: {code: “0”, status: “500”, title: “Internal Server Error”,…}
    1. code: “0”
    2. detail: “Argument 9 passed to SwagMigrationAssistant\Migration\Run\RunService::__construct() must implement interface Shopware\Core\Framework\DataAbstractionLayer\EntityRepositoryInterface, instance of Shopware\Core\Framework\DataAbstractionLayer\Indexing\MessageQueue\IndexerMessageSender given, called in /var/www/vhosts/neu.shoppet.ch/httpdocs/xyxyxy/var/cache/prod_k6911cee2_p525306e8/ContainerCmx2E7G/getRunServiceService.php on line 32”
    3. status: “500”
    4. title: “Internal Server Error”

@aqula schrieb:

  1. {errors: [{code: „0“, status: „500“, title: „Internal Server Error“,…}]}
  2. errors: [{code: „0“, status: „500“, title: „Internal Server Error“,…}]
  3. 0: {code: „0“, status: „500“, title: „Internal Server Error“,…}
  4. code: „0“
  5. detail: „Argument 9 passed to SwagMigrationAssistant\Migration\Run\RunService::__construct() must implement interface Shopware\Core\Framework\DataAbstractionLayer\EntityRepositoryInterface, instance of Shopware\Core\Framework\DataAbstractionLayer\Indexing\MessageQueue\IndexerMessageSender given, called in /var/www/vhosts/neu.shoppet.ch/httpdocs/xyxyxy/var/cache/prod_k6911cee2_p525306e8/ContainerCmx2E7G/getRunServiceService.php on line 32“
  6. status: „500“
  7. title: „Internal Server Error“

Bitte clear nochmal den Cache per Konsole. 

Habe den ganzen cache ordner schon gelöscht…

Nochmals alles gelöscht, jetzt geht’s wieder!

@aqula schrieb:

Nochmals alles gelöscht, jetzt geht’s wieder!

Okay… Was anderes hätte mich auch gewundert. 

1 Like

Aber die Performance ist massiv schlechter mit der neuen Version, was vorher einige Sekunden/wenige Minuten gadauert hat läuft jetzt schon über 15 Minuten

In der neuen Version wurde nur der Abschluss der Migration geändert, daher sollten die anderen Request nicht davon betroffen sein…
Ist vielleicht ein Request-Fehler in der Chrome-Console?

Hallo @Krispin‍,

wir haben die Community Edition v6.3.2.1 per Installer auf unserem Webspace installiert und wollten mit dem aktuellen Migrationsassistenten (v2.1.2) von Shopware 5 migrieren.
Wir erhalten jedoch gleiche Fehlermeldung in unserem Browser und in der Browser-Konsole wenn wir eine Verbindung zum DB-System von Shopware 5 herstellen wollen. Cache leeren mithilfe der Shopware-Backend-Option und auch manuell des Inhaltes von Ordner /var/cache/ hat leider zu keiner Besserung beigetragen.

Fällt dir sonst noch ein, was ich probieren könnte?

Viele Grüße

EDIT: folgende Antwort steht im HTTP-Header auch noch "An exception occurred in driver: SQLSTATE[HY000] [1203] User o755783 already has more than ‚max_user_connections‘ active connections"
Ich gehe deswegen von meinem Webspace-Anbieter als Fehlerursache aus.

EDIT 2: Habe gerade Shopware 6 bei einem anderen Anbieter aufgesetzt. Hier funktioniert die Einrichtung des Migrationsassistenten, auch wenn ich jetzt beim nächsten Problem hänge (https://forum.shopware.com/discussion/65807/migrationsassistent-ueber-api-es-wurden-keine-daten-zum-migrieren-gefunden)

Fazit: Ionos (1&1) scheint definitiv nicht der richtige Anbieter zu sein, um Shopware zu hosten :smiley: