Nach Update auf 5.7.8 - Navigation im Frontend (Shop) defekt

Hallo,
nach dem Update ist die Navigation defekt. Es wird immer die Kategorie links neben der angeklickten Kategorie angezeigt.
Kann mir da bitte jemand einen Tip geben
(www.strickzeit.com)
Einkaufswelten sind aktiv
Danke im Voraus
Liebe Grüße und frohe Ostern
Eva

PS: an Einkaufswelt kann es nicht liegen. Hab es mal deaktiviert. Fehler bleibt bestehen

Der Fehler wird mit Shopware 5.7.9 behoben: Shopware Issuetracker

Hallo und danke für die Antwort
Nachdem der Shop so nicht bleiben kann, nehme ich ihn vom netz.
Wann kommt bitte die Version 5.7.9
LG Eva

Hallo,

kannst Du wie folgt lösen:

Diese Stelle: shopware/RewriteGenerator.php at v5.7.8 · shopware/shopware · GitHub mit folgenden Fix ersetzen

Viele Grüße

Probiere mal folgenden Fix aus:

SEO-Index-Problem in den Einkaufswelten - Shopware 5 / Administration - Shopware Community Forum

Hallo, das bringt leider auch nichts.
Warum wird eigentlich nicht vorab richtig getestet?
Gerade das Ostergeschäft hätte ich gerne mitgenommen

2 Likes

Cache geleert und Theme neu kompiliert?

Damit hast geklappt

Vielen lieben Dank

Wo ist denn der Fix?
Die Links hier verweisen nur auf den Shopware 5.7.8-Zweig, welcher den Fehler enthält?
Bei so einem groben Patzer sollte Shopware die korrigierte Datei als Fix bereitstellen. So ist das sehr unprofessionell.

Hallo,

die o.a. Code-Zeilen sind der Fix.

Viele Grüße

Sorry, aber das löst das Problem bei mir nicht. Ich habe bereits einmal die betreffende Datei vom Server geladen und ein Diff gemacht, da ist in den Zeilen 119-122 kein Unterschied. Caches wurden bereits geleert, Kategoriebaum neu aufgebaut, der SEO-Index neu generiert das Theme neu kompiliert.

Bei uns das selbe Problem, der Fix Zeile 119-122 hat nicht geholfen bzw. das steht bereits so im File drin.

### Ticket: SW-26644 | Menüreiter im Frontend nicht funktionsfähig, dies sollte für das Update 5.7.9 umgesetzt sein.
Doch wir können nicht warten - Könnte uns jemand den Fix vorab zu Verfügung stellen?

1 Like

Ihr müsst azs Version 5.7.7 das rauskopieren.
Dann gehen Kategorien wieder.


        $urls = $this->rewriteList($orgPathList, $context);
        if (empty($urls) || max($urls) === false) {
            return $urls;
        }
5 Likes

Hallo Nurich,
vielen Dank für Deine schnelle Hilfe - es ist perfekt, jetzt läuft es wieder :slightly_smiling_face:
Gruss Jakob

Vielen Dank, nurich, das funktioniert!
Unser Shop-Entwickler lag gleichzeitig mit Corona flach und bei Profihost der Support konnte gleichzeitig nicht einmal über die Feiertage ein Backup wieder einspielen. Einmal mit Profis arbeiten…

Shopware sollte einmal eruieren, wie es sein kann, dass so ein Klopper vor Feiertagen SO rausgehen kann. Ein Unding, eine Marketing-Aktion zu Ostern mussten wir daher ausfallen lassen. Wir hadern ja noch mit Shopware 6, da sind ja derzeit noch mehr Bugs drin. So langsam entsteht da der Eindruck von systemischen Fehlern im Ökosystem „Shopware AG“, unabhängig von der Version.

@KaffeeService24 :

Vielleicht solltest Du Dir meine anderen Beiträge hier im Forum anschauen, bevor es zu irgendwelchen Unterstellungen kommt. In Deinem Profil kann ich jedenfalls keine Hilfestellungen für andere Benutzer erkennen.

Viele Grüße

Warum sollte ich ein Interesse an Deinen sonstigen Beiträgen haben? Du hast Dich zu diesem Thema hingestellt und behauptet „Das ist der Fix!“ und das war nur der Ort des Problems, nicht dessen Lösung. Woraus leitest Du Unterstellungen ab? Ich stelle nur eine Frage, das sollte erlaubt sein, oder?

Nur zur Info, wie Dein Beitrag im Forum angezeigt wird:


Hattest Du ggf. die CODE-Tags im Beitrag vergessen, so dass man nichts sah?

Ich bin kein ITler, daher gebe ich auch keine Hilfestellungen zu IT-Fragen. Aber Deine Reaktion passt. Schönen Tag noch.

Grundsätzlich sollte man sich abgewöhnen vor längeren Feiertagen seinen Shop zu Updaten. Macht dies besser NACH den Feiertagen. Bei einem Update kann immer etwas schief gehen und das muss nicht zwangläufig immer an Shopware liegen!

Richtig, üblicherweise warten wir mindestens 1-2 Wochen oder länger, da ja auch nicht immer alle Plugins gleich kompatibel sind. Dieses Mal ausnahmsweise nicht und gleich ein „Volltreffer“.
Der Fehler trat ja offenbar bei mehreren auf und läßt sich auf eine Code-Zeile zurückführen, die sich von 5.7.7 zu 5.7.8 geändert hat. Den Code vom Core schreiben ja nicht wir als Shopbetreiber.

Jedenfalls überlegen wir nun, ob wir zukünftig nicht zuätzlich eine Staging-Umgebung nutzen. Und auf welche Software wir setzen werden, wenn Shopware 5 in absehbarer Zeit nicht mehr supportet wird.

2 Likes

Man sollte sich prinzipiell abgewöhnen in einem laufenden Shop Updates einzuspielen die man nicht braucht.

Auch mich erwischt es immer wieder, zb. mit dem neuen Paypal 4 Plugin. Nächstesmal hacke ich mir einen Finger ab als Beispiel für die Zukunft :upside_down_face:

1 Like