Nach Update auf 5.2 lässt sich das Theme nicht mehr kompilieren

Hallo,

ich habe eben das Update auf 5.2 eingespielt. Seither kann ich das Theme nicht mehr kompilieren.

Es kommt die Meldung 1 Theme gefunden, danach erscheint bearbeite Shop und das wars.

Ich verwende das Standard Theme von Shopware 5.

Was kann ich machen?

Habe dasselbe Problem mit dem RC3 der 5.2

Hi,

bitte schaut in eure Log Dateien unter /var/log/core_*.log.

Kontrolliert auch bitte ob Ihr plugins installiert habt, welche sich in die Kompilierung einhägen um weitere Styles/Javascript Extensions im Frontend zu laden. 

Im Standard lässt sich das Theme kompilieren und ohne genauere Fehlerbeschreibung können wir euch leider nicht helfen.

Gruß Oliver

Ich habe zu Testzwecken neu installiert und keine Plugins installiert.

Danke schon mal für die Antwort.

Bei mir im log steht das:
 

[2016-07-04 01:46:18] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Hundebett-DOGSTYLE-Dream-Softline-Groessentabelle.jpg","redirectedTo":"https://www.livaro.de/media/image/cb/e8/c0/Hundebett-DOGSTYLE-Dream-Softline-Groessentabelle.jpg"} {"uid":"8ee4624"}
[2016-07-04 04:33:26] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/pdf/Widerrufsformular.pdf","redirectedTo":"https://www.livaro.de/media/pdf/e8/8c/58/Widerrufsformular.pdf"} {"uid":"9dce7b1"}
[2016-07-04 05:32:39] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Esstisch-Norwin_xs.jpg","redirectedTo":"https://www.livaro.de/media/image/99/2c/94/Esstisch-Norwin_xs.jpg"} {"uid":"3cb10bd"}
[2016-07-04 14:07:23] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/herstellung-esstische.jpg","redirectedTo":"https://www.livaro.de/media/image/18/5a/b9/herstellung-esstische.jpg"} {"uid":"24d80db"}
[2016-07-04 14:07:27] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/herstellung-esstische.jpg","redirectedTo":"https://www.livaro.de/media/image/18/5a/b9/herstellung-esstische.jpg"} {"uid":"e04c7c8"}
[2016-07-04 15:31:46] core.ERROR: exception 'Enlight_Controller_Exception' with message 'Action "Widgets_Index_indexAction" not found failure' in /www/htdocs/w006e6bf/livaro/engine/Library/Enlight/Controller/Action.php:402 Stack trace: #0 /www/htdocs/w006e6bf/livaro/engine/Library/Enlight/Controller/Action.php(159): Enlight_Controller_Action->__call('indexAction', Array) #1 /www/htdocs/w006e6bf/livaro/engine/Library/Enlight/Controller/Action.php(159): Shopware_Proxies_ShopwareControllersWidgetsIndexProxy->indexAction() #2 /www/htdocs/w006e6bf/livaro/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('indexAction') #3 /www/htdocs/w006e6bf/livaro/engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #4 /www/htdocs/w006e6bf/livaro/engine/Shopware/Kernel.php(175): Enlight_Controller_Front->dispatch() #5 /www/htdocs/w006e6bf/livaro/vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #6 /www/htdocs/w006e6bf/livaro/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #7 /www/htdocs/w006e6bf/livaro/vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #8 /www/htdocs/w006e6bf/livaro/vendor/symfony/http-kernel/HttpCache/HttpCache.php(275): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #9 /www/htdocs/w006e6bf/livaro/engine/Shopware/Components/HttpCache/AppCache.php(133): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #10 /www/htdocs/w006e6bf/livaro/vendor/symfony/http-kernel/HttpCache/HttpCache.php(206): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #11 /www/htdocs/w006e6bf/livaro/engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #12 /www/htdocs/w006e6bf/livaro/shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #13 {main} [] {"uid":"43e8049"}
[2016-07-04 16:02:23] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Bronzeguss1.jpg","redirectedTo":"https://www.livaro.de/media/image/85/e2/2e/Bronzeguss1.jpg"} {"uid":"ed1d5bd"}
[2016-07-04 16:02:23] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Bronzeguss2.jpg","redirectedTo":"https://www.livaro.de/media/image/ea/84/1c/Bronzeguss2.jpg"} {"uid":"827c930"}
[2016-07-04 16:02:24] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Bronzeguss3.jpg","redirectedTo":"https://www.livaro.de/media/image/9e/e4/21/Bronzeguss3.jpg"} {"uid":"9dc413a"}
[2016-07-04 16:02:24] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Bronzeguss4.jpg","redirectedTo":"https://www.livaro.de/media/image/f7/4f/5a/Bronzeguss4.jpg"} {"uid":"064c0ce"}
[2016-07-04 16:02:24] core.ERROR: Legacy media url detected. {"requestedUrl":"/media/image/Patinierung.jpg","redirectedTo":"https://www.livaro.de/media/image/4d/37/f8/Patinierung.jpg"} {"uid":"709bc28"}

 

Hallo,

die Log-Einträge helfen erstmal nicht weiter und haben mit der Theme-Compilierung nichts zu tun. Sonst müsstet ihr mal schauen per Debug-Konsole des Browsers ob dort eine Fehlermeldung als Antwort auf den Request zurück gegeben wird.

Moritz

Hmm, ich sehe da so nichts leider :frowning:

Muss es denn etwas mit einem Plugin zu tun haben?

Es kann auch etwas mit deinen individuellen Theme-Anpassungen und/oder Theme-Einstellungen zu tun haben. Allgemein kann man das einfach nicht sagen.

Arghhh, na super :frowning:

Ich erhalte Folgende Meldung in der Konsole:

ext-all.js?201606290954:21 POST http://domain.de/backend/cache/themeCacheWarmUp 503 (Service Unavailable)

request@ext-all.js?201606290954:21request@base?file=bootstrap&loggedIn=1467644133:1600runRequest@/backend/Index/load/?f=m/Widget|m/WidgetSettings|m/Turnover|m/Batch|m/Customers|m/Visitors|m/Orders…:3196onThemeCacheWarmUpStartProcess@/backend/Index/load/?f=m/Widget|m/WidgetSettings|m/Turnover|m/Batch|m/Customers|m/Visitors|m/Orders…:3164fire@ext-all.js?201606290954:21dispatch@base?file=bootstrap&loggedIn=1467644133:657fireEvent@ext-all.js?201606290954:21handler@/backend/Index/load/?f=m/Widget|m/WidgetSettings|m/Turnover|m/Batch|m/Customers|m/Visitors|m/Orders…:2348fireHandler@ext-all.js?201606290954:21onClick@ext-all.js?201606290954:21(anonymous function)@VM475:6g@ext-all.js?201606290954:21

und

ext-all.js?201606290954:21 Uncaught Ext.JSON.decode(): You're trying to decode an invalid JSON String: 503 Service Unavailable

raise@ext-all.js?201606290954:21Ext.JSON.me.decode@ext-all.js?201606290954:21callback@/backend/Index/load/?f=m/Widget|m/WidgetSettings|m/Turnover|m/Batch|m/Customers|m/Visitors|m/Orders…:3206callback@ext-all.js?201606290954:21onComplete@ext-all.js?201606290954:21onStateChange@ext-all.js?201606290954:21(anonymous function)@ext-all.js?201606290954:21

 

Hallo,

das sind keine Fehlermeldungen.

Schau mal in die Response/Antwort des POST http://domain.de/backend/cache/themeCacheWarmUp 

 

Moritz

Ich habe gerade alle Plugins deaktiviert und rausgenommen.

Jetzt kann ich kompilieren.

Werde jetzt leider Stück für Stück die Plugins wieder neu installieren und konfigurieren und dann mal schauen, woran es hakt.

Muss ja demnach ein Plugin sein.

Ich hatte das selbe Problem mit einer frischen Installation.

Hatte nur 2 Plugins installiert:

  • PayPal
  • Cookie Hinweis

Also wird es wahrscheinlich an einen von den beiden liegen.
 

Habe auch das Problem.

[2016-07-04 20:44:20] core.ERROR: exception 'Shopware\Components\CSRFTokenValidationException' with message 'The provided CSRF-Token is invalid. If you're sure that the request should be valid, the called controller action needs to be whitelisted using the CSRFWhitelistAware interface.' in /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Components/CSRFTokenValidator.php:108 Stack trace: #0 [internal function]: Shopware\Components\CSRFTokenValidator->checkBackendTokenValidation(Object(Enlight_Controller_ActionEventArgs)) #1 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #2 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #3 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Controller/Action.php(143): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs)) #4 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('themeCacheWarmU...') #5 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #6 /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Kernel.php(175): Enlight_Controller_Front->dispatch() #7 /homepages/22/d367730654/htdocs/bygenashop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #9 /homepages/22/d367730654/htdocs/bygenashop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #10 /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #11 /homepages/22/d367730654/htdocs/bygenashop/shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #12 {main} [] {"uid":"e56eceb"}
[2016-07-04 21:04:53] core.ERROR: exception 'Shopware\Components\CSRFTokenValidationException' with message 'The provided CSRF-Token is invalid. If you're sure that the request should be valid, the called controller action needs to be whitelisted using the CSRFWhitelistAware interface.' in /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Components/CSRFTokenValidator.php:108 Stack trace: #0 [internal function]: Shopware\Components\CSRFTokenValidator->checkBackendTokenValidation(Object(Enlight_Controller_ActionEventArgs)) #1 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #2 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #3 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Controller/Action.php(143): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs)) #4 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('themeCacheWarmU...') #5 /homepages/22/d367730654/htdocs/bygenashop/engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #6 /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Kernel.php(175): Enlight_Controller_Front->dispatch() #7 /homepages/22/d367730654/htdocs/bygenashop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #9 /homepages/22/d367730654/htdocs/bygenashop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #10 /homepages/22/d367730654/htdocs/bygenashop/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #11 /homepages/22/d367730654/htdocs/bygenashop/shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #12 {main} [] {"uid":"66736aa"}

Kann damit überhaupt nichts anfangen Crying

@Patrick_B‍, bitte lösche einmal deinen Browser Cache und lade das Backend neu. Wenn das Problem weiterhin besteht, beschreibe bitte kurz was genau du tust und welche Plugins du zusätzlich installiert hast.

@sh1n‍, ich habe die beiden Plugins nun auch installiert aber kann den Fehler nach wie vor nicht nachstellen. Kannst du auch einmal in deine Logs schauen und die hier posten?

1 Like

Hallo,

ich hatte dasselbe Problem - sollte an PayPal liegen. Als ich das Plugin deaktiviert hatte und den gesamten Cache aufgeräumt hatte, war wieder alles in Ordnung. Tendentiell rate ich aber davon ab, das Update zu installieren. Zum Einen ist das Pickware Addon wieder rausgenommen worden und zum anderen gab es viele Anzeigefehler. Ich denke es lohnt sich, hier auf das 5.2.1 Update zu warten.

 

Viele Grüße

Hallo Julian,

im aktuellen 5.2.1 Paket konnte ich kein Problem mit Paypal feststellen. Könntest du das noch einmal gegen testen und ggf. dich noch mal melden?

Viele Grüße aus Schöppingen

cool Michael Telgmann

1 Like

Gleiches Problem auch hier. Theme kompilieren klappt nicht mehr. Hat schon jemand eine Lösung an welchem Plugin es liegen könnte?

 

EDIT: Bei uns ist es auch das Paypal Plugin!! Wenn wir es deaktivieren klappt das kompilieren!

Browser Cache habe ich schon gefühlte 100 mal gelöscht.

Ich habe alle Plugins Deinstalliert mein eigenes Theme gelöscht und jetzt gerade das Update auf 5.2.1 gemacht.

Das Problem besteht immer noch. Theme lässt sich nicht kompilieren

Hi,

welche Version des Paypal Plugins nutzt ihr denn?

Viele Grüße aus Schöppingen

cool Michael Telgmann

1 Like