Nach Update 5.1.1 expected expression, got '<' Plugin Manage

Hallo, seit dem Update auf 5.1.1 lässt sich der Plugin Manager nicht mehr starten. Beim Starten kommt [code]Ext.globalEval

Niemand eine Idee? Serverplatz ist es nicht. Hab gerade aufgeräumt.

Hallo, die Meldung unten kommt ja erstmal vom Paypal Plugin. Hast du das mal gelöscht über FTP und dann nochmal getestet? Grüße Moritz

Wie lösche ich das? Ist doch sicher nicht nur der Ordner zu löschen. Gruß Mario

Hallo, bei Paypal kannst du das ruhig machen, dass kann man danach auch wieder installieren. Natürlich vorher dennoch ein Backup machen! Ansonsten wüsste ich so auch erstmal keine Lösung. Moritz

Ordner löschen bzw. umbenennen löst das Problem nicht, ändert nur die Fehlermeldung. Das Plugin verursacht dann ein 503.

Kann wirklich niemand helfen? So kann ich keine Plugins mehr installieren oder deinstallieren. Wie kann ich denn über FTP das Paypalplugin raus nehmen, damit der Pluginmanager wieder startet? Gruß Mario

Hallo, wenn du das restlos über FTP löschst, dann kann es auch keinen Fehler mehr verursachen. Es kann ja in diesen beiden Ordnern sein: /engine/Shopware/Plugins/Community/Frontend/SwagPaymentPaypal /engine/Shopware/Plugins/Default/Frontend/SwagPaymentPaypal Wenn das komplett gelöscht ist, muss da auch eine andere Fehlermeldung kommen, wenn es dann nicht wieder läuft. Die neue Melduing kann dann auch nix mehr mit dem Plugin zu tun haben. Moritz

Den SwagPaypal Ordner gibt es nur in Default Wenn ich diesen umbenenne kommt als Fehlermeldung: **Fatal error** : Class 'Shopware\_Plugins\_Frontend\_SwagPaymentPaypal\_\_\_Bootstrap' not found in **/var/www/web28/html/shopware989sklflsej/engine/Shopware/Components/Plugin/Namespace.php** on line **264** 503 Service Unavailable Der Pluginmanager startet trotzdem nicht.

Hallo, Umbenennen bringt da nix. Bitte mal entweder verschieben ins Root Verzeichnis des Shops oder ganz löschen. Hauptsache nicht mehr im Engine Ordner. Moritz

1 Like

DANKE! Das klappt. Verstehe zwar nicht, warum Umbenennen nicht klappt…aber mit Löschen ging es.

Hallo, der Plugin-Manager ließt beim Start alle Dateien aus dem Plugin-Ordner ein. Wenn die Dateien jetzt das Problem machen, dann wird beim einlesen natürlich dennoch auch der umbenannte Ordner eingelesen und das Problem bleibt. Plugins müssen immer aus dem Ordner entfernt werden, ein umbenennen hilft da also nix. Moritz