Mails versenden in einem lokalen Entwicklungs-Shop

Hallo Zusammen,

Einfache Frage: Was muss ich konfigurieren, damit ich in einem lokalen Entwicklungs-Shop (z.B. in einer Vagrant Umgebung) Mails versenden kann?

In der .env Datei steht aktuell MAILER_URL=null://localhost
In der Mailer-Konfiguration steht der Bevorzugte Mail-Agent aktuell auf “Umgebungs-Konfiguration benutzen”.

Gibt es überhaupt eine solche Möglichkeit oder benötigt man zwingend einen laufenden SMTP-Mailer?

 

Viele Grüße
Dennis

1 Like
  1. Vagrantfile anpassen

    DNS Server

    config.vm.network „forwarded_port“, guest: 53, host: 53, protocol: „udp“
    config.vm.network „forwarded_port“, guest: 53, host: 53, protocol: „tcp“

    SMTP

    config.vm.network „forwarded_port“, guest: 25, host: 25

    IMAP SSL

    config.vm.network „forwarded_port“, guest: 587, host: 587, protocol: „tcp“

    IMAP4 SSL

    config.vm.network „forwarded_port“, guest: 993, host: 993, protocol: „tcp“

    POP3 SSL

    config.vm.network „forwarded_port“, guest: 995, host: 995, protocol: „tcp“

  2. .env MAILER_URL anpassen

    MAILER_URL=smtp://user:pass@host:587?encryption=tls

  3. Absender E-Mail hier eintragen: /admin#/sw/settings/basic/information/index

1 Like

Willst du denn Mails verschicken oder dir nur ansehen ob sie raus gehen und wie die aussehen?
Lokal benutze ich immer mailhog: GitHub - mailhog/MailHog: Web and API based SMTP testing

2 Likes

@Moritz Naczenski schrieb:

Willst du denn Mails verschicken oder dir nur ansehen ob sie raus gehen und wie die aussehen?
Lokal benutze ich immer mailhog: https://github.com/mailhog/MailHog

 Grundsätzlich geht es erstmal nur darum, wie die Mails aussehen, aber es wäre natürlich auch Top, wenn man direkt sieht ob der Versand funktioniert.

@Moorleiche schrieb:

  1. Vagrantfile anpassen

DNS Server

config.vm.network “forwarded_port”, guest: 53, host: 53, protocol: “udp”
config.vm.network “forwarded_port”, guest: 53, host: 53, protocol: “tcp”

SMTP

config.vm.network “forwarded_port”, guest: 25, host: 25

IMAP SSL

config.vm.network “forwarded_port”, guest: 587, host: 587, protocol: “tcp”

IMAP4 SSL

config.vm.network “forwarded_port”, guest: 993, host: 993, protocol: “tcp”

POP3 SSL

config.vm.network “forwarded_port”, guest: 995, host: 995, protocol: “tcp”

  1. .env MAILER_URL anpassen

MAILER_URL=smtp://user:pass@host:587?encryption=tls

  1. Absender E-Mail hier eintragen: /admin#/sw/settings/basic/information/index

Das werde ich mal ausprobieren, Danke!

@compragmbh schrieb:

@Moritz Naczenski schrieb:

Willst du denn Mails verschicken oder dir nur ansehen ob sie raus gehen und wie die aussehen?
Lokal benutze ich immer mailhog: https://github.com/mailhog/MailHog

 Grundsätzlich geht es erstmal nur darum, wie die Mails aussehen, aber es wäre natürlich auch Top, wenn man direkt sieht ob der Versand funktioniert.

Das macht Mailhog auch, das simuliert einen SMTP. Hat eine Weboberfläche um Mails anzuzeigen.

 

In der Mailhog-Dokumentation ist SMTP erwähnt, allerdings bleiben mir die Zugangsdaten unklar, die dann in Shopware einzustellen sind.

Alternativ kann Mailhog ja per Sendmail betrieben werden, dazu habe ich laut deren Doku in der php.ini ergänzt:

sendmail_path = '/usr/local/bin/Mailhog sendmail mailhog@mail.com'

und konnte dann mit dem mail -Befehl von PHP eine E-Mail an Mailhog versenden.

Wenn ich aber in Shopware (*) „Sending method: mail“ eingebe, geht leider keine Mail raus:

Unable to send mail.  at /var/www/html/engine/Library/Zend/Mail/Transport/Sendmail.php:134)

Update: Sorry für die falsche Rubrik. Wie die Fehlermeldung zeigt, versuche ich gerade, das mit Shopware 5 zum laufen zu kriegen. Google hielt diesen Beitrag für relevant und ich habe die Rubrik nicht beachtet. Hier ist mein Post im passenden Forum: Lokale E-Mail-Einstellungen für Mailhog in Shopware 5

Update 2: Im Zweifel hilft es immer, nach jeglicher Konfigurationsänderung den Cache zu leeren.

Grundsätzlich geht es erstmal nur darum, wie die Mails aussehen, aber es wäre natürlich auch Top, wenn man direkt sieht ob der Versand funktioniert.