Logo passt sich nicht an

Hallo,

ich möchte im Header ein Logo der Größe 375x100px integrieren.
Obwohl ich das Plugin von "8mylez"nutze wird mir das Ausgangs-Logo 375x100px auf 188x56 px heruntergerendert.
Cache wurde selbstevrständlich vorher nochgelöscht und das Theme neu kompiliert. 
Keine Änderung, das Logo wird immer wieder verkleinert dargestellt.

Also dachte ich mir dann halt in Less die header.less anpassen, hier gibt es ja auch ein Code-Beispiel von 8mylez :slight_smile:
Alles korrekt eingestellt, keine Schreibfehler, Template lässt kompilieren und anschließend den Cache geleert.

Und was passiert - nicht’s - bzw. besser gesagt das Logo wird weiterhin verkleinert.

Kann mir jemand helfen? Vielleicht ist das alles ja nur ein Handlingsfehler!

Vielen Dank schon einmal für Eure Ratschläge.

Gruß
HMS

Link wäre nicht schlecht zum Debuggen :slight_smile:
Welches Theme? SW5 responsive?
Warum willst du des genau so gross drin haben? Das wichtigste ist das Seitenverhältnis (Breite zu Höhe) und den Rest lässt mal den Browser machen :slight_smile:

Gruss Arya_Svitkona

@Arya_Svitkona schrieb:

Link wäre nicht schlecht zum Debuggen :)
Welches Theme? SW5 responsive?
Warum willst du des genau so gross drin haben? Das wichtigste ist das Seitenverhältnis (Breite zu Höhe) und den Rest lässt mal den Browser machen :)

Gruss Arya_Svitkona

Hallo,

der Link: softair-unlimited.de. Das Logo wird viel zu klein dargestellt!
Genutzt wird das Flat-Template - SW 5.2.6

Danke schon im voraus! 
HMS

Dein Logo ist nur 275x60 px groß - und genau in dieser Größe wird es dargestellt. In welcher Größe lädst Du es hoch?

@Synonymous schrieb:

Dein Logo ist nur 275x60 px groß - und genau in dieser Größe wird es dargestellt. In welcher Größe lädst Du es hoch?

Jetzt bin ich ein wenig wirr!
Das Logo ist eigentlich 375 x 100 px!
Was läuft denn da falsch??

Gruß
HMS 

Vermutlich wird es beim Upload runtergerechnet oder Du lädst es schon in dieser kleineren Auflösung hoch.

Google mal nach deiner URL…I don’t like that :wink:
Hier “access denied” als Titel im Google Suchindex… Bei Gelegenheit neu Indexieren lassen (wenns soweit ist).

 

Das ist das Problem.

.header-main .logo-main .logo–shop{ width:50%; } // anpassen

Das Logo mag zwar gross genug sein, jedoch ist der Umschliessende div nur 50% gross und darum kann das Bild nie grösser dargestellt werden.
Die Lösung gib ich dir nicht “Pfannenfertig”, aber schau mal im Google Chrome mit “Rechts klick (aufs Logo) - Untersuchen” die einzelnen Div’s und ihre Grösse an.
Dann merkst was ich meine und kannst mit wenig CSS das ganze anpassen.

LG Arya_Svitkona

 

Update: Offtopic aber, pass deine .htaccess auf dem Server an, damit “softair-unlimited.de” auf “www.softair-unlimited.de” umgeleitet wird. Wenn du die Adresse ohne WWW angibst, kommt 1. ein anderer Shop 2. wirst schlechter von Google bewertet.

1 Like

@Arya_Svitkona schrieb:

Google mal nach deiner URL…I don’t like that ;)
Hier „access denied“ als Titel im Google Suchindex… Bei Gelegenheit neu Indexieren lassen (wenns soweit ist).

 

Das ist das Problem.

.header-main .logo-main .logo–shop{ width:50%; } // anpassen

Das Logo mag zwar gross genug sein, jedoch ist der Umschliessende div nur 50% gross und darum kann das Bild nie grösser dargestellt werden.
Die Lösung gib ich dir nicht „Pfannenfertig“, aber schau mal im Google Chrome mit „Rechts klick (aufs Logo) - Untersuchen“ die einzelnen Div’s und ihre Grösse an.
Dann merkst was ich meine und kannst mit wenig CSS das ganze anpassen.

LG Arya_Svitkona

 

Update: Offtopic aber, pass deine .htaccess auf dem Server an, damit „softair-unlimited.de“ auf „www.softair-unlimited.de“ umgeleitet wird. Wenn du die Adresse ohne WWW angibst, kommt 1. ein anderer Shop 2. wirst schlechter von Google bewertet.

Hallo,

Danke für Deinen Hinweis „Update“.
Das mit dem Logo verstehe ich jetzt zwar theoretisch, aber praktisch stehe ich da im Moment auf dem Schlauch insbesondere da der div.logo-main-block-group 378x80px gross ist ( Newbi Problem, ich weiß)

Gruß
HMS

Die falsche .htaccess config erklärt auch, warum ich jetzt eine ganz andere Seite sehe :slight_smile:
Jetzt ist Dein Logo noch immer 275x80, wird aber durch den angesprochenen DIV skaliert.

Such Dir die Klasse in Deinen .less Files raus (bzw. überlade Sie in Deinem eigenen Theme) und setze die width auf 100%.
Die Höhe ist übrigens für Viewports > 48em auch noch auf 5rem limitiert.

@Synonymous schrieb:

Die falsche .htaccess config erklärt auch, warum ich jetzt eine ganz andere Seite sehe :)
Jetzt ist Dein Logo noch immer 275x80, wird aber durch den angesprochenen DIV skaliert.

Such Dir die Klasse in Deinen .less Files raus (bzw. überlade Sie in Deinem eigenen Theme) und setze die width auf 100%.
Die Höhe ist übrigens für Viewports > 48em auch noch auf 5rem limitiert.

Hallo Synonymous,

Danke für Deine Hilfe. Mal sehen ob ich es umsetzten kann.
Was ist denn an der .htaccess denn falsch, bekommt Du beim Aufruf der Website nicht „softair-unlimited.de“ im Browser angezeigt?

Gruß
HMS 

Doch, jetzt schon. Aber beim letzten Mal hatte ich ein grün-schwarzes Logo und auch die Site sah etwas anders aus.

@hms‍ wie fit bist du in CSS? Hast bereits mal Änderungen in einem Theme durchgeführt?
Ansonsten rate ich dir das hier an:

https://shopwareianer.com/tutorials/shopware-eigene-less-datei-anlegen
https://shopwareianer.com/tutorials

Es gibt auch noch ein Tutor für deine Frage, aber ich lege dir nahe, dich im allgemeinen mit der Thematik auseinanderzusetzen. :slight_smile:
Good Luck!

@Arya_Svitkona schrieb:

@hms‍ wie fit bist du in CSS? Hast bereits mal Änderungen in einem Theme durchgeführt?
Ansonsten rate ich dir das hier an:

https://shopwareianer.com/tutorials/shopware-eigene-less-datei-anlegen
https://shopwareianer.com/tutorials

Es gibt auch noch ein Tutor für deine Frage, aber ich lege dir nahe, dich im allgemeinen mit der Thematik auseinanderzusetzen. :)
Good Luck!

Hallo,

es geht, ich arbeite bereits mit Less und habe darüber auch schon einige Anpassung an “meinem Template” vorgenommen. Der Link von “shopwareianer” und “8mylez” kenne ich schon, vielen Dank für den Tipp! Dort hole ich mir bereits, sehr erfolgreich, den einen oder anderen Tipp zur speziellen Anpassung.

Gruß
HMS