Lange Ladezeiten durch Plugin Recommendation

Hallo, ich habe teilweise super lange Ladezeiten. Mal geht die Seite schnell auf, mal dauert es eine Ewigkeit. Habe schon bei HostEurope nachgefragt, da diese Wartungsarbeiten hatten, ob es an denen liegen könnte. Jetzt habe ich alles durchforstet und mal das Plugin Recommendation inaktiv gestellt. Und siehe da… die Seiten gehen auf wie der Blitz! Hat jemand von Euch auch evtl. dieses Problem? Ich würde es natürlich gerne weiterhin nutzen, schon alleine wegen Cross-Selling etc. Was könnte man denn hier machen, dass es die Ladezeiten nicht hemmt?

Hallo, da mein Testshop auch bei HostEurope gehostet ist, hab ich gleich mal nachgeschaut. Das Aufrufen der Detailseiten hat manchmal ein paar Sekunden gedauert. Ich hab dann das Plugin deaktiviert und den kompletten Cache gelöscht. Die Detailseiten öffneten sich danach sehr schnell. Danach hab ich das Plugin wieder aktiviert und die Seiten öffnen sich nun genauso schnell wie mit deaktiviertem Plugin. Kann das evtl. am Cache liegen? Kannst du das nachvollziehen? Danke vorab.

Hallo Ralf, ja, genauso ist es bei mir auch. Hatte es deaktiviert = super schnelle Ladezeiten, dann wieder aktiviert, Cache gelöscht etc. und dann ging auch erst alles super schnell auf. Freu !!! Aber nach einiger Zeit auf die Seiten rumklicken gehts wieder los mit dem langen Seitenladen! Irgendwas stimmt da nicht und ich raufe mir schon die Haare! Von HostEurope habe ich Nachricht bekommen, dass es geprüft und an die Fachabteilung weitergeleitet wurde. Jetzt warte ich noch. Ich weiß ja nicht genau ob es am Plugin liegt, nur wenn es nicht aktiv ist geht alles super schnell auf. ???

Hallo Petra, werde das mit den Plugins/Ladezeiten die nächsten Tage mal verfolgen. Möchte eigentlich bei HostEurope bleiben. Mal schauen was deine Anfrage bei HE bringt. PS: Noch mal ne Frage zum Schluß. :wink: Wenn du bei dir mit aktivem Plugin den kompletten Cache löschst, öffnet sich dann die Seite wieder genauso schnell wie mit deaktiviertem Plugin?

[quote=„radox“]Hallo Petra, PS: Noch mal ne Frage zum Schluß. :wink: Wenn du bei dir mit aktivem Plugin den kompletten Cache löschst, öffnet sich dann die Seite wieder genauso schnell wie mit deaktiviertem Plugin?[/quote] Ja, hatte ich ja geschrieben! Nur dann dauert es eine Weile und dann hängt es teilweise wieder.

Richtig steht ja oben, war zu schnell. :wink: Danke.

Hallo ! Beim Aufruf der Detailseite wenn die Slider Kunden kauften auch bzw Kunden haben sich ebenfalls angesehen aktiv sind ist inder Grundeinstellung im Plugin bei den Limits ein sehr hoher Wert eingetragen Es kommt dann dazu, dass es 10 Slider-Seiten werden…mal je 3 Bilder sind 60 Anfragen … belastet sowohl den MySQL als auch wenn man weiter blättert den Browseraufruf. In Summe kommt mit zuletzt angesehen und Ähnliche Artikel wohl 80 zusammen. Empfehle einfach mal die Limits herunterzusetzen, etwa auf 5 Sliderseiten …bzw nur den Slider Kunden haben sich ebenfalls angesehen zu aktivieren… Sollte dann eigentlich schneller gehen… lg klaus

Hallo Klaus, habe das Limit runtergesetzt und es geht wirklich schneller! :smiley: Ich hoffe das bleibt auch so! Vielen lieben Dank für Deine Hilfe!

Guter Hinweis, Danke. :thumbup:

Ich glaube ich bin blind… Finde die Einstellungen nicht…

Hi, schau mal unter Einstellungen/plugins/Core Plugins/Frontend

1 Like

Um noch einmal auf das Thema zurück zu kommen. Durch herabsetzen des Limits ist der Shop schon schneller geworden. Jedoch denke ich ist es nicht der eigentliche Grund, da teilweise die Seiten wieder hängen. Mal schnell, mal hängt es. Von HostEurope habe ich folgende Antwort bekommen: „Der Server steht unter einer erweiterten Beobachtung. Das Problem konnte bedingt eingegrenzt werden. Leider können wir an diesem Zeitpunkt nicht mit Sicherheit sagen, wann dieses gelöst ist - Die technische Abteilung arbeiten mit Hochdruck an einer Lösung.“ Habe dort den Virtual Server Managed! Bin mal gespannt auf die Lösung, wenn und wann sie dann kommt! Bisher war ich recht zufrieden mit HE und möchte auch dort bleiben.

Hallo Petra, ich habe auch einen HostEurope VS und bin mir relativ sicher das es an HE liegt. Ich hatte in der Vergangenheit auch oft Probleme mit der Performance des Shops die tlw. bis zur quasi Nichterreichbarkeit (Ladezeiten von 2 Minuten und mehr) über Minuten und Stunden ging. Laut HE Support lag es jedesmal an der DB, bzw. daran das einzelne DB-Abfragen Tabellen gesperrt haben und alle nachfolgenden DB-Abfragen dann quasi blockiert wurden. Das führte dann zu den langen Ladezeiten. Seit ca. 1-2 Wochen habe ich, ohne das ich etwas verändert hätte, keine Ausfälle mehr d.h. der Shop läuft stabil und relativ flott…ich hoffe das bleibt so…*klopfaufHolz*…:wink:

Hallo Petra ! Es ist immer schwierig zwischen Top-Performance und TOP-Design im Shop die richtige Konfiguration zu finden. In Summe sind natürlich auch die Servereinstellungen wichtig, daher nie aufhören den Provider TOP Leistung abzuverlangen, die sparen oft an Resourcen um möglicht viele Seiten auf einen Webserver zu bekommen. Habe mir dennoch deine Seite näher angesehen und zwar mit diesem Tool und hier ist das Ergebnis: http://www.webpagetest.org/result/11032 … 1/details/ Da sehe ich ein paar Dinge: Zeile 14,16,18 : das ekomi Tool bremst hier !! Zeile 24: ekomi tool zu langer request 465 ms …!! Offensichtlich ist deren Server überlastet ! 48-51 deine Banner sind sehr groß ! Versuche die zu optimieren ! 170-180kb mehrmals hintereinander ist zuviel ! zeile 28: PIE.htc sehr groß brauchen wir aber leider für IE, eventuell kann shopware die noch kleiner machen, bzw sehe ich mir das auch an… zeile 79: da hast du ne 404…ist im Forum schon beschrieben wie man das behebt ! (Datei hochladen, die fehlt oder im Stylesheet rausnehmen) Also da gibt es ein wenig zu tun… :slight_smile: lg klaus

1 Like

Guten Morgen Klaus, die Banner habe ich jetzt statt png in jpg umgewandelt. Natürlich weniger kb! Der fehlende close-button ist auch hochgeladen. Soweit so gut, nur an eKomi kann ich ja nichts verändern. Ist aber schon wesentlich schneller! Danke für Deine Hilfe! :thumbup:

Hallo ! Kenne jetzt die Struktur von EKOMI zuwenig…aber es sollte möglich sein, Dateien die sich nichtändern durch Korrektur des Pfades von deinem Server lokal zu laden ! Da könntest du bei ekomi in der Technik nachfragen, welche Dateien statisch sind und welche variabel… lg klaus

Habe das Problem bei HE momentan aber auch. Weiss aber auch, dass einige “Spielereien” wie Facebook und Co. den Shop ausbremsen.

[quote=“Porter”]Hallo Petra, ich habe auch einen HostEurope VS und bin mir relativ sicher das es an HE liegt. Ich hatte in der Vergangenheit auch oft Probleme mit der Performance des Shops die tlw. bis zur quasi Nichterreichbarkeit (Ladezeiten von 2 Minuten und mehr) über Minuten und Stunden ging. [/quote] Subjektive Meinung, also ich glaube nicht das der HosteEurope VS schuld an den Problemen ist. Wir liegen selber mit einem Shop (ok, es ist noch 3.0.5) auf einem Virtuellen Server bei HostEurope (Linux MAX 4.0) und haben keinerlei Probleme mit Ladezeiten oder ähnlichem. OK, wir haben auch die Einstellungen des Servers optimiert. Aber das ist ja schließlich auch Aufgabe des Kunden der sich für einen root Server entscheidet und nicht des Hosters der die Maschine zur Verfügung stellt. Wer sich die Serveradministration nicht zutraut sollte sich für einen managed Server entscheiden, da übernimmt der Provider wieder die Einstellung. OK, das Posting wirkt jetzt vielleicht etwas negativ, nur wir sind seit über 10 Jahren mit allen Projekten bei HostEurope und die Leistung, der Preis und der Service haben immer gestimmt. Holger

OK, ich gestehe, der Beitrag war wirklich nicht produktiv. Demnächst werden wir auch auf Shopware 3.5 updaten und dann können wir hier gerne ein “wie optimiere ich mein vituellen Server für Shopware” Thema aufmachen. In der Zwischenzeit, wurden bereits Optimierungen am Server vorgenommen? Wie alle Programme wird der MySQL Server auch mit einer Einstellung für möglichst große Kompatibilität ausgeliefert (soll ja schließlich überall laufen). Das das nichts mit brauchbaren Einstellungen für einen Server zu tun hat kan sich sicher jeder vorstellen. Wurde, je nach Speicher des Servers, die large oder hugh Konfiguratiosn Datei für MySQL schon ausprobiert? Was sagen den mysqltuner (http://www.mysqltuner.com) und das primer Skipt (http://www.day32.com/MySQL/)? Und das Gleiche gilt auch für den Apachen. Wurden dort die Einstellungen überprüft und optimiert? Wurden die unnötigen Plugins aus der Konfiguration entfernt? So Sachen wie actions, autoindex, cgi, fcgi, include, mod_phyton, negotiation, perl, status, userdir sind Kandidaten die für den Betrieb von Shopware unnötig sind. Es muß immer beacht werden, die Erweiterungen blähen jede einzelne Instanz von Apache unnötig auf, was sich ebenfalls im Specherverbauch, load werten und ähnlichem niederschlägt. Ist keep-alive im Apachen aktiviert? Ist hostnamelookup deaktiviert? Kann eventuell auf die Logdateien auf dem Produktivsystem verzichtet werden? Wurde der eAccelerator fü php schon installiert? http://eaccelerator.net/ Das wären so die Punkte wo ich anfangen würde um mehr Leistung aus dem Server zu holen. Plus für die Leute die sich die Konfiguration des Servers auf der Komandokonsole zutrauen ist es immer ein Gute Idee Plesk oder sonstige Verwaltungssoftwaren gar nicht erst zu installieren, die fressen auch einiges an Ressourcen.

[quote=“ronecker”] OK, wir haben auch die Einstellungen des Servers optimiert. Aber das ist ja schließlich auch Aufgabe des Kunden der sich für einen root Server entscheidet und nicht des Hosters der die Maschine zur Verfügung stellt. Wer sich die Serveradministration nicht zutraut sollte sich für einen managed Server entscheiden, da übernimmt der Provider wieder die Einstellung. [/quote] Hi Holger, habe es nicht explizit dazugeschrieben weil ich dachte das es sich aus dem Vorposting von Petra ergibt…wir haben auch einen HE VS Managed…;)…die Möglichkeiten für uns Einfluss auf die Serverconfig zu nehmen sind daher sehr begrenzt…:wink: