Kunden können Ihr Passwort nicht mehr ändern.

Hallo, derzeit importiere ich Kundendaten aus unserem anderen Shop. Da bestimmt einige Kunden ihre Passwörter vergessen haben, habe ich gerade mal ausprobiert, ob die Änderung der Passwörter funktioniert. Dafür habe ich mich als neuen Kunde registriert und wollte dann im Kundenbereich mein Passwort ändern. Dort wird mir dann ein Fehler angezeigt: Ein Fehler ist aufgetreten! Die eMail-Adressen stimmen nicht überein. Das ist natürlich ein komischer Fehler, da bei der Passwortänderung nur einmal die Email-Adresse abgefragt wird und somit ein Tippfehler ausgeschlossen ist. Selber Fehler tritt auch auf, wenn ich mir das Passwort zuschicken lasse, mich mit diesem einlogge und dann wieder im Kundenbereich verändern will. Hat jemand eine Idee, woran das liegen könnte. Beste Grüße Thomas P.S. Shopware neuste Version ist instaliert.

Hallo Thomas, hmmm klingt eigenartig. Schau mal in der Datenbank, ob da eventuel irgendwelche Sonderzeichen mit rein gekommen sind? Wobei, wenn du dich frisch registriert hast, sollte dies ja nicht der Fall sein. Hast du eventuell die Viewport-, bzw. die Template-Dateien angepasst? Eventuell hat sich da ein kleiner Fehler eingeschlichen? Viele Grüße Thomas

Also die Datenbank sieht gut aus. Alle Email-Adressen sind sauber ohne Zusätze etc abgespeichert. Ja ich habe das Template etwas angepasst. Aber die betreffende Seite account/account_start.tpl wurde nicht verändert. Trotzdem habe ich mal die Original-Datei überkopiert - keine Änderung. So sieht meine Datei auszugsweise aus: [code]

{* FORM_BOX *}

{* sSnippet: Your access data *}{$sConfig.sSnippets.sAccountYouraccessdata}

{* sSnippet: Your e-mail address *}{$sConfig.sSnippets.sAccountYouremailaddress}

{* sSnippet: New Password *}{$sConfig.sSnippets.sAccountNewPassword}

{* sSnippet: Repeat password *}{$sConfig.sSnippets.sAccountRepeatpassword}

</div>
{* /FORM_BOX *}[/code]

Welche Dateien spricht denn diese Funktion “Passwort ändern” alles an. Im Registrierungsprozess wurde nur noch eine Checkbox eingebaut - die sollte hierrauf aber keine Auswirkung haben…

Grüße Thomas

Deaktiviere bitte mal kurz die Einstellung “Doppelte Eingabe der eMail-Adresse” - diese scheint das Problem zu verursachen. Wir haben das bereits als Ticket in unseren Bug-Tracker aufgenommen, so bald es hier einen Workaround gibt, veröffentlichen wir den an dieser Stelle!

1 Like

Genau daran liegt es. War schon fast am Verzweifeln. Dann werde ich das jetzt zuerst einmal deaktiviert lassen, bis Ihr eine Lösung habt. Danke für die schnelle Hilfe! Thomas

Als Workaround kannst du einfach im Viewport s_admin.php (engine/core/class/viewports/s_admin.php) ganz zu Anfang der Funktion „sRender“ die Zeile: $this-\>sSYSTEM-\>sCONFIG["sDOUBLEEMAILVALIDATION"] = ""; einfügen. Dann müsste hier die Überprüfung für den Mein Konto Bereich deaktiviert werden.

1 Like

Hat funktioniert! Danke

Danke dafür, eine Frage habe ich dazu aber noch. Wenn ich das Passwort ändere und dabei nicht 2 mal das identische Passwort eingebe, kommt zwar eine Fehlermeldung, aber wie ich finde, nicht die passende: „Ein Fehler ist aufgetreten! Bitte wählen Sie ein Passwort welches aus mindestens 6 Zeichen besteht“ Was muss ich anpassen, damit wieder folgende Fehlermeldung kommt? : „Ein Fehler ist aufgetreten! Die eMail-Adressen stimmen nicht überein.“ Vielen Dank im vorraus!

Hallo, das geht, ja. Schauen Sie sich mal dazu die /engine/core/class/viewports/s_password.php an. Das ist das Viewport das bei dieser Aktion gerufen wird. Dort werden auch die eingegebenen Sachen geprüft und eventuelle Fehler ausgegeben. viele Grüße Thomas

[quote=“TSchenk”]Hallo, das geht, ja. Schauen Sie sich mal dazu die /engine/core/class/viewports/s_password.php an. Das ist das Viewport das bei dieser Aktion gerufen wird. Dort werden auch die eingegebenen Sachen geprüft und eventuelle Fehler ausgegeben. viele Grüße Thomas[/quote] Danke für die Antwort, habe auch kurz reingeschaut, aber meine Kenntnisse reichen leider nicht aus, um zu erkennen, was ich dort anpassen muss…