Installation bei domainfactory

Hallo, ich habe alle Installationsschritte soweit durch allerdings wird mir permanent Fehlermeldung angezeigt obwohl alle Daten stimmen. SQLSTATE[28000] [1045] Access denied for user ... kann es evtl. an DB Host liegen, da Adresse in anderer Form angegeben wird, nämlich „mysql5.domain.tld“? Gruß

Hallo. Also wo Dein Fehler liegt kann ich Dir noch nicht sagen. Aber um einmal nach dem Ausschlussverfahren vorzugehen … An der Form des DB-Host liegt es nicht. Wir haben aktuell eine Installation bei DomainFactory laufen und geben den Host auch so an: mysql5.meinedomain.tld Funktioniert bei uns. Gruss AS

Moin, also ich bin auch bei DF und bei mir hat soweit alles funktioniert. Machst du die Installation manuell oder über das Install-Script? Gruß ottscho

Hallo, sieht für mich nach einem falschen Eintrag in der config aus, scheinbar sind die Zugangsdaten zur Datenbank noch nicht korrekt.

Hi, mal eine Frage an die DomainFactory Mitglieder, welche Pakete habt ihr bei DomainFactory? Sehe auf den Internetseiten nichts von der Zend aus dem Grund frage ich gerade.

Wir sind auch bei DF und die Installation ging mit den beschriebenen Anpassungen in der htaccess problemlos. Wir haben noch einen Managed Server L2, der aber heute auf einen L4 umgestellt wird.

Hallo. @vinylmeister: Welche Anpassungen musstet Ihr in der .htaccess machen? Danke derweil … AS

Folgende Tipps aus dem Forum haben weitergeholfen (mittlerweile sind diese auch in der Installationsanleitung verankert): 1. Öffnen Sie die Datei .htaccess und ersetzen Sie diese Zeile: RewriteRule ^(.\*)$ shopware.php/$1 [PT,L,QSA] komplett durch diese Zeile: RewriteRule ^(.\*)$ shopware.php [PT,L,QSA] 2. In der .htaccess-Datei muss nach dieser Zeile: RewriteEngine on diese Zeile eingefügt werden: RewriteBase / 3. Aus dem Forum von user „rtbr“ Suche in der Datei OpenId.php im Verzeichnis /engine/Enlight/Vendor/Zend/libary/Zend in den Zeilen 144 und 145 den Code $\_SERVER['PATH\_INFO'] Ersetzen durch $\_SERVER['REQUEST\_URI'] Ich hoffe das hilft weiter.

1 Like

Hallo. Danke Dir. Habe das mal abgeglichen. zu 1.) War bei uns bereits so. Wahrscheinlich wurde die Script-Installation angepasst. Wir haben erst gestern installiert. zu 2.) Hatten wir auch bereits, war das erste was ich selber gemacht habe :-). Installation läuft. zu 3.) Für was ist das gut? Was für ein Problem wurde damit behoben? Dann weiß ich wenn ich das Problem habe, was ich tun muss. Ohne Not möchte ich das nicht ändern. Danke derweil… AS

Stimmt, zu Punkt 3 sollte schon noch etwas mehr stehen :wink: Ein Aufruf des Backends nach Installation war nicht möglich. Es gab den Fehler “No input file specified” Sie hier: Backend Aufruf nicht möglich

1 Like

Danke. Dann denke ich das lassen wir mal. Unser Backend läuft auch so … Servus AS

[quote=„ottscho“]Moin, also ich bin auch bei DF und bei mir hat soweit alles funktioniert. Machst du die Installation manuell oder über das Install-Script? Gruß ottscho[/quote] Die Installation wurde manuell laut Anleidung durchgeführt, einen Install. Skript habe ich leider niergends zum Download gefunden.

[quote=“Alpine Swift”]Hallo. Also wo Dein Fehler liegt kann ich Dir noch nicht sagen. Aber um einmal nach dem Ausschlussverfahren vorzugehen … An der Form des DB-Host liegt es nicht. Wir haben aktuell eine Installation bei DomainFactory laufen und geben den Host auch so an: mysql5.meinedomain.tld Funktioniert bei uns. Gruss AS[/quote] Frage zu domainfactory df Paket: um die shopware 3.5 bei df zu installieren, reicht dort das Paket ManagedHosting aus oder muss es ein ManagedServer Paket sein? Nach 1 Woche erfolgloser Eigenregie (Laie bin) die shopware 3.5 zu installieren bei domainfactory ( Paket ManagedHosting ) beauftragte ich domainfactory. Die haben es zwar “installiert” aber bekommen es anscheinend nicht ans laufen. unter: http://www.meinedomain.tld/shopware.php … oller=auth erscheint: Zitat (abgekürzt da 4 Zeilen lang): Schwerwiegender Fehler: Nicht abgefangene Ausnahme “Enlight_Exception ‘with message’ Controller” Shopware_Controllers_Ollerauth_Index "kann nicht geladen werden Versagen ‘in / kunden/kundennr. usw etc pp unter: http://www.meinedomain.tld/engine erfolgt http://www.meinedomain.tld/backend/index Zitat: Der Server hat einen internen Fehler oder eine Fehlkonfigurationen und konnte nicht erfolgreich abgeschlossen Ihre Anfrage. etc pp zusätzlich 500 Internal Server Error Fehler trat bei dem Versuch, ein ErrorDocument zu verwenden, um die Anfrage zu bearbeiten. bei der eingabe: http://www.meinedomain.tld/ Zitat: Error Index Title / Shopware 3,5 Demo Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Keine gültige Lizenz gefunden in Shopware / Plugins / Standard / Kern / Shop / Bootstrap.php on line 0 Stack-Trace: # 0 Shopware / Plugins / Standard / Kern / Shop / Bootstrap.php (0): Shopware_Plugins_Core_Shop_Bootstrap: onPreDispatch () # 1 [interne Funktion]: Shopware_Plugins_Core_Shop_Bootstrap: onPreDispatch (Objekt (Enlight_Event_EventArgs)) # 2 Enlight / Event / EventHandler.php (60): call_user_func ("Shopware_Plugin …’, Object (Enlight_Event_EventArgs)) # 3 Enlight / Event / EventManager.php (70): Enlight_Event_EventHandler-> execute (Object (Enlight_Event_EventArgs)) # 4 Enlight / Controller / Front.php (75): Enlight_Event_EventManager-> melden ("Enlight_Control …’, Array) # 5 Shopware / Bootstrap.php (21): Enlight_Controller_Front-> dispatch () # 6 Enlight / application.php (69): Shopware_Bootstrap-> run () # 7 shopware.php (6): Enlight_Application-> run () # 8 {main} kann mir bitte jemand helfen, das ich das an domainfactory weiter leiten kann !?! Danke & Gruß Freddi

Hat DF die Daten per FTP Binär übertragen? Wenn nicht muss dies noch mal neu gemacht werden. Ich denke hier liegt der Fehler. Ich habe auch einen DF Account. ManagedHosting reicht vollkommen aus. Wenns nicht klappt melden. ich kann dir ggfls. die Installation durchführen.

Hi, für domainFACTORY gibt es ein Wiki-Eintrag. Dieser sollte umbedingt beachtet werden: http://www.shopware.de/wiki/Installatio … ainFACTORY Ansonsten sieht es so aus, ob die Shopware richtig installiert wurde. Dateien, Datenbank und Konfiguration sollten schon stimmen. Viele Grüße Heiner

@ Ottscho danke für Dein Angebot bezüglich der Installation :slight_smile: df hat eine Nacht darüber geschlafen und heute morgen funktionierte die backend Anmeldung incl. der Lizensierung bei Shopware. :thumbup: :slight_smile: