https /SSL auf allen Seiten von google bevorzugt

Hallo angeblich bevorzugt Google SSL auf allen Seiten. http://googlewebmastercentral.blogspot. … ignal.html https://www.youtube.com/watch?v=cBhZ6S0 … ls_en_post Also hab ich unter Shopeinstellungen/Shops/Hauptshop deutsch/ das “überall SSL” angehakt Auf google chrome und safari ist jetzt auch die Startseite auf https nur die Artikelseiten sind nach wie vor normal ungeschützt. Im Firefox sind alle Seiten https. Woran liegt das ? Und der pagespeed leidet -ca 20-30% langsamere Ladezeiten Stellt ihr euren Shop um ? Und eine weitere Frage wäre: cannonical sollte laut dem Video auch auf https umgestellt werden Shopware bietet aber nur unter SEO Routereinstellungen http immer verwenden an oder nicht verwenden oder vererben an. Update 1: OK ich sehe gerade daß die textbausteine und die html elemente mit http links nachwievor http Seiten aufrufen und nicht umgeleitet werden auf https: Die Links die Shopware selbst anbietet in den Seitenleisten oder in den “Kunden haben sich ebenfalls angesehen” Bildern werden automatisch auf https umgeleitet. Man muß wohl alle selbst gesetzten http Links auf https abändern. Update2: So hab jetzt alle Textbausteine und html Links auf https umgestellt. Nur was bleibt ist wenn man den shop mit http://www.kuscheldir.com aufruft wird nicht automatisch auf https://www.kuscheldir.com umgeleitet. Muß ich in der htaccess auf https umleiten ?

Hallo, ich stand vor kurzem auch vor diesem Problem. Ich hab folgendes in meiner .htaccess hinzugefügt und seitdem wird von alle von http auf https “umgeleitet”. RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L] Diese Angaben sind wie immer ohne Gewähr :slight_smile: Liebe Grüße

1 Like

Hallo Das funktioniert gut bei der Startseite. Aber wenn ich eine Produktseite aufrufe http://www.kuscheldir.com/antuan.html erfolgt eine Umleitung auf die Startseite mit dem Zusatz shopware.php Ist also noch nicht die Ganze Lösung

Du musst den Haken bei „überall SSL verwenden“ nicht setzen insofern du es über den Server regelst. Funktioniert bei mir wunderbar: www.tcgshop.ch :wink:

1 Like

Haken entfernt Das Problem bleibt - wird eine Artikelseite oder eine Shopseite wie die AGB mit http:// aufgerufen wird auf die Startseite umgeleitet. Liegt das an meiner .htaccess [code]
RewriteEngine on

#RewriteBase /shopware/

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule images/ayww/(.*) images/banner/$1

RewriteCond %{REQUEST_URI} !(/(engine|images/[a-z]+|files|templates)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

# Staging-Rules start SetEnvIf Host “staging.test.shopware.in” ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration
Deny from all
# Enable gzip compression
# disable compression on iconset due to loading problems in google chrome on windows
SetEnvIfNoCase Request_URI icon-set.css$ no-gzip dont-vary

AddOutputFilterByType DEFLATE text/html text/plain text/css text/javascript application/json

AddOutputFilterByType DEFLATE application/javascript

AddOutputFilterByType DEFLATE text/xml application/xml text/x-component

AddOutputFilterByType DEFLATE application/xhtml+xml application/rss+xml application/atom+xml



ExpiresActive on
ExpiresDefault “access plus 1 month”
FileETag None

Header append Cache-Control “public”
Header unset ETag


# Disables auto directory index
Options -Indexes

Options -MultiViews

php_value memory_limit 256M

php_value max_execution_time 120

php_flag phar.readonly off
php_flag magic_quotes_gpc off
php_flag session.auto_start off
php_flag suhosin.session.cryptua off
php_flag zend.ze1_compatibility_mode off
# AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php php_value memory_limit 256M php_value session.save_path /tmp [/code]

Jup, glaube das liegt an deiner .htaccess. So schaut das bei mir aus. [color=green]
RewriteEngine on
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L][/color]

Sprich ich hab die beiden zeilen die ich oben beschrieben habe unters „RewriteEngine on“
geschrieben.

Liebe Grüße

Habe unter RewriteEngine on folgende zwei Zeilen hinzugefügt: # Https config for the backend RewriteCond %{HTTPS} !=on RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] # von HTTP auf HTTPS umleiten RewriteCond %{SERVER_PORT} !^443$ RewriteRule (.*) https://%{HTTP_HOST}/$1 [L] Der erste Abschnitt ist bei dem neuestem htaccess von Shopware mit dabei, hier wurde nur das auskommentierte aktiviert. Der zweite Abschnitt leitet alles was nicht als https angefragt wurde, auf https weiter. Funktioniert auch wunderbar bei Artikeln etc.

1 Like

Hallo ihr beiden, Ich kann es erst am Sonntag abend ausprobieren. Aber was mir auffällt ist das bei biberstock die Umleitung nicht mit 301 passiert. Ich hab gelesen das google nur 301 Weiterleitungen gleich bewertet wie die alten addressen. Ich vermute ja das in meiner htaccess noch ein paar Zeilen zu ändern wären. Ich hoffe auch Shopware sagt etwas dazu. Schliesslich sollten ja jetzt alle Shops komplett auf https umgestellt werden.

Moin, vielleicht hilft Dir dieser Post: administration-f55/ssl-fur-kompletten-shop-einrichten-erzwingen-t17055-20.html?hilit=https In dieser Regel ist ein anderes Zeichen drin: ^ RewriteCond %{HTTPS} !=on RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] Ich habe keine Ahnung davon ob die Klammer andere Auswirkungen hat!

1 Like

Hallo artep, Hallo Biberstock, Hallo warmes-plätzchen Hab zuerst versucht es so zu machen wie Artep schreibt. Die 2 Zeilen in die .htaccess + die geänderte bootstrap.php Datei wie in dem link von Artep beschrieben. Wahrscheinlich war ich nicht fähig diese Änderung korrekt zu machen, jedenfalls hat es bei mir nicht funktioniert - weil ich konnte nach wie vor beides aufrufen http und https. Ich habe jetzt die Version von Biberstock verwendet - und die funktioniert nun auch bei mir. Eine kleine Änderung habe ich in der letzten Zeile gemacht - das „R=301“ für google Auch weil das hier http://www.use-blog.de/server-administr … mschalten/ so beschrieben und erklärt wird. #RewriteBase /shopware/ # Https config for the backend RewriteCond %{HTTPS} !=on RewriteRule backend/(.\*) https://%{HTTP\_HOST}%{REQUEST\_URI} [L,R=301] # von HTTP auf HTTPS umleiten RewriteCond %{SERVER\_PORT} !^443$ RewriteRule (.\*) https://%{HTTP\_HOST}/$1 [R=301,L] Und Ich hab den Haken bei „überall SSL verwenden“ gemacht, weil die Seiten zwar jedenfalls umgeschrieben werden, die Menü (zb.:Seitenmenü) Links sonst auf http stehen. Danke jedenfalls für eure Hilfe. Ich glaub das ist jetzt ok.