Help ! Nach Installation und Aufruf des Backend erscheint Fehler 500

Die Erstinstallations Routine der neuesten Shopware Version konnte ich insoweit durchführen. Die Homeseite - www.lange-gruena.de - lässt sich aufrufen. Wenn ich das Backend das erste Mal aufrufen möchte, kommt folgende Fehlermeldung:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Diese Fehlermeldung kommt ebenso, wenn ich auf der Homeseite einen Link anklicke.  Habe mich mit den " Hoster ( 1und 1 ) in Verbindung gesetzt. Dort konnte mir aber niemand weiterhelfen. Man meinte, es läge an irgend einer htaccess Datei. Da ich " blutiger Anfänger " meine Bitte: welchen Tip kann mir " die community " geben ?

 

In Ergänzung meiner Frage:

Es sollte laut Beschreibung zunächst ei " Shopware First Run Wizard" starten. Diese Aufruf funktioniert scheinbar nicht

Gibt es Fehlermeldungen im Error-Log der Website oder in den Shopware-Logs?

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

1 Like

Tip: Nutze mal die Forensuche oben rechts

@TimmeHosting schrieb:

Gibt es Fehlermeldungen im Error-Log der Website oder in den Shopware-Logs?

image

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

in welchem Pfad finde ich besagte  error-logs ?

Auch da hilft wieder die Forensuche Wink

500 Error = They fucked up!

Und klar, es liegt garantiert an der .htaccess.

@kulli schrieb:

Auch da hilft wieder die Forensuche Wink

Thumb-Up Wearing-Sunglasses 

Ein Apache Fehler mit dem Fehlercode 500 ist ein klassischer Timeout-Fehler,der bevorzugt dann auftritt, wenn irgendwo eine Endlosschleife auftritt durch die eine Anfrage (=Request) an den Server nie beantwortet werden kann…

Sowas tritt bevorzugt bei

1.) fehlerhaften mod_rewrite Regelsätzen in einer .htaccess Datei auf oder auch

2.) bei erfolglosen Versuchen auf Verzeichnisse oder Dateien zuzugreifen auf denen der Zugriff verboten ist (z.B. durch eine Access Deny Regel) oder wo

3.) der User unter dessen Kennung der virtuelle Apache-Host läuft aufgrund der gesetzten Dateirechte einfach keinen Zugriff hat.

 

Ich bin zwar neu im Umgang mit Shopware, aber das ist nun ein klassisches Webserverkonfigurationsproblem welches seine Ursachen an mehreren Stellen haben kann, in der Webserverkonfiguration, in der .htaccess Datei (häufigste Ursache) oder eben in den Dateirechten im Dateisystem des Servers (passiert bevorzugt wenn man einen Shellzugang hat aber die eingeloggte User-Kennung dann eine andere als die des virtuellen Apache Hostusers ist, wenn man da nicht dran denkt oder es nicht weiss, dann ist fix mal was aus Versehen an den Dateirechten verstellt, einmal speichern kann dann reichen)…

1 Like

@ALA schrieb:

in welchem Pfad finde ich besagte  error-logs ?

Die Shopware-Logs findest du im var/logs-Verzeichnis Deiner Shopware-Installation. Wo das Error-Log der Website liegt, hängt von der Webserver-Konfiguration ab; meistens findest Du, wenn Du per FTP oder SSH eingeloggt bist, irgendwo einen Ordner namens log/ oder logs/, dort könnte das Error-Log liegen. Im Zweifel kann Dir Dein Hoster sagen, wo Du das Error-Log findest.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

1 Like

@TomcatMJ schrieb:

Ein Apache Fehler mit dem Fehlercode 500 ist ein klassischer Timeout-Fehler,der bevorzugt dann auftritt, wenn irgendwo eine Endlosschleife auftritt durch die eine Anfrage (=Request) an den Server nie beantwortet werden kann…

Sowas tritt bevorzugt bei

1.) fehlerhaften mod_rewrite Regelsätzen in einer .htaccess Datei auf oder auch

2.) bei erfolglosen Versuchen auf Verzeichnisse oder Dateien zuzugreifen auf denen der Zugriff verboten ist (z.B. durch eine Access Deny Regel) oder wo

3.) der User unter dessen Kennung der virtuelle Apache-Host läuft aufgrund der gesetzten Dateirechte einfach keinen Zugriff hat.

 

Ich bin zwar neu im Umgang mit Shopware, aber das ist nun ein klassisches Webserverkonfigurationsproblem welches seine Ursachen an mehreren Stellen haben kann, in der Webserverkonfiguration, in der .htaccess Datei (häufigste Ursache) oder eben in den Dateirechten im Dateisystem des Servers (passiert bevorzugt wenn man einen Shellzugang hat aber die eingeloggte User-Kennung dann eine andere als die des virtuellen Apache Hostusers ist, wenn man da nicht dran denkt oder es nicht weiss, dann ist fix mal was aus Versehen an den Dateirechten verstellt, einmal speichern kann dann reichen)…

 

Vielen Dank für die Ausführungen.

Derweil läuft mein Testshop und auch das Backend. Der Grund war die htaccess im Verzeichnis recovery/install - dieses habe ich einfac umbennannt, so konnte ich die Installation ausführen. Weiter habe ich in der htaccess im Stammverzeichnis folgendes geändert:

#RewriteBase /shopware/
RewriteBase /

Somit läuft der shop und ich kann " meinen " Testshop aufbauen.