Gutschriften PDF falsche Berechnung des Gesamtbetrags

Ich habe hier ein Problem, wo ich nicht glauben kann, dass es bis Version 6.3 niemandem aufgefallen ist, deshalb die Frage, ob noch es noch andere Betroffene oder sogar Lösungsideen gibt.

Gutschriften werden in den erstellten PDFs sowohl in unserer (bald) live-Umgebung, als auch in meiner lokalen Installation falsch berechnet:

Folgendes Vorgehen:

  • Bestellung und Rechnung existieren
  • Bestellung bearbeiten, Gutschriftposten hinzufügen über den Gesamtbetrag
  • im Backend angezeigter Betrag stimmt
  • Beleg erstellen -> Gutschrift -> PDF herunterladen
  • Berechnung auf PDF falsch

Es scheint so zu sein, dass der Bruttobetrag der Einzelposten als Nettobetrag ausgewiesen und dann aber nochmal der (ursprünglich) richtige MWSt-Betrag hinzuaddiert wird. D.h. die Gesamtbeträge sind immer zu hoch.

Alle anderen Dokumente funktionieren richtig. Habe auch schon mal alle Plpugins deaktiviert, die irgendwas mit Dokumentenerstellung zu tun haben - leider keine Abhilfe.

Fällt euch dazu etwas ein?

3 Likes

Ja, bei den Gutschriften scheint er irgendwie einen Brutto-Wert als Netto zu nehmen.

Mach am besten mal ein Ticket auf: issues.shopware.com

Uns ist es jetzt auch aufgefallen. Gutschriften sind damit nicht mehr möglich… Und das in einem halbwegs produktiven shop!

Ist es möglich das Problem vorrübergehend zu umgehen? Evtl durch Änderungen in credit_note.tpl Datei?

Wir haben das gleiche Problem. Es wird noch einmal die Mwst. berechnet.

Hallo,
hat jemand eine Lösung? das geht mal überhaupt nicht…

Hallo, ich hab genau dasselbe Problem. Versuche auch schon seit Monaten eine Lösung zu finden – kein Erfolg.

Hallo Leute,

ich habe nach wie vor das Problem mit den Gutschriften in einem aktuellen Projekt. Gibt es dazu mittlerweile eine Lösung?

Lässt sich hier evtl. das Template der Gutschrift anpassen?

Hat jemand einen Brotkrumen oder Lösungsansatz?

Merci im Voraus.