Gibt es Probleme mit dem Store?

Hallo,

heute erhalte ich beim Versuch mich im Plugin-Manager für die neuen Plugin-Updates einzuloggen nur die folgende Fehlermeldung vom Store:

An error occured while parsing the REST response with simplexml

Ein temporäres Problem, oder was läuft falsch? 

SW 4.3.7 

 

Sieht mir nach einem Problem in der 4er aus, gebe das mal weiter.

2 Likes

Kannst du schon sagen wann es wieder geht? Wir kommen auch mit 4.3.6 nicht über den Pluginmanager auf die Updates.

@impuls schrieb:

Kannst du schon sagen wann es wieder geht? Wir kommen auch mit 4.3.6 nicht über den Pluginmanager auf die Updates.

Das ist aber etwas anderes, kann ich lokal auch nicht nachstellen.
Hier ging es speziell um die Store-Funktionen des Plugin-Managers. Die Grundfunktion Updaten/Installieren usw. klappen immer noch einwandfrei. 
Ich möchte auch nochmal ausdrücklich drauf hinweisen, dass der offizielle Support für SW4 am 01.07. ausgelaufen ist.

Hallo,

ich denke nicht, auch nach mehrmaligem Lesen, das @impuls‍ da etwas anderes gemeint hat als wir. Man kann die Updates sich auch aus dem Shopware-Account runter laden und dann direkt installieren. Ist aber umständlich und zeitraubend.

Ich möchte auch nochmal ausdrücklich drauf hinweisen, dass der offizielle Support für SW4 am 01.07. ausgelaufen ist.

Das wäre aber noch lange kein Grund, den direkten Zugriff auf Updates auch und gerade von Drittanbietern zu unterbinden (sei es versehentlich oder absichtlich).
Selbst Microsoft stellt jetzt doch wieder Updates für XP bereit.

Man muss einfach akzeptieren, daß es wirtschftliche, zeitliche und andere Gründe gibt, die das Update zumindest eine zeitlang stark erschweren. Immerhin sind einige große Sprünge erforderlich, um die Version 4 an 5 anzupassen. Das ist ja nicht mit einem Knopfdruck erledigt.

Bei uns funktionieren die Funktionen leider nicht! Wenn ich auf “Meine Einkäufe” klicke und mich einloggen möchte bekomme ich folgenden Hinweis:

Plugin manager

An error occured while parsing the REST response with simplexml.

Beim Klick auf die Updates (aktuell z.B. PayPal / PayPal Plus) bekomme ich den Hinweis “Out of Range”. 

Wenn ich danach wieder auf “Meine Einkäufe” klicke bekomme ich eine genaure Fehlermeldung mit einem 503er Fenster:

Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. An error occured while parsing the REST response with simplexml. in Zend/Rest/Client/Result.php on line 61 Stack trace: #0 Zend/Rest/Client.php(265): Zend_Rest_Client_Result->__construct('') #1 Shopware/Plugins/Default/Backend/StoreApi/StoreApi/Core/Rest/Client.php(92): Zend_Rest_Client->__call('post', Array) #2 Shopware/Plugins/Default/Backend/StoreApi/StoreApi/Core/Rest/Client.php(92): Zend_Rest_Client->post() #3 Shopware/Plugins/Default/Backend/StoreApi/StoreApi/Core/Gateway/Gateway.php(48): Shopware_StoreApi_Core_Rest_Client->call('GET', 'auth/check', Array) #4 Shopware/Plugins/Default/Backend/StoreApi/StoreApi/Core/Gateway/Auth.php(44): Shopware_StoreApi_Core_Gateway_Gateway->get('auth/check', Array) #5 Shopware/Plugins/Default/Backend/StoreApi/StoreApi/Core/Service/Auth.php(49): Shopware_StoreApi_Core_Gateway_Auth->isTokenValid(NULL, NULL) #6 Shopware/Plugins/Default/Core/PluginManager/Components/Store.php(158): Shopware_StoreApi_Core_Service_Auth->isTokenValid(Object(Shopware_StoreApi_Models_Auth)) #7 Shopware/Plugins/Default/Core/PluginManager/Controllers/Backend/Store.php(584): CommunityStore->isLoggedIn() #8 Enlight/Controller/Action.php(159): Shopware_Controllers_Backend_Store->licencedProductsAction() #9 Enlight/Controller/Dispatcher/Default.php(528): Enlight_Controller_Action->dispatch('licencedProduct...') #10 Enlight/Controller/Front.php(228): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #11 Shopware/Kernel.php(145): Enlight_Controller_Front->dispatch() #12 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(471): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #14 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(242): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #15 Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #16 shopware.php(109): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #17 {main}  

 

@drakon schrieb:

Das wäre aber noch lange kein Grund, den direkten Zugriff auf Updates auch und gerade von Drittanbietern zu unterbinden (sei es versehentlich oder absichtlich).
Selbst Microsoft stellt jetzt doch wieder Updates für XP bereit.

Man muss einfach akzeptieren, daß es wirtschftliche, zeitliche und andere Gründe gibt, die das Update zumindest eine zeitlang stark erschweren. Immerhin sind einige große Sprünge erforderlich, um die Version 4 an 5 anzupassen. Das ist ja nicht mit einem Knopfdruck erledigt.

Hab ich ja auch nicht gesagt :wink:
Ist erstmal ein Hinweis gewesen. 

[@Moritz Naczenski](http://forum.shopware.com/profile/14574/Moritz Naczenski „Moritz Naczenski“)‍

Kannst du denn mit meinen Hinweisen oben etwas zu der Problematik sagen?
Wie Drakon schon geschrieben hat, kann es ja nicht sein, dass seitdem ihr die 4er Version nicht mehr supportet auch keine Plugin Updates mehr über den Manager erfolgen können. Denn andere Änderungen wurden in letzter Zeit nicht vorgenommen.

Siehe meine Antwort oben.Es ist ein Hinweis, es hat keiner gesagt, dass wir da nix machen :wink:

Wir schauen uns das an, aktuell kann ich da noch nicht vielmehr zu sagen. Müssen halt erstmal die Ursache finden. Für die Übergangszeit müsst ihr das halt manuell machen, die Dinge sind ja auch manuell über Account/Store möglich, sodass ihr aktuell keine Einschränkungen habt.

Hallo,

da gibt es nur ein kleines Problem mit dem Paypal-Plugin. Das befindet sich bei mir (und anderen Installationen) aus historischen Gründen :slight_smile: in /plugins/default/frontend/. Beim updaten über den Update-Mechanismus wird das an dieser Stelle upgedatet.

Lade ich aber das runtergeladene Zip aus dem Account in den Shop, dann versucht er das Plugin aber in /plugins/community/frontend/ upzudaten. Dann muss ich die Files immer in den anderen Ordner kopieren, weil das sonst nicht funktioniert.

Warum ist das so und wie kann man es in Zukunft vermeiden?

Das kannst du nicht vermeiden, du kannst aber die Dateien lokal entpacken und einfach per FTP manuell in den Ordner packen wo sich das Paypal Plugin befindet. Der manuelle Upload des Zips im Backend packt immer alles unter Community.

Das ist aber generell ein SW4-Problem, weil es damals Plugins gab die in “Default” gelegen haben, gibt es ab SW5 nicht mehr. Du kannst es natürlich auch deinstallieren, löschen und dann wieder installieren. Dann landet es auch in Community. Deinstallation eines Zahlungsanbieters ist aber generell immer etwas doof.

Alternativ: Per FTP verschieben in den Community-Ordner und in der s_core_plugins die Source von Default auf Community ändern.

Ist wahrscheinlich das einfachste. In der Zwischenzeit darf aber niemals der Plugin-Manager geöffnet werden.

Moin,

wir haben ein Problem im Session-Handling von Shopware 4 Backend entdeckt.

Das Problem wurde gerade behoben.

Alle Funktionalitäten in SW4-Backends sollten somit wieder reibungslos funktionieren. Auch Updates können somit wieder wie üblich bezogen werden!

 

Ich bitte eventuelle Unannehmlichkeiten zu entschuldigen :slight_smile: