[Gelöst] Startseite lädt nicht mehr, Unterseiten erzeugen Fehler

Hallo,

ich habe ein eigenartiges Problem mit dem Laden der Startseite, die Ladezeit bei Aufruf https://www.modellbaushop-joachim.de geht aktuell gegen unendlich ohne dass der Ladervorgang abgebrochen wird oder gar eine Fehlermeldung ausgegeben wird. Das letzte was ich gemacht habe war das Update auf 5.5.1 Rev. 201809181442. Das lief aber ohne Probleme und danach ist noch eine Bestellung eingetroffen. Eine Anfrage an den Hoster ob an der Serverumgebung etwas geändert wurde läuft. So ganz ohne Fehlermeldung ist die Suche etwas schwierig. Rufe ich eine Unterseite auf also z.B. eine bestimmte Artikelkategorie, werden die Kategorie und auch die Artikeldetails aufgerufen hier gibt es aber eine Fehlermeldung sobald ich versuche einen Artikel in den Warenkorb zu legen:

Invalides Formular-Token!

Die Aktion konnte aufgrund eines invaliden Formular-Tokens nicht durchgeführt werden.
Ein neues Token wurde bereits generiert.

Bitte gehen Sie in Ihrem Browser eine Seite zurück und starten die Aktion erneut.

Ich bin mir nicht bewußt die Shopwarekonfiguration wesentlich geändert zu haben - kennt jemand auch solch ein Verhalten von Shopware und kann mir Tips für weitere Tests und die Fehlersuche geben?

 

Gruß Andreas

 

Tips für die Fehlersuche findest Du im Handbuch.

und über die Forensuche

Die Seite würde ich aber sofort offline stellen, weil bei manchen Artikeln die Grundpreise fehlen. bzw weil es rechtlich noch nicht einwandfrei ist (Widerrufsformular ?)

 

Vielen Dank, jetzt habe ich auch endlich die Ausgabe einer Fehlermeldung im Frontend generieren können:

Anscheinend zuviele Verbindungen oder Verbindungen zur Datenbank die nicht mehr beendet werden? Eine Lösung habe ich aber dafür nicht kann das an einer Änderung liegen die der Hoster auf dem Server vorgenommen hat?

 

Gruß Andreas

http://lmgtfy.com/?q=shopware+mysql+too+many+connections

Hallo,

shopware gibt mir weiter Rätsel auf, heute morgen den shop noch einmal aufgerufen statt der erwarteten Ausgabe der Fehlermeldung im Frontend erhalte ich wieder den unendlichen Ladevorgang der Startseite.

 

Die Rückmeldung vom Hoster ergab noch keine neuen Erkenntnisse ausser vieleicht mal eine andere PHP Version zu testen - habe aber dort die bisher generierte Fehlermeldung noch zugesandt mal sehen ob das weiterhilft.

Gruß Andreas

Ich überlege auch noch ob es nich doch mit der Softwareaktualisierung zu tun hat - die letzte Bestellung ist doch vor dem Update und nicht danach eingegangen danach sind aber noch e-mails aus dem Backend versandt worden.

Aber dann müssten solche Probleme auch bei anderen Betreibern auftauchen.

 

Gruß Andreas

Hallo,

 

ich bin mit meiner Fehlersuche wieder ganz am Anfang!

Die o.g. Fehlermeldung war laut Hoster auf eine Störung des Datenbankdienstes zurückzuführen und wurde am Montag behoben.

Derzeit gibt es bei Aufruf der Startseite keine Fehlermeldung mehr sondern nur noch den unendlichen Ladevorgang ohne irgend eine Rückmeldung.

 

Hat jemand noch einen Tipp wie ich weiter vorgehen soll?

 

Gruß Andreas

Ich habe das Verzeichnis var/log aufgerufen und die Einträge von heute und gestern einmal (gekürzt) kopiert. Mir als nicht Programmierere sagt das erst einmal nichts scheint sich aber um Meldungen zu handeln, die erzeugt werden wenn ich das Hauptverzeichnis verlasse und irgend eine Aktion anklicke?

 

[2018-10-23 08:41:25] core.CRITICAL: The provided X-CSRF-Token for path “/newsletter” is invalid. Please go back, reload the page and try again. {“uid”:“b9b483d”}
[2018-10-23 08:41:25] core.CRITICAL: The provided X-CSRF-Token for path “/newsletter” is invalid. Please go back, reload the page and try again. {“uid”:“b9b483d”}
[2018-10-23 08:41:25] core.ERROR: exception ‘Shopware\Components\CSRFTokenValidationException’ with message ‘The provided X-CSRF-Token for path “/newsletter” is invalid. Please go back, reload the page and try again.’ in /var/www/web57486/html/shopware/engine/Shopware/Components/CSRFTokenValidator.php:149 Stack trace: #0 [internal function]: Shopware\Components\CSRFTokenValidator->checkFrontendTokenValidation(Object(Enlight_Controller_ActionEventArgs)) #1 /var/www/web57486/html/shopware/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #2 /var/www/web57486/html/shopware/engine/Library/Enlight/Event/EventManager.php(220): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs))

 

und vom 22.10-

[2018-10-22 10:00:33] core.CRITICAL: The provided X-CSRF-Token for path “/checkout/addArticle” is invalid. Please go back, reload the page and try again. {“uid”:“ae3ab83”}
[2018-10-22 10:00:35] core.CRITICAL: The provided X-CSRF-Token for path “/checkout/addArticle” is invalid. Please go back, reload the page and try again. {“uid”:“ae3ab83”}
[2018-10-22 10:00:35] core.ERROR: exception ‘Shopware\Components\CSRFTokenValidationException’ with message ‘The provided X-CSRF-Token for path “/checkout/addArticle” is invalid. Please go back, reload the page and try again.’ in /var/www/web57486/html/shopware/engine/Shopware/Components/CSRFTokenValidator.php:149 Stack trace: #0 [internal function]: Shopware\Components\CSRFTokenValidator->checkFrontendTokenValidation(Object(Enlight_Controller_ActionEventArgs)) #1 /var/www/web57486/html/shopware/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #2 /var/www/web57486/html/shopware/engine/Library/Enlight/Event/EventManager.php(220): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #3 /var/www/web57486/html/shopware/engine/Library/Enlight/Controller/Action.php(177): Enlight_Event_EventManager->notify(‘Enlight_Control…’, Object(Enlight_Controller_ActionEventArgs)) #4 /var/www/web57486/html/shopware/engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch(‘addArticleActio…’) #5 /var/www/web57486/html/shopware/engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #6 /var/www/web57486/html/shopware/engine/Shopware/Kernel.php(202): Enlight_Controller_Front->dispatch() #7 /var/www/web57486/html/shopware/vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 /var/www/web57486/html/shopware/vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true) #9 /var/www/web57486/html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #10 /var/www/web57486/html/shopware/vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #11 /var/www/web57486/html/shopware/vendor/symfony/http-kernel/HttpCache/HttpCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #12 /var/www/web57486/html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(143): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #13 /var/www/web57486/html/shopware/vendor/symfony/http-kernel/HttpCache/HttpCache.php(181): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #14 /var/www/web57486/html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(116): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #15 /var/www/web57486/html/shopware/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #16 {main} {“uid”:“ae3ab83”}
[2018-10-22 11:50:50] core.CRITICAL: The provided X-CSRF-Token for path “/checkout/addArticle” is invalid. Please go back, reload the page and try again. {“uid”:“4c9f48d”}
[2018-10-22 11:50:52] core.CRITICAL: The provided X-CSRF-Token for path “/checkout/addArticle” is invalid. Please go back, reload the page and try again. {“uid”:“4c9f48d”}
[2018-10-22 11:50:52] core.ERROR: exception ‘Shopware\Components\CSRFTokenValidationException’ with message ‘The provided X-CSRF-Token for path “/checkout/addArticle” is invalid. Please go back, reload the page and try again.’ in /var/www/web57486/html/shopware/engine/Shopware/Components/CSRFTokenValidator.php:149 Stack trace: #0 [internal function]: Shopware\Components\CSRFTokenValidator->checkFrontendTokenValidation(Object(Enlight_Controller_ActionEventArgs)) #1 /var/www/web57486/html/shopware/engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs)) #2 /var/www/web57486/html/shopware/engine/Library/Enlight/Event/EventManager.php(220): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #3 /var/www/web57486/html/shopware/engine/Library/Enlight/Controller/Action.php(177): Enlight_Event_EventManager->notify(‘Enlight_Control…’, Object(Enlight_Controller_ActionEventArgs)) #4 /var/www/web57486/html/shopware/engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch(‘addArticleActio…’)

Dann frag ich mal anders: Was sollte denn als Startseite erscheinen ?

Eine Einkaufswelt ?

Wurde was am template verändert ?

Ist die Kategorie Deutsch noch vorhanden ?

Plugins ?

Servervorraussetzungen für die neue 5.5 ?

Ja es ist eine Einkaufswelt eingerichtet mit einem Banner-Slider einem Text und 2 Artikelfeldern. Die erscheint aber schon nicht mehr auf der Startseite

Am Templete wurde nichts geändert ich verwende nur das Standard Template

Plugins werden auch nur spärlich verwendet: PayPal, Shopware Autoupdate, Statistics und Input Filter alles von shopware

In der Serverkonfiguration sind alle Häkchen auf grün!

 

 

welches paypal ? Das richtige für die neue Version?

Hast Du es schon mit einer anderen Einkaufswelt versucht ?

Das bringt aber alles nichts, da wir hier keine Glaskugel haben; mach doch mal das:

https://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html

 

Ich hab das Gefühl mich zu verzettelen aber folgendes: ich habe jetzt einmal im Plugin manager das PayPal Plugin (3.5.0) neu installiert danach wollte shopware eine „Theme Kompilierung“ die habe ich angestoßen diese läuft aber nicht durch und kann auch nicht abgebrochen werden.

in der Firefox Konsole gibt es folgende Fehlermeldung (gekürzt):

unreachable code after return statement[Weitere Informationen] base:15160
unreachable code after return statement[Weitere Informationen] ext-all.js:494
unreachable code after return statement[Weitere Informationen] ext-all.js:3574
Synchrone XMLHttpRequests am Haupt-Thread sollte nicht mehr verwendet werden, weil es nachteilige Effekte für das Erlebnis der Endbenutzer hat. Für weitere Hilfe siehe http://xhr.spec.whatwg.org/ ext-all.js:21:421280
unreachable code after return statement[Weitere Informationen] ext-all.js:1030
[Mitteilungsdetails anzeigen/ausblenden] TypeError: block.items.items[0] is undefined[Weitere Informationen] ext-all.js:352:1
success /backend/systeminfo/load/?f=m/Config|m/Path|m/File|m/Version|v/main/Window|v/systeminfo/Configlist|v/systeminfo/Pathlist|v/systeminfo/Filelist|v/systeminfo/Versionlist|v/systeminfo/Phpinfo|v/systeminfo/Timezone|store/Configs|store/Paths|store/Files|store/Versions|c/Systeminfo|c/Main&no-cache=1540280971+1+1:352:1 callback
https://www.modellbaushop-joachim.de/engine/Library/ExtJs/ext-all.js:21:67494
onComplete
https://www.modellbaushop-joachim.de/engine/Library/ExtJs/ext-all.js:21:422666
onStateChange
https://www.modellbaushop-joachim.de/engine/Library/ExtJs/ext-all.js:21:422309
bind/<
https://www.modellbaushop-joachim.de/engine/Library/ExtJs/ext-all.js:21:17404
uncaught exception: Ext.JSON.decode(): You’re trying to decode an invalid JSON String:










( ! ) Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/web57486/html/shopware/vendor/oyejorge/less.php/lib/Less/Output.php on line 26
Call Stack
# Time Memory Function Location
1 0.0000 245912 {main}( ) ../shopware.php:0
2 0.0033 1878136 Shopware\Components\HttpCache\AppCache->handle( ) ../shopware.php:122
3 0.0035 1887224 Symfony\Component\HttpKernel\HttpCache\HttpCache->pass( ) ../AppCache.php:105

Ruf mal deine Einkaufswelt auf im backend und nur einfach wieder speichern.

geht das?

Ansonsten dein paypal plugin ist für V5.5 nicht freigegeben, da musst du das neue nehmen.

Das Paypal deinstallieren und aus das neue 1.1.1 nehmen

Die max_execution_time auf 60 oder 90 hochsetzen oder vom Provider hochsetzen lassen.

Dass alles in der Servervorraussetzungen auf Grün steht, heist nicht, dass es funktionieren muss; es werden nur die Mindestvorraussetzungen erfüllt. Da kann es noch mehr Baustellen geben…

Ja die Einkauswelt speichern geht, wenn ich diese mal deaktiviere fällt auch die unendliche Ladezeit weg - die Seite ist dann halt leer.

 

PayPal Plugin jetz neu installiert Version 1.1.1 aber nach wie vor keine Theme Kompilierung möglich

Die max_execution_time steht auf benötigt wird 30 und eingerichtet ist auch 30 ist das zu wenig?

dann ist ein Plugin bei dir aktive was in den Einkaufswelten irgendwas macht.

Von welcher Version hast du geupdatet?

Ich vermute mal da liegt noch mehr an Leichen rum bei dir.

meine bisherigen Updates liefen am 01.08.2018 auf 5.4.6 dann auf 5.5.1 und zuletzt auf 5.5.2 alle ohne Probleme oder Fehlermeldungen

 

Plugins verwende ich nur sparsam (s.o.) alle Plugins von shopware

 

würde es helfen einem der Experten mal einen Zugang zum shop einzurichten?

 

Gruß Andreas

Also die Updatefunktion von Shopware erzeugt bei mir mittlerweile einen ziemlichen Frust!

Aber hier erst einmal was ich gemacht habe und vieleicht das Problem gelöst hat - genau weiß ich dass allerdings nicht:

Ich habe im “Theme Manager” das von mir verwendete shopware Standard Theme neu zugewiesen und danach die Kompilierung gestartet - die Kompilierung lief erst nicht durch irgendwann aber dann doch! Danach war die Startseite mit den Einkaufswelten wieder erreichbar und es ließen sich auch wieder Artikel in den Warenkorb legen.

Beim nächsten Update wieder Probleme danach waren alle Seitenformatierungen weg alle Shopinhalte standen Listenmäßig untereinander!

Auch hier hat es geholfen das Theme neu zuzuweisen und zu kompilieren - auch hier lief die Kompilierung erst nicht durch sondern brach mit einer Fehlermeldung ab.

Im ersten Fall hatte ich den Shop mehrere Wochen offline im zweiten Fall nur noch 30 Min - diese Aufforderung zum Updaten verursacht mir mittlerweile Angstzustände, nichts für ungut aber ein simples Update sollte so etwas nicht verursachen.

@mobajo schrieb:

Die max_execution_time steht auf benötigt wird 30 und eingerichtet ist auch 30 ist das zu wenig?

Nicht nur daran wird es scheitern; das sind die absoluten Mindestvorraussetzungen; Du kannst nicht erwarten dass ein Fahrrad mit 2 Tonnen Nutzlast noch fährt.

Beschäftige Dich doch erst mal mit den Basics:

Danach kannst Du noch mit der Forensuche Deine Probleme identifizieren.

Den Shop würde ich schon wegen der AGB erstmal abstellen.

Möglicherweise ist das Shopleben ja nichts für Dich.