[GELOEST] Fehler Bestellbearbeitung? Portokosten ändern sich

Hallöchen… Erstmal ein großes Lob für so einen tollen Shop, optisch wie administrativ. Allerdings habe ich jetzt beim Testen ein Problem festgestellt, was ich mir nicht erklären kann. Sobald ich eine Bestellung bearbeite, also die Bestellungs-Details aufrufe, um den Status zu ändern und dann wieder speichere, verändern sich die Portokosten. Aus EUR 2.95 werden EUR 295. Also immer Faktor 100. Ein nachträgliches ändern und speichern führt zum gleichen Ergebnis. So als ob der Datenbankserver auf ‚deutsch‘ stuende und somit der Punkt nicht als Komma interpretiert wird. Hier ein Screenshot direkt nach dem Öffnen: Ob ich was ändere oder nicht ist wurscht, sobald ich auf Speichern klicke, verändern sich die Versandkosten in Noch schöner sieht man das, wenn man oben den Rechnungsbetrag vergleicht. Bin ich doof? mach ich was falsch? oder ist das ein Bug?

Habe jetzt etwas mit den Sprachen im Backend gespielt - leider keine Aenderung. Hat denn jemand das gleiche Problem?

Hallo, anbei habe ich einen Fix bereit gestellt. Einfach die Datei entpacken und folgende Datei damit ersetzen: /templates/\_default/backend/order/view/detail/overview.js Über eine kurze Rückmeldung ob es geklappt hat würde ich mich freuen :wink: Viele Grüße, Benjamin Cremer :shopware:

1 Like

[quote=„Benjamin Cremer“]Über eine kurze Rückmeldung ob es geklappt hat würde ich mich freuen ;)[/quote] Hi Benjamin, merci fuer den Hotfix. Hat einwandfrei geklappt und funktioniert jetzt! Super… Schoenes WE, ich teste mal weiter!