Frontend und Backend nach Update Weiß

Hallo,

gleich zu Anfang: Ich bin nicht der größe Programmierungsprofi und mache sicherlich Fehler bzw. weiß einiges nicht, aber ich bin sehr lernfähig Halo

Zu meinem Problem: Ich habe Gestern meinen Shop so weit fertig gemacht und wollte noch etwas in dem Plugin Shop stöbern. Jetzt bin ich auf ein vorhandenes gestoßen, dass ein Update angezeigt hat (dummerweise weis ich nicht mehr was ( ich meine etwas mit lizenzmanager oder so?)). Gesagt getan, ich das Update installieren lassen und ab dem Moment geht einfach nichts mehr. Sowohl Frontend als auch Backend sind weiß und ich kann rein gar nichts mehr machen.

www.plotterbot.de

Google hilft mir nicht wirklich, also hoffe ich, dass ihr mir weiter helfen könnt.

In den Logs steht:

[Thu Apr 06 16:31:54 2017] [warn] [client 91.186.42.190] mod_fcgid: stderr: PHP Fatal error:  The file /var/www/vhosts/web1179.dehamd006.servertools24.de/httpdocs/engine/Shopware/Plugins/Community/Core/SwagLicense/Bootstrap.php cannot be decoded
[Thu Apr 06 16:31:54 2017] [warn] [client 91.186.42.190] mod_fcgid: stderr: by this version of the ionCube Loader.
[Thu Apr 06 16:31:54 2017] [warn] [client 91.186.42.190] mod_fcgid: stderr:  If you are the administrator of this site
[Thu Apr 06 16:31:54 2017] [warn] [client 91.186.42.190] mod_fcgid: stderr: then please install the latest version of the ionCube Loader.
[Thu Apr 06 16:31:54 2017] [warn] [client 91.186.42.190] mod_fcgid: stderr:  in Unknown on line 0

 

Ich habe das Internet schon nach der Installation des ionCube durchforstet, mehrere Sache gefunden, getestet aber es hat nichts gebracht.

Da ich den Shop erst fertig gemacht habe, will ich jetzt nicht wieder bei 0 anfangen. Bitte helft mir.

Liebe Grüße

Chris

Hast du denn einen Ioncube-Loader aktiv?
Das Lizenz Plugin brauch den Loader ja. Das könntest du in einer PHP-Info nachsehen.

@Moritz Naczenski schrieb:

Hast du denn einen Ioncube-Loader aktiv?
Das Lizenz Plugin brauch den Loader ja. Das könntest du in einer PHP-Info nachsehen.

Habe eben eine info.php mit Inhalt : 

phpinfo(); ?>

erstellt und aufgerufen, aber die Seite ist genau so leer. Mein Fehler? Bitte um Hilfe.

Hi,

lt. Fehlermeldung ist der installierte ionCube Loader veraltet. Eine neuere Version bekommst Du unter Loader Download - PHP Encoder, protection, installer and performance tools from ionCube, falls Du die Möglichkeit hast, diesen selbst auszutauschen. 

VG

@AIXPRO schrieb:

Hi,

lt. Fehlermeldung ist der installierte ionCube Loader veraltet. Eine neuere Version bekommst Du unter https://www.ioncube.com/loaders.php, falls Du die Möglichkeit hast, diesen selbst auszutauschen. 

VG

Hey,

ja das habe ich soweit auch verstanden nur bekomme ich den neuen nicht installiert. Er sagt immer ich soll die benötigte 5.6 Datei gegen eine neue zum installieren tauschen aber selbst dann geht es nicht oder ich habe die falsche… welchen Loader brauche ich denn genau (System)?

Nutzt Du PHP7 ?  Falls ja, geh’ mal auf 5.6 zurück - falls sich das Backend dann öffnen lässt, musst Du den Lizenzmanager aktualisieren, bevor Du PHP7 verwenden kannst.

Hierzu im Shopware Community Store die aktuell verwendete Shopware Version einstellen - danach wird Dir der richtige Lizenz-Manager zum Download angeboten.

Diesen dann im Backend -> Plugin-Manager händisch hochladen, bevor Du auf PHP7 zurückstellst.

VG

@AIXPRO schrieb:

Nutzt Du PHP7 ?  Falls ja, geh’ mal auf 5.6 zurück - falls sich das Backend dann öffnen lässt, musst Du den Lizenzmanager aktualisieren, bevor Du PHP7 verwenden kannst.

Hierzu im Shopware Community Store die aktuell verwendete Shopware Version einstellen - danach wird Dir der richtige Lizenz-Manager zum Download angeboten.

Diesen dann im Backend -> Plugin-Manager händisch hochladen, bevor Du auf PHP7 zurückstellst.

VG

Laut Plesk Oberfläche ist PHP 5.6.20 eingestellt also sag ich mal nein… Daran hab ich auch nichts geändert. Es hat alles prima funktioniert bis ich den Lizens-Manager geupdatet habe, bzw wollte danach ging ja nichts mehr.

Du könntest natürlich versuchen, in der DB Tabelle s_core_plugins das Plugin zu deaktivieren - vielleicht kommst Du dann wieder in das Backend.

Eine Deaktivierung kann natürlich zu Problemen mit lizenzpflichtigen Plugins führen …

VG

@AIXPRO schrieb:

Du könntest natürlich versuchen, in der DB Tabelle s_core_plugins das Plugin zu deaktivieren - vielleicht kommst Du dann wieder in das Backend.

Eine Deaktivierung kann natürlich zu Problemen mit lizenzpflichtigen Plugins führen …

VG

Hat tatsächlich funktioniert! Alles wieder da :smiley:

Allerdings ist jetzt die Frage was muss ich tun um den LizenzManager wieder zum laufen zu bekommen, damit ich im Verlauf keine Probleme bekomme?

Prima :wink:

Lizenzmanager im Backend löschen - dann vorgehen, wie in meinem vorherigen Post erwähnt:

Im Shopware Community Store die aktuell verwendete Shopware Version einstellen - danach wird Dir der richtige Lizenz-Manager zum Download angeboten.

Diesen dann im Backend -> Plugin-Manager händisch hochladen und aktivieren.

VG

 

2 Likes

@AIXPRO schrieb:

Prima :wink:

Lizenzmanager im Backend löschen - dann vorgehen, wie in meinem vorherigen Post erwähnt:

Im Shopware Community Store die aktuell verwendete Shopware Version einstellen - danach wird Dir der richtige Lizenz-Manager zum Download angeboten.

Diesen dann im Backend -> Plugin-Manager händisch hochladen und aktivieren.

VG

 

Alles klar vielen lieben Dank! :slight_smile:

Hallo.

wo genau finde ich denn im Account den Lizenz Managner zum Download?

Die richgtige Shopversion habe ich eingestellt und laut Plugin Manager ist der Lizenzmanager Version 1.2.0
Ein Download wird mir nicht angeboten.

Das errorlog wirft aber ständig folgende Meldung aus:

Shopware/Plugins/Community/Core/SwagLicense/Bootstrap.php was encoded by the ionCube Encoder for PHP 5.4 and cannot run under PHP 7.0.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0

Danke für einen Hinweis!

 

Gruß Dirk

 

 

 

Hi Dirk,

falls Dir dieser in Deinem Shopware Community Store Account nicht angeboten wird einfach erwerben (ist kostenlos):

Danach steht Dir dieser zum Download zur Verfügung.

VG

1 Like

Danke, das war es …