Shopware Lizenz Manager lässt sich nicht installieren

Hi, ich habe ein Shopupdate von 5.1.2 auf 5.2.26 gemacht. Parallel dazu wurde die PHP Version von 5.4.40 auf 5.6.30 geändert (php -v ergibt allerdings 5.6.5-1 cli ?). Während des Prozesse war der Lizenzmanager deinstalliert und schliesslich gelöscht. Das Update wäre sonst gar nicht durchgegangen. Der Lizenzmanager lässt sich allerdings nicht mehr installieren. Es kommt jedes mal nach “aktivieren” ein “500” und danach ist das Backend weg. Lösche ich per FTP den Ordner SwagLicense geht wieder alles, jedoch geben Verschlüsselte Plugins einen Fehler. Wenn ich den Cache mit der Console lösche (sh clear_cache.sh) bekomme ich zurück, dass ich IONCube 5.6 benötige. Bei Shopware is die richtige Shopversion hinterlegt. Gehostet wird bei @TimmeHosting‍ . Der Timmemitarbeiter tippt darauf, dass der Lizenzmanager falsch IONCube verschlüsselt ist? Hat jemand einen Tip? Gruss und Danke.

Hi,

eigentlich kann das nicht - Ansonsten würden uns die Leute hier auch sicher die Bude einrennen :wink:
Ich tippe auf die Ioncube Version beim Hosting. Wenn deine Installation im Shopware Account als passende Version eingestellt ist, dann bekommst du auch den passenden Download mit passender lauffähiger Ioncube Verschlüsselung (Der Store verschlüsselt das automatisch in verschiedenen Versionen und anhand der Shopware Version bekommst du passende Binaries ausgeliefert.)

Wenn du direkt einen 500er bekommt, müsste das ja auch in dem Log zu erkennen sein, welche Fehlermeldung da genau kommt.

Sebastian

PS: Gerade noch einmal selber getestet. PHP 5.6.31 und Shopware 5.2.27 mit neu geladenem Lizenz-Manager - > Funktioniert

1 Like

OK, vielen Dank bis hierher @SebastianKlöpper‍ . Ich habe eben noch mit Timme telefoniert. IONCuber liegt in der Version 6.0.9 vor. Reicht das für den Lizenz Manager? Anbei der Error.log mit installiertem Lizenz Manager beim Aufruf vom (leeren) Backend: 

 FastCGI sent in stderr: "PHP message: PHP Fatal error: Call to a member function getId() on null in /var/www/xxx/engine/Shopware/Components/DependencyInjection/Bridge/Session.php on line 90" while rea...

Hast du dazu eine Idee?