Fehlermeldung nach Update (ProjectContainer.php on line 8993)

Hallo Community, ich hatte gestern ein Update eingespielt.
Seitdem funktioniert leider nichts mehr.

Kann einer helfen ?

Fehler siehe
www.pvc-fuchs24.de

Hallo,

offenbar hast Du das Update eingespielt, obwohl noch nicht alle Plugins als kompatibel markiert waren.

In Deinem Fall liegt es offenbar am Amazon Pay Plugin von best.IT - Du kannst versuchen, dieses in der Datenbank-Tabelle s_core_plugins zu deaktivieren, indem Du beim Plugin „Active“ von 1 auf 0 setzt.

Stack trace: #0 /www/htdocs/w01c0f53/pvc-fuchs24.de/engine/Shopware/Plugins/Community/Frontend/BestitAmazonPay/src/BestitAmazonPay/DependencyInjection/CompilerPass/ParameterCompilerPass.php(58): ShopwareProductionaadfad7672200e252cba09e9166c394a91fdd1eeProjectContainer-

Viele Grüße

Hallo Scoopex, vielen Dank für die Info.
Hat Super geklappt.

Heyho,

ja, das Plugin von Amazon Pay (von der WorstIT ääh BestIT) hat eine erhebliche Anzahl an Komplikationen verursacht, als wir es auf unserer Testumgebung validiert haben. In der Regel können wir kleinere Probleme direkt lösen, aber in diesem Fall sind die Probleme so zahlreich, angefangen von Abweichungen in der Namenskonvention (shopware.oAuth.path / shopware.oauth.path, shopware.model.proxydir / shopware.model.proxyDir) über andere Fehlerarten.

Wäre schön, wenn das zeitnah gefixt wird, denn AmPay wird doch von einem hohen Prozentsatz an SW-Shops verwendet?

Danke & einen schönen Tag :slight_smile:

1 Like

gibt es hierzu wirklich keine Antwort?

Hey @shopwareuniverse,

von wem erwartest Du hier darauf eine Antwort. Ich denke nicht das die Kollegen der BestIT hier im Forum mitlesen.

Das Plugin ist doch klar bis maximal zur Shopware Version 5.6.10 als kompatibel markiert. Wer das Plugin nicht löscht und dennoch updatet macht sich in meinen Augen die Probleme aber auch ein bisschen selbst.

Ob das Plugin Kompatibel gemacht wird, liegt alleine in der Entscheidung des Herstellers.

Wir können die Hersteller nur darauf Hinweisen und es ihnen Nahe legen.

Viele Grüße
Tobi

Ansonsten einfach dieses hier benutzen, läuft problemlos auch mit 5.7.x, Probleme hatten wir damit auch bisher keine: Amazon Pay | Shopware Store

1 Like

Hallo @TobiasKassner,

ich hatte mir mehrere Reaktionen vorstellen können. Natürlich könnte die „BestIT“ lesen und als Feedback geben „sorry, wir sind dran, braucht aber noch ne Woche“. Es könnten auch andere Shopbetreiber fragen „ja, da warten wir auch schon dringend drauf“.

Wer lesen kann ist klar im Vorteil: ich hatte ja geschrieben dass wir in unserer TESTUmgebung das Update vorgenommen haben und die Probleme festgestellt haben. Das machen wir IMMER, auch mit den Plugins, die noch nicht explizit freigegeben wurden. Wenn es alle Tests in der Testumgebung besteht, geht das ganze ins Update der Produktivumgebung. Also nein, wir ignorieren diese Kompatibilitätsangaben nicht, sondern versuchen, Features auch nach Updates weiter zu nutzen, um nicht ewig zu warten, bis sich auch der letzte Plugin-Anbieter bequemt oder Zeit findet, die Kompatibilität offiziell zu bejahen.

Danke für die Alternative von @SmartStylez, dann werden wir mal die WorstIT hinter uns lassen und hoffen, dass dieser Anbieter besser sich um das Plugin bemüht als deren Mitbewerber bei AmPay.

Euch allen einen schönen Tag!
LG shopwareuniverse

Hey @shopwareuniverse,

ich hab ja auch nix von Produktiv- oder Testumgebung geschrieben. Was ich meinte war genau das was Du geschrieben hast: Wenn Du trotz gekennzeichneter Inkompatibilität ein Update durchführst, nimmst Du die möglichen Konsequenzen ja in Kauf. Böse gemeint war das nicht :wink:!

Einzelne Hersteller lesen hier im Forum auch immer mal Quer, aber dann eher im Plugin-Beriech, statt im Allgemeinen. Demnach wäre ein zusätzlicher Thread dort ggf. sinniger gewesen, wenn Du eine Antwort des Herstellers erwartest :man_shrugging: (So hatte ich deinen Beitrag zumindest interpretiert).

Aber Du hast ja jetzt eine Alternative und somit hoffentlich eine Lösung. :+1:

Grüße
Tobi

Hallo @TobiasKassner,

dann haben wir uns jetzt verstanden :slight_smile:

Stimmt, das sollte dann eher ins Plugin-Verzeichnis hier. Ich kann mich daran erinnern, dass aufgrund der deutlich geäußerten Kritik einer breiten Masse gegen das AmPay Plugin und dabei die qualitative Problematik bei WorstIT wurde damals die Ansicht vertreten, AmPay würde in den SW Standard aufgenommen. Ist das noch aktuell oder „nur“ für SW6 umgesetzt?

Wir sind noch in einem Projekt gebunden, aber sobald die Testumgebung modifiziert wurde werden wir uns auch an das Plugin machen - und wenn das Plugin bis dahin nicht kompatibel ist, fliegt es. WorstIT hat sich offenbar auch nicht wirklich gebessert…

LG shopwareuniverse

Für Shopware 5 ist das nicht in Planung, demnach wird das nicht mehr passieren.

Das SW6 Plugin wurde im Auftrag und in Kooperation mit einem Partner entwickelt, durch uns kostenlos angeboten und gewartet. Ein Core-Feature ist es hier aber auch nicht.