Fehlermeldung bei Shopware Update auf 5.2

Da geht es um eine ganz andere Änderung.

Bei den Fehler oben ist eine Tabelle bereits vorhanden. In dem jetzt genannten Migrationsfile geht es um was anderes 

Also das update läuft bei mir immer noch nicht.

Ich habe angefangen die tabellen zu löschen, die laut script schon existieren.
Zum Einen hat man das gefühl man dreht sich im kreis… da man gefühlte fünf mal die gleichen tabellen löscht um dann folgendes zu erhalten:

 

Error
Received the following error message:
Could not apply migration (Migrations_Migration708). Error: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'plugin_id' in 'field list' 

in der app.php finde ich auch kein debug, wie im link erläutert und eine Spalte   error_msg in der Tabelle   s _schema_version  finde ich auch nicht…
 

@totemshop schrieb:

Also das update läuft bei mir immer noch nicht.

Ich habe angefangen die tabellen zu löschen, die laut script schon existieren.
Zum Einen hat man das gefühl man dreht sich im kreis… da man gefühlte fünf mal die gleichen tabellen löscht um dann folgendes zu erhalten:

 

Error
Received the following error message:
Could not apply migration (Migrations_Migration708). Error: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘plugin_id’ in ‘field list’

in der app.php finde ich auch kein debug, wie im link erläutert und eine Spalte   error_msg in der Tabelle   s _schema_version  finde ich auch nicht…
 

Hallo,

 

genau das Gleiche bei mir. Update erzeugte die Tabellen, um dann den Fehler auszugeben. Das kannst du unendlich lang machen. Update auf 5.2 ist somit nicht möglich.

Ich frage mich, ob jemand das Update geschafft hat ohne diese Probleme. Scheint hier im Forum dazu noch keine Lösung zureisen. 

@Bosche schrieb:

Wie wurde das Problem hier gelöst?

Ich versuche von 5.2.0 BETA1 auf 5.2.1 zu aktualisieren. Bekomme allerdings einen ähnlichen Fehler:

Error
Received the following error message:
Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‚title‘

Please try to fix this error and restart the update.
Response
{„valid“:false,„errorMsg“:„Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‚title‘“}

ich habe leider auch das Problem mit dem Update von 5.2 Beta zu  5.2.1, löscht man den Eintrag in der Datenbank kommt ein neuer Hinweis es ist ein Fass ohne Boden.

Da es sich ja bei mir nur um ein Testshop handelt, in dem ich Änderungen und meine Plugin teste, werde ich diesen neu aufsetzen.

Uwe

Hallo zusammen,

 

ich bekomme den gleichen Fehler. Gibt es dafür mittlerweile eine Lösung?

 

Gruß

Henrik

Ich hatte den Fehler ebenfalls und konnte ihn wie folgt lösen.

Einfach folgende Datenbanken vor dem Update löschen:

DROP TABLE `s_filter_options_attributes`, `s_filter_values_attributes`, `s_product_streams_attributes`, `s_attribute_configuration`;


DROP TABLE `s_user_addresses_attributes`, `s_user_addresses`, `s_user_addresses_migration`;

 

Danach lief das Update fehlerfrei durch.

6 Likes

Danke!

Bei mir lief es jetzt auch durch!

@Zzotti schrieb:

Ich hatte den Fehler ebenfalls und konnte ihn wie folgt lösen.

Einfach folgende Datenbanken vor dem Update löschen:

DROP TABLE s_filter_options_attributes, s_filter_values_attributes, s_product_streams_attributes, s_attribute_configuration;

DROP TABLE s_user_addresses_attributes, s_user_addresses, s_user_addresses_migration;

 

Danach lief das Update fehlerfrei durch.

Aber warum denn auch die s_user_…? Da stehen doch die Kundendaten drin?  Undecided 

1 Like

Hallo,

 

habe genau das gleiche Problem vom Update von 5.1.6 auf 5.2.9

“valid”:false,“errorMsg”:"Could not apply migration (Migrations_Migration708). Error: SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘s_filter_values_attributes’ already exists "}

Ich erhalte ebenfalls die Hinweise, dass die Tabellen bereits existieren. Das löschen aller oben angegebenen Tabellen habe ich ebenfalls versucht und habe dann die Domain:

https://meine-Domain/recovery/update/index.php/dbmigration

erneut aufgerufen.

 

Dann erhalte ich den Fehler:

"Received the following error message:

Could not apply migration (Migrations_Migration709). Error: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‘default_shipping_address_id’

Please try to fix this error and restart the update.

Response

 {"valid":false,"errorMsg":"Could not apply migration (Migrations\_Migration709). Error: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'default\_shipping\_address\_id' "}

"

 

Das war schon der zweite Versucht nach einem Backup.

Ich brauche auch Hilfe von jemanden, der für mich das Update durchführen kann.

 

Grüße Nicolai

 

 

 

Hallo Nicolai

siehe auch hier: https://forum.shopware.com/discussion/41729/datenbankfehler-bei-update-auf-5-2-9

Da gibt es bei dir schon vorher was in der Datenbank, was da nicht hingehört. Was erst mit Shopware 5.2.0 hinzukommen darf/kann.

Sebastian

Oben genannten Thread nach geht es um die bereits vorhandene Tabelle s_filter_values_attributes

Ich möchte auch von 5.1.6 auf 5.2.9 updaten und habe diese Tabelle ebenfalls in meiner Version 5.1.6
die Tabelle ist leer

Soll ich die Tabelle vor dem Update einfach löschen?

Hallo Sebastian,

danke für den Link. Ich hatte das BackUp von Domainfactory einspielen lassen. Jetzt hab ich aber das Problem, dass selbst bei meiner funktionierenden Version Tabellen in der Datenbank vorhanden sind, die erst mit dem Update kommen, da wir bereits zwei mal ein BackUp haben einspielen lassen.

Was kann ich denn nun machen ? Gibt es eine Drop-Table Anweisung für alle betroffenen Tabellen, die nach dem Update 5.1.6 hinzukommen, damit ich diese manuell in der DB löschen kann? Es handelt sich um das Live-System.

Grüße Nicolai

Es muss sichergestellt werden, dass das Backup der Datenbank auf jeden Fall in eine leere Datenbank eingespielt wird.

Es gibt keine Anweisung, die das zu einem späteren Zeitpunkt bereinigt

Sebastian

Ich habe dasselbe Problem! Die Tabelle s_filter_values_attributes wird vom Updater immer wieder neu angelegt, nachdem sie manuell gelöscht wurde. Danach kommt sofort wieder die Fehlermeldung.

Daher nochmal die Frage: Welche Tabellen wurden in 5.2 hinzugefügt? Offenbar haben wir hier eine Datenbank die unter 5.1 läuft, wo aber vorher schon mal ein Update auf 5.2 versucht wurde, da sind jetzt lauter leere Tabellen drin (ich tippe auf die Freitextfelder).

Diese Tabellen müssen vor Start des Updaters manuell gelöscht werden, sonst bleibt der Ablauf hängen.

Gibt es vielleicht trotzdem eine Hilfestellung wie das Problem zu lösen ist?

Es gibt sicher nicht wenige User die beim Update von 5.1.6 auf 5.2.x wieder ein Backup hatten einspielen müssen, weil nach dem Update der Shop nicht mehr zu gebrauchen war.

Welche Tabellen müssen entfernt werden?

Vor dem Restore die Datenbank droppen und neu anlegen.

das nutzt nichts, im Backup sind die Tabellen ja bereits enthalten, da diese vor längerer Zeit durch einen Updateversuch bereits eingespielt waren

Daher nochmal die Frage: Welche Tabellen wurden in 5.2 hinzugefügt?

Hallo, 

das alleine hilft dir ja nicht. Es gibt teilweise große Migrationen in der Datenbank. Da musst du dich also wirklich sonst Stück für Stück durcharbeiten 

Alle Datenbank Änderungen / Migrationen sind hier erfasst shopware/_sql/migrations at 5.2 · shopware/shopware · GitHub

Es gibt ja eine Migration, die immer fehlschlägt. Genau diese muss man dann manuell korrigieren. Dann in der Tabelle s_schema_version diese Migration als erledigt markieren und das Update wieder ausführen 

Sebastian 

Siehe auch hier: https://forum.shopware.com/discussion/comment/177467/#Comment_177467