Fehler im /checkout/finish

Moin, mein /checkout/finish hat sich verabschiedet. Das einzige was ich nachvollziehen kann ist, dass der Hersteller vom Fastbill Plugin sein Plugin installiert hat. Sagt aber, dass es damit nichts zu tun haben kann. Bevor ich lang drum herum rede, hier mal die Fehlermeldung: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘usrdb_emecrjas.s_plugin_cc_items’ doesn’t exist in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(303): Zend_Db_Statement_Pdo->_execute(Array) #1 Zend/Db/Adapter/Abstract.php(480): Zend_Db_Statement->execute(Array) #2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query(’\n UP…’, Array) #3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend_Db_Adapter_Pdo_Abstract->query(’\n UP…’, Array) #4 Enlight/Components/Db/Adapter/Pdo/Mysql.php(120): Enlight_Components_Db_Adapter_Pdo_Mysql->query(’\n UP…’, Array) #5 engine/core/class/sOrder.php(883): Enlight_Components_Db_Adapter_Pdo_Mysql->executeUpdate(’\n UP…’, Array) #6 engine/core/class/sOrder.php(654): sOrder->refreshOrderedVariant(‘EF7041.03’, ‘1’) #7 [internal function]: sOrder->sSaveOrder() #8 cache/proxies/sOrderProxy.php(11): call_user_func_array(Array, Array) #9 Enlight/Hook/HookManager.php(191): Shopware_Proxies_sOrderProxy->executeParent(‘sSaveOrder’, Array) #10 cache/proxies/sOrderProxy.php(23): Enlight_Hook_HookManager->executeHooks(Object(Shopware_Proxies_sOrderProxy), ‘sSaveOrder’, Array) #11 Shopware/Controllers/Frontend/Checkout.php(563): Shopware_Proxies_sOrderProxy->sSaveOrder() #12 Shopware/Controllers/Frontend/Checkout.php(242): Shopware_Controllers_Frontend_Checkout->saveOrder() #13 Enlight/Controller/Action.php(159): Shopware_Controllers_Frontend_Checkout->finishAction() #14 Enlight/Controller/Dispatcher/Default.php(528): Enlight_Controller_Action->dispatch(‘finishAction’) #15 Enlight/Controller/Front.php(228): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #16 Shopware/Kernel.php(141): Enlight_Controller_Front->dispatch() #17 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(473): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #18 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #19 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(244): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #20 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(261): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #21 Shopware/Components/HttpCache/AppCache.php(132): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #22 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(190): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #23 Shopware/Components/HttpCache/AppCache.php(113): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #24 shopware.php(91): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #25 {main} Das Fastbill Plugin habe ich wieder entfernt, auch den Server auf Dateireste geprüft. Andere Plugins habe ich soweit deaktiviert im try-n-error Verfahren geprüft ob es an etwas lag. Ausgelöste Bestellungen kommen trotzdem im BE an, können aber nicht administriert werden. Ich komme von einem anderen Shopsystem, bin also bei SW Neuling und werde bei der Fehlermeldung leider nicht schlau wo ich weiter suchen sollte. Freue mich über einen Tipp. Danke! Grüße Michael

Hi, die Tabelle “s_plugin_cc_items” gehört nicht zum Shopware-Standard. Ich glaube, dass die zum CouchCommerce-Plugin gehört - falls du das im Einsatz hast. Irgendein Plugin versucht zumindest auf die Tabelle zuzugreifen - die nicht existiert. Besten Gruß, Daniel

1 Like

Danke. Das CouchCommerce Plugin hab ich zwar drauf, aber nicht aktiv. Ich habe es nun ganz runtergenommen, auch FTP geschaut ob die Dateien weg sind. dennoch der Fehler. EDIT 27.11.2015 Ich habe den Fehler gefunden bzw es gelöst bekommen. Es lag wohl daran, dass ich Couchcommerce testweise mal installiert, aktiviert hatte und dann wieder deinstalliert. Warum genau das jetzt so ist, weiß ich nicht. Was ich mir als SW Neulig aber merken muss ist, dass wenn ein Plugin installiert wurde, man es nicht sicher deaktivieren / löschen kann ohne dass es zu Problemen kommt.