Fehler beim Frontendaufruf "checkout/cart"

Hallo ich erhalte folgende Fehlermeldung beim Aufruf vom Warenkorb bzw.Checkout (checkout/cart) im Frontend: Fatal error: Unsupported operand types in /var/www/xxxxx/xxx/xx/xx/engine/core/class/sAdmin.php on line 2778 shopware 3.5.0 Rev 3650 Danke für eine Hilfe bzw. einen Tipp beste Grüße mac

Hi, dieses Thema wurde hier schon mehrfach diskutiert, ich denke mal,Du hast noch eine PHP Version, die nicht den Mindestanforderungen entspricht!? Was sagt denn die Systeminfo unter Einstellungen / Systeminfo? Gruß´ Stefan

hi, das liegt an der php-version. unter php 5.2.12 läuft shopware nicht.

Hallo, danke für die wirklich schnellen Antworten :wink: Zur vorhandenen PHP Version: 5.2.6 Benötigt 5.2.5 Der Ckeck zeigt Status ok. Und eine Abwärtskompatibilität sollte eigentlich in diesen PHP Versionen gegeben sein. Ansonsten funktioniert auch fast Alles. Desweiteren, my Server, also ich kann fast machen was ich möchte :wink: PHP anpassen u.s.w… Ich hatte mir die Fehlermeldung im PHP Code auch schon genauer angesehen, nur habe ich bisher keine Fehlerlogik erkannt. best regards

[quote=“Stefan Heyne”]Hi, dieses Thema wurde hier schon mehrfach diskutiert, ich denke mal,Du hast noch eine PHP Version, die nicht den Mindestanforderungen entspricht!? Was sagt denn die Systeminfo unter Einstellungen / Systeminfo? Gruß´ Stefan[/quote] Hi Stefan, zu deiner Antwort, habe erst nach meinem vorigem Posting gelesen das Du ja von der ShopCompany bist. Also die PHP Mindestanforderuneg sollten ja wie in meinem anderen Posting geschrieben erfüllt sein. Es wird ja auch alles als ok angezeigt. Aber davon unbenommen, eine Abwärtskompatibilität innerhalt der 5.2 PHP sollte doch gegeben sein, oder etwa nicht ? Und es betrifft nur diesen von mir geposteten Aufruf. greetings mac

Benutze bitte den aktuellen System Check http://www.shopware.de/downloads/SystemCheck.zip Dort steht min 5.1.12 Gruß

[quote=„TEiling“]Benutze bitte den aktuellen System Check http://www.shopware.de/downloads/SystemCheck.zip Dort steht min 5.1.12 Gruß[/quote] Hallo, danke für deine Antwort. Ich habe den Systemcheck benutzt. Das ist aus meinen Antworten ersichtlich. Der SystemCheck zeigt alles als ok an. Er zeigt auch die angesprochene PHP Version als ok an. Da hier oft auf die falschen PHP Versionen verwiesen wird. Ich hatte es auch in meinen Postings kurz angerissen, eine Abwärtskompatibilät sollte eigentich in gewissen Toleranzen und Grenzen gegeben sein. Ich finde es freundlich und nett, wenn jeder Poster denkt und schreibt, das er in schneller Hilfsbereitschaft sofort immer auf das CheckTool verweisen muss :wink: Ich habe in meinen Postings geschrieben das ich es verwendet habe. Mir geht es um einfache Trial and Error Antworten, damit auch weiteren,zukünftigen Usern bei der Lösung solcher Probleme schnell geholfen werden kann. Mein Problem, Resume’ und Frage: Es erscheint die folgende Fehlermeldung beim Aufruf vom Warenkorb bzw.Checkout (checkout/cart) im Frontend: Fatal error: Unsupported operand types in /var/www/xxxxx/xxx/xx/xx/engine/core/class/sAdmin.php on line 2778 in der shopware 3.5.0 Rev 3650 aufgrund der vorhandenen und installierten PHP Version: 5.2.6 Benötigt wird laut SystemCheck 5.2.5 Der SystemCheck zeigt aber Status ok (grün;-).

Hi Mac, als min. Vorraussetzung wird PHP 5.2.12 benötigt. Daher kann es bei älteren Version, wie es bei dir z.B. der Fall ist, genau zu den angesprochenen Problemen kommen. Viele Funktionen laufen natürlich auch auf älteren Versionen. Eine Garantie können wir das natürlich nicht geben. Falls du also bei dir eine aktuelle PHP Version installierst (> 5.2.12) dann sollten diese Meldungen direkt der Vergangenheit angehören. Ps: in deinem Posting gehst du noch auf Shopware 3.5 ein. Ich empfehle dir da noch auf die aktuelle 3.5.1 upzudaten. So kannst du ggf. anderen Versionsproblemen direkt ausweichen, da dort einige Anpassungen eingeflossen sind. Hier ist auch noch das passende Thema LINK Viele Grüße :shopware:ebastian

1 Like

[quote=“Sebastian Klöpper”]Hi Mac, als min. Vorraussetzung wird PHP 5.2.12 benötigt. Daher kann es bei älteren Version, wie es bei dir z.B. der Fall ist, genau zu den angesprochenen Problemen kommen. Viele Funktionen laufen natürlich auch auf älteren Versionen. Eine Garantie können wir das natürlich nicht geben. Falls du also bei dir eine aktuelle PHP Version installierst (> 5.2.12) dann sollten diese Meldungen direkt der Vergangenheit angehören. Ps: in deinem Posting gehst du noch auf Shopware 3.5 ein. Ich empfehle dir da noch auf die aktuelle 3.5.1 upzudaten. So kannst du ggf. anderen Versionsproblemen direkt ausweichen, da dort einige Anpassungen eingeflossen sind. Hier ist auch noch das passende Thema LINK Viele Grüße :shopware:ebastian[/quote] Hallo, danke, ich hatte es gestern spät nicht richtig gelesen und habe meine PHP Versionen vertauscht. Damit hat es sich geklärt und auch aufgeklärt. Ein Dank auch an Alle die hier im Forum sehr schnell und freundlich antworten. mac