Fatal Error beim Öffnen des Warenkorb

Hallo, ich habe vor einigen Tagen die aktuellste Shopware Version 3.5.2 mit Hilfe des Online-Installer installiert. Bei der Installation hat alles perfekt funktioniert. Nachdem ich einen Test-Artikel angelegt und die Versandkosten, Zahlungsarten etc. eingestellt habe wollte ich einen Artikel bestellen. Beim Klick auf „In den Warenkorb“ kam folgende Fehlermeldung : Fatal error: Unsupported operand types in /srv/www/test-shop/engine/core/class/sAdmin.php on line 2778 Vielen Dank schon mal vorab für Eure Hilfe.

Mehr kommt nicht als Fehlermeldung? Kannst du mal im backend unter plugins schauen, ob dort debug aktiviert ist?

Hi michel, diese Fehlermeldung kommt wenn du eine zu alte PHP-Version bei dir installierst hast. Shopware benötigt mindesten PHP-Version 5.2.12. Siehe: http://www.shopware.de/systemanforderungen/ Viele Grüße Heiner

1 Like

Hallo, derzeit ist die PHP Version 5.2.6 installiert und die Plugins Debug/Benchmark/BenchmarkEvents sind aktiviert. Wenn ich Firebug aktiviere und die Konsole aufrufe werden mir keine Fehlermeldungen angezeigt (. Muss ich hier noch etwas einstellen ? Zur Info: Derzeit läuft auch noch ein Shopware Shop Ver. 3.0.5 auf dem selben Server und der funktioniert einwandfrei. Hier noch die Screenshots zu Firebug und der Shopware SystemInfo:

Hi, Du nutzt glaube ich eine veraltete check.php, deshalb wird die PHP Version noch nicht bemängelt. Du musst aber definitiv auf PHP 5.2.12 oder höher und Dein Problem wird danach direkt behoben sein zu 100 %. Schönen Abend noch… Stefan

1 Like

Hi Stefan, jetzt funktioniert es. Danke. Nach einem versehentlichen Upgrade auf PHP 5.3.x, nachdem nichts mehr funktioniert hat (ZendOptimizer), habe ich jetzt PHP 5.2.14 und es funktioniert alles super. :thumbup: