Facebook Plugin funktioniert nicht

Hallo, ich habe ein Problem mit einem Shopware-Shop 4.0.4 Facbook-Plugin. Ich möchte gerne das Facebook Plugin nutzen und habe dazu auch schon eine Anleitung und Beschreibungen zu gefunden. Ich habe das Plugin aktiviert und auch eine Facebook App ID erstellt und eingefügt. Leider macht der Shop nicht, was ich möchte. Der „Like“-Button erscheint gar nicht - der Reiter „Facebook-Kommentare“ erscheint - reagiert aber nicht auf einen klick. Hat jemand einen Lösungsvorschlag für mich? Danke im Voraus.

Hallo, der Like-Button ist auch nach meiner Erfahrung fehleranfällig. Wir implementieren ihn daher grundsätzlich selber. Mit dem Standardplugin erscheint er manchmal und manchmal nicht. Die Kommentarfunktion funktioniert eigentlich immer. Wo kann man das Verhalten denn nachvollziehen? Viele Grüße H. Thomas Kontakt: info@mycetome.de

Danke schon mal für die Antwort - zu sehen ist das unter: http://www.chilli-und-choko.de

[quote=“niels”]Danke schon mal für die Antwort - zu sehen ist das unter: http://www.chilli-und-choko.de[/quote] Hallo, in diesem Fall ist das Template bei der Shoperstellung an entscheidenden Stellen verändert worden. Der Like-Button wird innerhalb von detailbox_middle an einen Container “gehangen”. detailbox_middle ist aber komplett entfernt, da kann das Plugin seinen Inhalt auch nirgendwo mehr anhängen. Ähnliches unten mit dem Facebook-Kommentar: Dort ist nur der HTML-Code für den Tabreiter (Facebook-Kommentar) in die ul-Liste eingefügt, aber der div-Container mit dem Formular selber fehlt. Ich vermute, da ist auch etwas geändert worden. Das habe ich aber nicht mehr weiter angesehen. Wenn Interesse an kommerzieller Unterstützung bei der Integration der zwei Komponenten besteht, bin ich über info@mycetome.de zu erreichen. Bei Salome-Schmuck.de sind auch noch mehr Social-“Like”-Buttons integriert. Hier muss das Template des Plugins überarbeitet werden, um es überhaupt verwenden zu können. Angesehen habe ich mir dies: http://www.chilli-und-choko.de/produkte … apple?c=25 Grundsätzlich muss vor dem Löschen von HTML-Elementen des Standardtemplates überprüft werden, ob Plugins diese für ihre Templateerweiterungen benötigen. Auch die Abhängigkeit der Ajax-Funktionalitäten von diesen muss getestet werden. Viele Grüße H. Thomas PS: Die Seite reagiert sehr träge.

1 Like

Vielen Dank, ich hatte mir schon so etwas gedacht. Ich melde mich per Mail, falls ich Unterstützung brauche.