[erledigt] Plugin: facebook "compatibility mode"

Hallo, seit heute erhalten wir beim Facebook-Plugin immer folgende Meldung: [quote]Warning: this comments plugin is operating in compatibility mode, but has no posts yet. Consider specifying an explicit ‘href’ as suggested in the Dokumentation des Kommentarplugins to take advantage of all plugin features.[/quote] Wie kann man diesen “Fehler“ beseitigen?

und hoch damit…hat jemand eine Idee woran das liegt?

Hallo Sebastian, hallo Porter, Facebook hat sein Comment-Plugin gearbeitet, womit neue Features eingeflossen sind. Weitere Informationen zu den Änderungen können im Developer Blog von Facebook bezogen werden. Um auf den neuen Standard aufzusetzen und somit die “compatibility mode” Meldung zu entfernen muss das Template “/_default/frontend/plugins/facebook/blocks_detail.tpl” editiert werden. Hier befindest sich in Zeile 40 folgender Code: [code]

[/code] Dieser Code muss mit den folgenden Code-Snippet überschrieben werden: [code]div id="fb-root"\>[/code] Ich konnte die Lösung leider nicht testen, deshalb bin ich auf eurer Feedback angewiesen. Viele Grüße, Stephan Pohl :shopware:
3 Likes

Feedback: Es erscheint der Ladebalken von Facebook, dahinter erscheint im roten Kasten die Fehlermeldung:[quote] Das Kommentar-Plugin benötigt ein href-Parameter.[/quote]

Ich habe den Fix bei dir unter „_local“ eingebaut. Jetzt funktionieren die Facebook-Kommentare wieder wie gewohnt. Viele Grüße, Stephan Pohl :shopware: [quote=„kaffeeteam“]Feedback: Es erscheint der Ladebalken von Facebook, dahinter erscheint im roten Kasten die Fehlermeldung:[quote] Das Kommentar-Plugin benötigt ein href-Parameter.[/quote][/quote]

1 Like

Hi Stephan, vielen Dank! Habe noch 3.5.3, d.h. meine blocks_detail.tpl hatte keine Zeile 40…habe es jetzt in der Zeile 14 geändert…Funktioniert!..:thumbup:

Danke, funktioniert

Die letzte Lösung würde uns auch interessieren ? Gibt es ein Update des Facebook plugins ?

Super, hat geklappt! Danke!

Hallo, ich weiß dieser Thread ist uralt, aber ich habe das ich habe genau das Problem: “Das Kommentar-Plugin benötigt ein href-Parameter.” Wie genau wurde das gelöst?