engine/Library/ExtJs/ext-all.js Zeilennummer: 21

Hallo seit update 4.0.3 erhalte diese Meldung, wenn ich “Kategorien” öffnen möchte: engine/Library/ExtJs/ext-all.js Zeilennummer: 21 Nachricht: TypeError: c is not a constructor Lokaler und Server Cache gelöscht, Seite mehrmals neugeladen, ohne Erfolg. Hilfe…

Hallo, den selben Fehler bekomme ich auch. Bei mir kam der Fehler, als ich die Grundeinstellungen aufrufen wollte. Nach einem Relog konnte ich zumindest die Grundeinstellungen wieder öffnen, der Fehler taucht dann aber an einer anderen Stelle auf. Ab und zu bekomme ich auch diesen Fehler: /engine/Library/ExtJs/ext-all.js Zeilennummer: 759 Nachricht: TypeError: me.store is null Gruß Manuel

Da muss ich mich leider einreihen… Dazu bekomme ich noch folgendes (s.u.) Ich hatte bis zur 4.02 keinerlei Fehlermeldungen im backend :frowning: Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Zend_Session::start() - /engine/Library/Zend/Session.php(Line:484): Error #8 session_start() [function.session-start]: ps_files_cleanup_dir: opendir(/tmp) failed: Permission denied (13) in Zend/Session.php on line 504 Stack trace: #0 Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(410): Zend_Session::start(Array) #1 Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Backend_Auth_Bootstrap->onInitResourceBackendSession(Object(Enlight_Event_EventArgs)) #2 Enlight/Event/EventManager.php(194): Enlight_Event_Handler_Plugin->execute(Object(Enlight_Event_EventArgs)) #3 Enlight/Bootstrap.php(300): Enlight_Event_EventManager->notifyUntil(‘Enlight_Bootstr…’, Array) #4 Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(447): Enlight_Bootstrap->loadResource(‘BackendSession’) #5 Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Backend_Auth_Bootstrap->onInitResourceAuth(Object(Enlight_Event_EventArgs)) #6 Enlight/Event/EventManager.php(194): Enlight_Event_Handler_Plugin->execute(Object(Enlight_Event_EventArgs)) #7 Enlight/Bootstrap.php(300): Enlight_Event_EventManager->notifyUntil(‘Enlight_Bootstr…’, Array) #8 Enlight/Bootstrap.php(232): Enlight_Bootstrap->loadResource(‘Auth’) #9 Enlight/Application.php(500): Enlight_Bootstrap->hasResource(‘Auth’) #10 Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(230): Enlight_Application->__call(‘Auth’, Array) #11 Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(230): Shopware->Auth() #12 Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(211): Shopware_Plugins_Backend_Auth_Bootstrap->checkAuth() #13 Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Backend_Auth_Bootstrap->onPreDispatchBackend(Object(Enlight_Event_EventArgs)) #14 Enlight/Event/EventManager.php(156): Enlight_Event_Handler_Plugin->execute(Object(Enlight_Event_EventArgs)) #15 Enlight/Controller/Action.php(122): Enlight_Event_EventManager->notify(‘Enlight_Control…’, Array) #16 Enlight/Controller/Dispatcher/Default.php(521): Enlight_Controller_Action->dispatch(‘getArticlesActi…’) #17 Enlight/Controller/Front.php(214): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #18 Shopware/Bootstrap.php(79): Enlight_Controller_Front->dispatch() #19 Enlight/Application.php(192): Shopware_Bootstrap->run() #20 shopware.php(74): Enlight_Application->run() #21 {main} Ich bin sehr erfreut, dass das Script der Meinung ist, diese kryptischen Zeilen würden mir weiter helfen…tun sie aber nicht :stuck_out_tongue: Ich hoffe, dass hier jemand eine Lösung parat hat. Gruß Roland

Das muss man als Entwickler doch sehen… versteh ich nicht. Shopware macht hierzu noch keine Äusserungen?

Hallo, hier gibt es schon eine Info post43951.html#p43951 Die Meldung sollen ab 4.0.3 also nur weitere Infos bereitstellen ohne z.B. auf Firebug zurückgreifen zu müssen. So lassen sich an den einzelnen Stellen, sollte mal etwas auftreten, leichter analysieren aufgrund der genauen Meldung. Sehr hilfreich auch bei Plugins oder eigene Erweiterungen. Die Melfung gibt dann genau an, in welcher Datei ein Problem vorliegt und kann diese gezielt ändern oder entfernen. Die Meldung von ghd ist da auch ein gutes Beispiel. Es handelt sich dabei um kein Shopware Problem, sondern um eines auf dem Server. Der /tmp Ordner besitzt wohl nicht nich korrekte Rechte. Da kein Zugriff möglich ist zeigt Shopware jetzt einen Fehler. Ggf. ist das auch nur temporär. PS: Die Meldung wurde auch schon einige Male hier behandelt - auch bei anderen Shopware Versionen. ankundigungen-und-news-f17/shopware-4-0-3-ab-jetzt-verfugbar-t8931-20.html#p44042

Ok. Welche Rechte müssen den gesetzt werden? wird dies auch mein Problem lösen? Mit den Kategorien? oder was muss ich da machen?

Das klingt ja alles plausibel, aber wie ich bereits erwähnt hatte… Ich hatte bis zur 4.02 keinerlei Fehlermeldungen im backend. In der php.ini steht das Verzeichnis /tmp als session-save-path und mehr kann ich als “Nicht-RootServer-Besitzer” auch nicht dran schrauben. Wenn sich im Laufe von SW4.0 die Systemanforderungen grundlegend ändern würden, dann wäre das für einen “normalen” Shopbetreiber wie mich echt ein Problem. Werde jetzt mal den Hoster kontaktieren, ob man an diesem /tmp etwas ändern kann. Sollte das nicht gehen, haben wir ein Problem :frowning:

Hallo, die Systemvoraussetzungen haben sich nicht geändert! Nur das Reporting wurde in Shopware 4.0.3 eingebaut - daher hast du vorher diese Meldung einfach nur nicht gesehen, da diese einfach im Hintergrund liefen. Das hat also nicht mit Systemanforderungen oder Funktionen zu tun, sondern ist nur eine reine zusätzlicher Ausgabe die aktiviert wurde. Mehr nicht… Du kannst die ja generell ignorieren und regulär weiterarbeiten - Nur ist es ja sinnvoll Probleme die ggf. im Hintergrund auftreten angezeigt zu bekommen.

1 Like

OK…jetzt hat es auch der DAU verstanden :wink: Vielen Dank für die Ausführungen. Ich bin natürlich mit Dir einig und hoffe, dass sich die Probleme bei mir lösen lassen. Fehler “wegklicken” macht auf Dauer nicht wirklich froh.