Database problems: "Please fill in all fields."


I am currently trying to install shopware on a Linux server hosted by Strato with Ubuntu 20.04.3 LTS and plesk Obsidian 18.0.38 (Strato package: Linux V10-8 ( However, at the moment I always get the error „Please fill in all fields.“ when installing the database. Filled in are server with „localhost“ user with the respective DB user, the password with the corresponding password. The DB name is automatically and correctly taken over without me having to enter it. A connection to the DB server seems to be established.
If I click on „Start installation“, the above-mentioned fields are cleared and I receive the above-mentioned error message - both in Firefox and edge.

I want to install v6.4.4.0 on the above server. I have downloaded the installation file from

An SSL is deposited via Strato.

PHP 7.4.23 is installed. FPM application is selected as the handler. The memory_limit is set to 512 in the PHP settings (not in php.ini). The max_execution_time was increased to 120 and the upload_max_filesize was set to 8. All included PHP extensions, except snmp and xdebug, are enabled (left on default settings).

I hope I have provided enough information for now - but feel free to provide more.

I am looking forward to your support.
Best regards

Hi Jonas /@layer42

Shopware 6 system requirements state, that you need at least PHP 7.4.3 or higher. As you are using PHP 7.4.23, this could be an issue.
Also, what database system are you using and what version? Our system requirements state the following:
MySQL 5.7.21 or higher
MySQL versions 8.0.20 and 8.0.21 are not compatible due to technical problems in these versions.

MariaDB 10.3.22 or higher
MariaDB versions 10.3.29, 10.4.19 and 10.5.10 are not compatible due to technical problems in these versions.

You can also check the rest of the requirements in our documentation.

Kind regards

Hey Patrick,

we are using MariaDB 10.3.31.
I will try to change the PHP version.

The installation initially worked without any changes.

On the last page I got the following error. Do you have any idea?

Slim Application Error
The application could not run because of the following error:
Type: Shopware\Recovery\Common\HttpClient\ClientException
Code: 60
Message: SSL certificate problem: unable to get local issuer certificate
File: /var/www/vhosts/
Line: 97
#1 /var/www/vhosts/\Recovery\Common\Httpclient\Curlclient->post(
#2 [internal function]: Closure-›{closure}()
#3 /var/www/vhosts/
#5 /var/www/vhosts/\Route->invoke()
#9 internal functionl: Closure->{closure}0)
#11 | internal functionl: slim\DeferredCallable->invoke0)
#18 {main}

The page looks like:

Hi Jonas /@layer42

try to clear the cache, you can do this under Settings > System > Caches & Indexes

The error you posted tells me that you have some issues with you SSL certificate, so you might want to check that.

Best regards,
Timmy Clark

This problem also occurs, when the php-session can´t be saved on the server (eg. missing rights).

The path can be found in: session.save_path
(eg: /var/opt/remi/php74/lib/php/session)

best regards