Darstellungsprobleme im FF

Könnte sich von euch mal jemand meine Seite im FF ansehen? Ich habe es eben auf 2 meiner MACs gesehen das auf der Listing Seite der link zum vergleichen fehlt (beim Artikel) und das auf der Detailseite im unteren Bereich einiges verschoben ist. Komischerweise ist im Safari, Chrome und IE alles in Butter. Ich habe auch nichts geändert. Danke schon mal fürs testen Frank

Moin Frank, ich schaue gerade… Punkt 1) Du hast da vermutlich das Vergleichen-Plugin deaktiviert (Compare)?! Da scheint auch die Probleme auf der Detailseite zu erzeugen PS: Folgendes kann auch ein Problem sein. templates/chsb/frontend/_resources/javascript/jquery.shopware.js Du greifst gar nicht auf die aktuelle Version aus _default zurück. Das sollte mann immer machen, da nur dort auch die aktuelle Version vorliegt. Eine ältere kann immer mit neuen Versionen kollidieren

Hi Sebastian, danke für die Info. Ich weiß jetzt woran es lag. Ich habe vor einiger Zeit mit dem JS Minifier gearbeitet und die jquery.shopware.js etwas komprimiert, daran lag es. Heißt aber für mich das man diese Datei nicht komprimieren darf/sollte. Gibt es dafür einen Grund? Grüße Frank

Hi, das kann ich im Detail jetzt nicht sicher sagen. Ich weiß, dass hier einige schon mit diesen Komprimierungen gearbeitet haben. Evtl. hat sich bei dir ein Fehler eingeschlichen oder der Stand der Datei war veraltet. Ich glaube allerdings auch nicht, dass die Komprimierung bei der Datei wirklich Verbesserungen bringt. Zudem kann das System nicht mehr auf die Neuerungen etc. zurückgreifen, wenn du diese in deinem Ordner hast. Auch kann es zu Problemen bei neuen Plugins führen, wenn sich diese ggf. nicht mehr an den passenden Stellen einklinken können.

Hi Sebastian, ich hatte sie nur zu Testzwecken in meinem Templateordner wegen der Komprimierung, ich nutze jetzt wieder den _default Ordner, hatte ich bis dato auch immer so. Wenn ich ehrlich bin hat es auch nichts gebracht die Datei zu verkleinern. Was ich gerade teste ist das CDN von Google über deren App Engine, werde mal die .js und .css Dateien darüber laden, denke allerdings nicht das dies all zu viel bringt. Aber dazu mache ich mal einen neuen Thread auf. Grüße Frank

[quote=„taaucher“]Hi Sebastian, danke für die Info. Ich weiß jetzt woran es lag. Ich habe vor einiger Zeit mit dem JS Minifier gearbeitet und die jquery.shopware.js etwas komprimiert, daran lag es. Heißt aber für mich das man diese Datei nicht komprimieren darf/sollte. Gibt es dafür einen Grund? Grüße Frank[/quote] Das „Minifying“ der jquery.shopware.js funktioniert, allerdings hatte ich bei einem früheren Versuch auch mal einen Bock geschossen, als ich es durch irgendeinen Minifyer gejagt hatte, der wohl nicht so 100%ig arbeitete. Mittlerweile lasse ich das meinen Apache mit mod_pagespeed machen. Dafür muss ich die Scripte nicht jedes mal manuell anfassen und wenn mal eine .js dazu kommt, wird das automatisch mitgemacht.

[quote=„tschersich“] Das „Minifying“ der jquery.shopware.js funktioniert, allerdings hatte ich bei einem früheren Versuch auch mal einen Bock geschossen, als ich es durch irgendeinen Minifyer gejagt hatte, der wohl nicht so 100%ig arbeitete. Mittlerweile lasse ich das meinen Apache mit mod_pagespeed machen. Dafür muss ich die Scripte nicht jedes mal manuell anfassen und wenn mal eine .js dazu kommt, wird das automatisch mitgemacht.[/quote] Kannst du das etwas genauer erläutern? Reicht es das Paket auf dem Server zu installieren? Habe letztens mal den APC installiert, das hat schon etwas gebracht.

Das ist gar nicht so schwer. Wie bei allen Dingen sollte man aber wissen, was das Modul macht und welche Parameter was bewirken. Pagespeed arbeitet für den Apache als eine Art interner RevserseProxy. Davon bekommt man in der Regel nichts mit, aber die Dateinamen ändern sich alle!! Sie werden aus dem Pagespeed Cache bedient, der in /var/mod_pagespeed/cache/ liegt. 1. Paket runterladen: http://code.google.com/intl/de-DE/speed … nload.html (nicht das FF Add-on, sondern das zum OS passemde Installationsmodul für Apache unter Linux) 2. als root Installieren: dpkg -i mod-pagespeed-\*.deb apt-get -f install Bei der Installation wird das pagespeed repository in die sources.list eingetragen. Das kann man aber vor der Installation abschalten, falls gewünscht: sudo touch /etc/default/mod-pagespeed 3. Konfigurieren Je nach Linux Version liegt die Config dann im Verzeichnis, wo die Module geladen werden, in meinem Beispiel hier /etc/apache2/mods-available/pagespeed.conf /etc/apache2/mods-available/pagespeed.load Die einzelnen Optionen sind hier erläutert: http://code.google.com/intl/de-DE/speed … lters.html Ich setze erst mal alles auf PassThrough und aktiviere dann jeden Filter nach Tests einzeln: ModPagespeedRewriteLevel PassThrough Die Filter, die Du suchst, sind diese hier: ModPagespeedEnableFilters remove\_quotes ModPagespeedEnableFilters collapse\_whitespace Auf jeden Fall muss in der .conf ModPagespeed on stehen. Damit das Backend damit zurecht kommt, habe ich noch: ModPagespeedDisallow \*/backend/\* ModPagespeedDisallow \*/engine/\* eingetragen. 4. Im Apache aktivieren: a2enmod pagespeed /etc/init.d/apache reload Es gibt hier noch viele andere, sehr nette Filter. Ich empfehle dringend, jeden einzeln a) zu verstehen, was er macht b) anzuschalten c) zu testen d) dann erst zum nächsten Filter

1 Like