Cookie Consent Tool - Einstellungen dauerhaft fort nach Klick auf Mehr Informationen

Hallo,

ich habe gerade unsere Testinstallation auf SW 5.6.3 upgedated und teste ein wenig mit dem Cookie Consent Tool herum. Wenn man weder auf Konfigurieren noch auf Ablehnen oder Alle Akzeptieren klickt, sondern auf “Mehr Informationen”, kann man nachträglich keine Einstellungen des Cookie-Verhaltens mehr vornehmen.
Den Block Konfigurieren gibt es dann in der Cookie-Einstellungs-Sidebar nicht (mehr).

Ein Fehler oder wie ist das gedacht?

Können das andere nachvollziehen (ich teste jeweils in einer frischen Anonymen Browser-Session)? Issue-Ticket erstellen?

Hallo,

das stimmt nicht so ganz: man kann das Cookie Consent Tool jederzeit wieder über den Footer des Shops, speziell im Bereich „Informationen“ bei „Cookie-Einstellungen“ aufrufen und seine Einstellungen treffen oder ändern, siehe: https://www.shopwaredemo.de/ . Solch einen Link wie bei „Cookie-Einstellungen“ kann man sich aber auch überall im Shop wenn gewünscht anzeigen.

„Mehr Informationen“ ist ja nur vorhanden, wenn man einen „Link zur Datenschutzerklärung für Cookies“ einpflegt, sonst nicht. Wenn man dann auf „Mehr Informationen“ klickt, kommt man automatisch zur verlinkten Seite - auf der und auch auf allen anderen Seite wird der Cookie - Banner dann aber auch weiterhin angezeigt.

Grüße

Sebastian

“Mehr Informationen” ist ja nur vorhanden, wenn man einen “Link zur Datenschutzerklärung für Cookies” einpflegt, sonst nicht.

Das war mir bekannt, tut aber hier nichts zur Sache. Wenn man es einstellen kann, sollte es ja auch funktionieren. Auf Shopwaredemo ist der Link nicht eingepflegt. Da kann man dieses Verhalten also schon mal nicht direkt überprüfen.

Hast Du es mal getestet, oder erwartest Du das beschriebene Verhalten nur? Wenn ich da bei mir drauf klicke, verschwindet der Banner unten dauerhaft, nicht nur auf dieser Seite, sondern auch auf jeder weiteren. Wenn gewünscht, kann ich das mit Screenshots zeigen, aber man kann meiner Erklärung sicher auch so folgen.

Die Frage wäre ja, ist das ein allgemeiner Fehler, oder ist das erst mal nur bei mir so? Bevor ich mir die Arbeit mache, mit Templates umstellen und Plugins deaktivieren.
Mag das evtl. jemand bei sich testen?

Hallo,

ich habe es logischerweise auch in einem nackten Demoshop getestet, sonst hätte ich es wohl kaum so detailliert beschrieben (sowohl mit als auch ohne die “Alle akzeptieren” - Schaltfläche).

Grüße

Sebastian

Ah, jedes mal das gleiche Gedöns nach einem Update. Könnte ja einmal auch ohne Zicken funktionieren.

LOL!  Grin

Ich habe aber auch das Gefühl, das es mehr Probleme mit dem Tool gibt, als das es wirklich was bringt.

Sieht so aus, als ob’s mit der heißen Nadel gestrickt wurde, da es scheinbar nur in der offiziellen DEMO richtig sauber funktioniert…  Wink

Laut Shopware sollte doch auch im Footer unten ein Link zu den Einstellungen sein, oder!?

Ich hab jedoch nichts im Footer, dafür aber oben unter Service/Hilfe sowie im Listing in der linken Box (Informationen) unter dem Menü…

@Murmeltier schrieb:

Laut Shopware sollte doch auch im Footer unten ein Link zu den Einstellungen sein, oder!?

Ist er doch auch! Informationen -> Cookie-Einstellungen 

…ja, aber nicht im Footer unter Informationen!

Doch, unten 2. Spalte und oben rechts in den Links oder reden wir grad aneinander vorbei?

@Murmeltier schrieb:

Laut Shopware sollte doch auch im Footer unten ein Link zu den Einstellungen sein, oder!?

Ich hab jedoch nichts im Footer, dafür aber oben unter Service/Hilfe sowie im Listing in der linken Box (Informationen) unter dem Menü…

Hallo,

wenn du oder ein Plugin von dir Veränderungen am Theme vorgenommen haben, kann ja Shopware nichts dafür, das es bei dir wo anders angezeigt wird.

Shopware fügt die neue Shopseite folgenden Shopseitengruppen hinzu:

  • bottom2 (Shopseitengruppe „Unten (Spalte 2)“)
  • left (Shopseitengruppen „Links“)

Wenn du also die Ausgabe der Shopseiten unten im Footer geändert hast (beispielsweise die Überschrift), wird dir die neue Shopseite natürlich unter einer anderen Shopseitengruppe oder Überschrift angezeigt. Jedoch kann man ja problemlos die Shopseite mit ein paar Klicks im Backend in die andere, gewünschte Shopseitengruppe verschieben. Oder einfach deaktivieren und somit wieder ausblenden.

Das Problem hier im Thema lag ja wahrscheinlich auch daran, das nicht der komplette Shop Cache, also inklusive Theme- und Backend-Cache, geleert wurde - was aber zwingend erforderlich ist, da es sich ja auch unter anderem um JavaScript - Änderungen handelt.

Grüße

Sebastian

1 Like

Menno Shopware was soll das? Dank des Themas hier sehe ich gerade auch den Link im Footer, obwohl ich den ganzen Kram aktuell gar nicht benutzen will. Warum wurde das Ganze nicht einach nur als Plugin gelöst? Ein Plugin bekommt schneller mal ein Update, als SW5. Jetzt können wir wieder zwei bis drei Monate auf Fehlerkorrekturen warten. Dazu passt das Overlay so auch nicht zu den Themefarben, bei mir nicht lesbar (wo kommen die Farben her? BG dürfte Hintergrundfarbe sein, Schrift???) . Gut, den Eintrag in Information kann man  wie normale Links “Shopseiten” deaktivieren . Dennoch ätzend, durch ein Update etwas aufgezwungen zu bekommen, was man aktuell gar nicht nutzen möchte.

1 Like

Moin @sonic‍,

du bekommst garnichts aufgezwungen.
Möchtest du nicht nutzen?
Dann stell einen anderen Modus ein und entferne die Shopseiten.
Der Modus ist auch nicht per Standard aktiviert.

Hätten wir die Shopseite nicht direkt im Standard mit ausgeliefert, wäre der Schrei groß gewesen, warum man erst selbst noch was anlegen muss, damit man einen Button hat, der die Tools wieder öffnet.
Oder eben der normale Fall: Der Upgrade Guide wurde nicht gelesen und man verpasst diese Information komplett.

So kannst du die Shopseite einfach wieder entfernen und gut ist, das kostet dich keine 30 Sekunden.

Ich glaube einfach, dass es hier keine Lösung gibt, mit der alle zufrieden sind.
Die Einen schreien hysterisch nach einer Lösung, die Anderen wollen damit garnichts zu tun haben. Die Einen wollen das im Core, die Anderen als Plugin.

In meinen Augen fahren wir so momentan den besten Weg - alle Versionen unterstützt, wer es nicht nutzen möchte kann’s einfach entfernen.

Bzgl. der Schriftfarbe: Das habe ich mir mal aufgeschrieben und schaue mal, ob da ein Fehler unsererseits vorliegt oder einfach eine Inkompatibilität mit deinem Theme o.Ä.

Besten Gruß
Shopware  Patrick Stahl

2 Likes

@sschreier schrieb:

Hallo,

wenn du oder ein Plugin von dir Veränderungen am Theme vorgenommen haben, kann ja Shopware nichts dafür, das es bei dir wo anders angezeigt wird.

Shopware fügt die neue Shopseite folgenden Shopseitengruppen hinzu:

  • bottom2 (Shopseitengruppe “Unten (Spalte 2)”)
  • left (Shopseitengruppen “Links”)

Wenn du also die Ausgabe der Shopseiten unten im Footer geändert hast (beispielsweise die Überschrift), wird dir die neue Shopseite natürlich unter einer anderen Shopseitengruppe oder Überschrift angezeigt. Jedoch kann man ja problemlos die Shopseite mit ein paar Klicks im Backend in die andere, gewünschte Shopseitengruppe verschieben. Oder einfach deaktivieren und somit wieder ausblenden.

Das Problem hier im Thema lag ja wahrscheinlich auch daran, das nicht der komplette Shop Cache, also inklusive Theme- und Backend-Cache, geleert wurde - was aber zwingend erforderlich ist, da es sich ja auch unter anderem um JavaScript - Änderungen handelt.

Grüße

Sebastian

Naja, ganz so ist es nicht, aber trotzdem Danke für Dein Beitrag…  Smile

Wenn Shopware diese neue - also vorher noch nie dagewesenen Seite, den zwei - von Dir angegebenen - Shopseitengruppen zuführt, dann sollten sie auch erst mal da sein. Und eben nicht eine ja, die ander wo anders. Das ist zumindest meine Auffassung von so etwas. Und das Cache-Gelumpe-Geleere mach ich sowieso immer, weil ich es ja sooooooo mag. Aber gut…  Wink

Sei es d’rum, denn letzendlich hat Deine Antwort mich drauf gebracht, wie ich den Link ja ganz easy da unten rein kriege, hehe. Manchmal sieht man auch den Wald vor lauter Java Script Backend nicht, sorry.  Wink

Ich danke Dir also, das Du mich erleuchtet hast…  Thumb-Up

Hallo,

Kann mir mal jemand bitte erklären, wo ich die Cookie-Einstellungen finde, damit ich Sie in den Footer einbauen kann.

Unter Shopseiten finde ich diese nicht.

Einstellungen -> Grundeinstellungen -> Weitere Einstellungen -> Datenschutz 

Die Einen schreien hysterisch nach einer Lösung, die Anderen wollen damit garnichts zu tun haben.

Allen Leuten recht getan, ist eine Kunst, die niemand kann.
Robert Bosch; 1921

Permament auf Shopware herum hacken ist auch keine Lösung.

Permament auf Shopware herum hacken ist auch keine Lösung.

Eignet sich aber gut zum Frustabbau  weil sich keiner wehren kann :-D 

Aber mal eine Frage, Ich habe SW 5.6.3 und das Consent Tool gibts nicht dafür weil es schon integriert ist? Ich finde es nicht.

Dsnke und Gruss

[@Patrick Stahl](http://forum.shopware.com/profile/1869/Patrick Stahl “Patrick Stahl”)‍

Genau das ist das Problem: Ich hatte vorher NICHTS eingestellt! Also nichts mit “anderen Modus einstellen”
Das ich die “Shopseiten” leicht selber entfernen kann, schrieb ich ja selber bereits :slight_smile:
Und da ich ja gerne immer auf die “Updateanleitung” verweise - https://docs.shopware.com/de/shopware-5-de/update-guides/update-guide-shopware-56?category=shopware-5-de/update-guides - wo steht hier noch gleich, dass ein neuer Link in meinem Footer eingetragen wird? Find ich gerade nicht… wo genau? Zweite Anlaufstelle wäre https://www.shopware.com/de/changelog-sw5/#5-6-3 - wo finde ich hier die Information?

“Der Upgrade Guide wurde nicht gelesen und man verpasst diese Information komplett.” ach ja??? Den Schuh zieh ich mir nicht an!

Zur Farbe: Da ist mein Theme an der Stelle 100% Responsive.
Sowohl im “Live-Shop”, als auch im “Testshop” ist es jeweils die Farbe aus “@body-bg” aus der Theme-Config. Dass ist die “Hintergrund-Farbe” aus dem Desktopviewport ausserhalb vom Content. Sollte also eher eine Hintergrundfarbe aus einem Panel sein.

Edit: Und da ist die Stelle auch schon
https://github.com/shopware/shopware/blob/5.6/themes/Frontend/Responsive/frontend/_public/src/less/_components/cookie-consent-manager.less#L8

Edit2: Und selbst wenn der “Modus” ganz deaktiviert ist, bleibt die “Consenttoolbar” im HTML erhalten - und bläht damit unnötig das HTML auf - ich werde das Ding also gar nicht los! Soviel zu "du bekommst garnichts aufgezwungen"

Edit3: Ticket zur Farbe

1 Like

@brettvormkopp schrieb:

Aber mal eine Frage, Ich habe SW 5.6.3 und das Consent Tool gibts nicht dafür weil es schon integriert ist? Ich finde es nicht.

Hallo,

Einstellungen/Grundeinstellungen/Weitere Einstellungen/Datenschutz

Gruss Armin

1 Like