Bug im LastArticles Plugin?

Hallo Leute, ein frohes, neues Jahr! Wenn ich das Plugin LastArticles desinstalliere und dann wieder installiere, hat es meines Erachtens einen Bug, der dazu führt, dass danach die letzten Artikel nicht mehr angezeigt werden. Nach meinem Ermessen ist der Grund dafür, dass folgende Zeile nicht in die Tabelle s_core_config_elements geschrieben wird: (231, 102, ‚lastarticlestoshow‘, ‚s:1:„5“;‘, ‚Anzahl Artikel in Verlauf (zuletzt angeschaut)‘, NULL, ‚text‘, 0, 0, 0, NULL, NULL, NULL), Ein Eintrag in Bezug auf ‚Specherfrist in Tagen‘ wird gemacht. Kann man das aktuelle Plugin irgendwo herunterladen? Grüße

PUSH Selbes Problem auch hier. Auch nach dem Einfügen der Zeile aus dem sw4_clean.sql, werden keinerlei Artikel ausgegeben. Wert steht auf 5 Artikel. Bug existiert wohl schon ne Weile: http://jira.shopware.de/?ticket=PT-1530 Grüß Tobi

Hi, wir haben werden uns das Verhalten noch einmal anschauen für die nächste Shopware Version: Da dies nun kein Plugin mehr ist, haben wir das Ticket in unser internes Shopware Projekt verschoben. Deswegen könnt Ihr es nun hier einsehen: http://jira.shopware.de?ticket=SW-7994 Vg, Marcel

Wir haben auch ein Problem: nach dem Update auf Shopware 4.2.1 funktioniert das LastArticles - Plugin nicht mehr. Plugin neu installieren, Cache löschen usw. hat bisher nichts gebracht. Seltsamerweise betrifft dies nur die Startseite bzw. Seiten die keine Artikelseiten sein. Auf den einzelnen Artikelseiten wird das Plugin korrekt angezeigt. Auf der Startseite usw. scheint das Skript abzustürzen, dort fehlen danach im HTML-Quelltext sämtliche Ausgaben wie Service-Hotline und Impressum. Habe dazu ein Ticket erstellt: http://jira.shopware.de/?ticket=SW-8321

[quote=“eurofreq”]Wir haben auch ein Problem: nach dem Update auf Shopware 4.2.1 funktioniert das LastArticles - Plugin nicht mehr. Plugin neu installieren, Cache löschen usw. hat bisher nichts gebracht.[/quote] Laut Marcel von Shopware ist dieses Funktion ja kein Plugin mehr?!?

[quote=“tonne”][quote=“eurofreq”]Wir haben auch ein Problem: nach dem Update auf Shopware 4.2.1 funktioniert das LastArticles - Plugin nicht mehr. Plugin neu installieren, Cache löschen usw. hat bisher nichts gebracht.[/quote] Laut Marcel von Shopware ist dieses Funktion ja kein Plugin mehr?!?[/quote] Es ist jetzt ein Core-Plugin (oder wie auch immer) - lässt sich aber dennoch installieren und deinstallieren. Ist halt nur schon bei der Installation integriert und muss nicht manuell installiert werden. Auf mein Ticket wurde mit Version 4.2.2 Release Candidate (RC) geantwortet - also ich soll quasi eine Beta-Version mit anderen Bugs installieren um diesen Bug zu beheben. Nun warte ich auf die Final-Version.

Auf opensource-Blog.de ist ein Bugfix zu finden. Gruß Gesendet von meinem iPad mit Tapatalk

1 Like

Plus 1. Ich hatte ewig an dem Punkt gesucht und mich gewundert, dass die Werte im Backend nicht gespeichert werden. Der beschriebene Fix in der Bootstrap.php des LastViewed Plugins müsste ausreichen wie im genannten Blog-Beitrag beschrieben (hier nochmal ohne die von Wordpress umgewandelten Anführungszeichen): $form-\>setElement('number', 'lastarticlestoshow', array( 'label' =\> 'Anzahl Artikel in Verlauf (Zuletzt angesehen)', 'value' =\> 5 )); Damit wird nach De- und Reinstallation in meinem Fall unter Shopware 4.1.4 der Wert wieder richtig gespeichert.