Blogboxen Design anpassen

Hallo, ich bräuchte mal Eure Hilfe: momentan werden die Blogartikel auf der Starteite so angezeigt: http://www.shopwaredemo.de/ Also in einem langen Block mit Rahmen. Ich möchte gerne jeden Blogartikel in einer einzelnen Box mit Rahmen nebeneinander haben. Das funktioniert leider nicht, bzw. viell. habe ich da eine falsche Einstellung. Wenn ich ein Raster mit 3 Boxen anlege, erscheint immer der gleiche Blogartikel!! Ich habs schon in einem anderen Shop so gesehen. Was mache ich hier falsch?

[quote=„artep“]Hallo, ich bräuchte mal Eure Hilfe: momentan werden die Blogartikel auf der Starteite so angezeigt: http://www.shopwaredemo.de/ Also in einem langen Block mit Rahmen. Ich möchte gerne jeden Blogartikel in einer einzelnen Box mit Rahmen nebeneinander haben. Das funktioniert leider nicht, bzw. viell. habe ich da eine falsche Einstellung. Wenn ich ein Raster mit 3 Boxen anlege, erscheint immer der gleiche Blogartikel!! Ich habs schon in einem anderen Shop so gesehen. Was mache ich hier falsch?[/quote] .blog-outer-container .blog-entry { border: 1px solid #dfdfdf; width: 32% !important; margin-right: 5px; } .emotion-listing .blog-outer-container { border: none; } Mit den Einstellungen sollte es bei dir auf der Seite funktionieren. Das !important bei width ist notwendig, weil im style-Attribut die Breite gesetzt wird. Der große Nachteil ist, dass die Blogbeiträge unterschiedlich hoch sind. Entweder es wird eine Höhe im CSS erzwungen, man muss bei der Erstellung der Beiträge darauf achten oder das Template so anpassen, dass es immer eine Höhe ergibt. Viele Grüße HTH

1 Like

Hallo Holger, danke Dir, aber das funktioniert so nicht. Es wurde ja mit den Einkaufswelten angelegt und nur mit Styleangabe klappt das nicht. Ich habe auch in dem anderen Shop gesehen, dass das Blogelement angepasst wurde. Da muss ich mal gucken ob ich Blondi das auch irgendwie hinbekomme. Denke mal nicht! :smiley:

Hallo Petra, doch, das geht genau so. Du bekommst drei nebeneinander liegenden Blogbeiträge, die jeweils einen eigenen Rahmen haben. Ich habe es extra “auf” deiner Seite getestet. Holger

Hallo Holger, jep, Du hast Recht! Ich hatte nur das width eingesetzt(man sollte schon richtig lesen!!), mit dem ganzen Code funktioniert es. Danke Dir!!! :thumbup: