Backend > tinyMCE inlinepopup Update and Cancel button hidden

Seit Version 5.7.4 werden bei uns im Backend bei den tinyMCE „Inline-Popups“ die Bedienelemente (Buttons am unteren Rand des Popups) abgeschnitten oder sind garnicht mehr sichtbar und damit auch nicht auswählbar. Somit können die Anpassungen nicht gespeichert werden.
Das betrifft z.B. das Popup für „HTML-Quellcode bearbeiten“ oder auch die Option zum Einfügen von Links in Texten.

Das ist Safari. In anderen Browsern sind die Buttons garnicht mehr zu sehen.

Temporär gelöst habe ich das Problem durch entfernen des HEIGHT values im entsprechenden CSS code.
Pfad: shopware/engine/Library/TinyMce/plugins/inlinepopups/skins/clearlooks2/window.css

von:
.clearlooks2 .mceMiddle span {top:23px; left:5px; width:100%; height:100%; background:#FFF}
zu:
.clearlooks2 .mceMiddle span {top:23px; left:5px; width:100%; background:#FFF}

Ich habe es im Original code ändern müssen, da es über eine Templateanpasung bei mir nicht funktioniert hat.
Evtl liegt die Ursache des Problems auch wo anders, ich habe es für mich jedenfalls so hinbekommen und kann wieder effektiv arbeiten.

1 Like

Hallo @ManuelK

kannst du mal schauen, ob das nach einem Update auf 5.7.6 immer noch so ist?

Viele Grüße aus Schöppingen
Michael Telgmann

Hallo Michael, ja das Problem ist auch in 5.7.6 noch vorhanden. ich hatte in 5.7.5 meinen Quick-fix bereits eingebaut und nach dem Update auf 5.7.6 wurde der Bug wieder dargestellt.

Grüße
Manuel

Hallo Manuel,

ich kann das Problem selber nicht nachstellen. Magst du vielleicht ein Ticket einstellen?

Welchen Browser du nutzt, vielleicht spielt auch die Bildschirmgröße mit rein. Alles was uns helfen könnte, das Problem nachzuvollziehen :slightly_smiling_face:

Viele Grüße aus Schöppingen
Michael Telgmann

Klar. ich mach ein Ticket dazu auf. Ich habe eben noch geschaut ob CSS von einem Plugin wirkt, aber es sieht nicht so aus. Ich nutze Safari in der neuesten Version, kann aber das Problem in allen anderen gängigen Browsern (Chrome / Firefox / Edge) nachvollziehen. Details dann im Ticket.

Danke und Gruß
Manuel

@Michael_Telgmann - Auch bei uns sind teils die Buttons je nach Browser kaum sichtbar oder nicht vorhanden. Beim Firefox zum Beisspiel auch abhängig vom Zoomfaktor. Interssant dabei ist: wenn ich das Fenster des HTML Quelltextes vergrößere, sind für einen sehr kurzen Moment die Buttons sichtbar und mit Loslassen der Maustaste sind diese wieder verschwunden. Vielleicht hilft der Hinweis auch, um das Problem zu finden. Auch bei uns trat das Problem erst nach oben besagtem update auf.

Hallo,

das Ticket zu diesem Thema findet ihr hier: Shopware Issuetracker

Schreibt gerne weiter Erkenntnisse in die Kommentare.

Viele Grüße aus Schöppingen
Michael Telgmann