Backend Bestellungen: keine Artikeldaten im Lieferschein

Hallo Hallo Support, wenn ich mit dem Plugin von Shopware: “Backend Bestellungen” eine Bestellung durchführe, werden an den “Lieferschein” keine Artikeldaten übergeben. Die Daten in der Rechnung sind dagegen in Ordnung. Wo kann man dieses einstellen / ändern? Im Einsatz: Shopware 5.1.1 Backend Bestellungen: Version:1.0.1 Automatische Rechnungserstellung & -versand Version:2.1.3 Gruss FH

Wir haben dasselbe Problem… Shopware V 5.1.1 Backend-Bestellung V 1.0.1 normale Dokumenterstellung (Fester “Bestellungen”)

Hi, hast Du ein eigenes Template und die documents.tpl`s in Deinem Template hinzugefügt? Dann unter Grundeinstellung/Shops das Dokumententemplate zugewiesen? Ansonsten sollten bei Standardtemplate auch die Dokumente aus Bare funktionieren.

Hi Petra, bin nicht 100% sicher was Du meinst. Ich denke Deine Frage war, ob wir die .tpl’s (index.tpl, index_ls.tpl, index_gs.tpl und index_sr.tpl) im Ordner (themepfad)Bare/documents auch in unserem eigenen Theme im selben Pfad haben. Das ist bei mir nicht der Fall, weil bisher keine umfangreichen Änderungen an den Dokumenttemplates stattfanden. Es wurden nur im Backend editierbare Änderungen durchgeführt (Grundeinstellungen->Shopeinstellungen->PDF-Belegerstellung) In der Dokumenten-Template Zuordnung in den Shopeinstellungen ist mein eigenes Template ausgewählt. (ich nehme an, da dort nichts ist wird wohl aus Bare gezogen) Die Dokumenterstellung funktioniert ja auch in allen Fällen, mit einer Ausnahme: Bei Bestellungen die übers Backend mit dem Plugin Backend-Bestellungen angelegt werden, fehlen im Lieferschein die Artikel. Sonst sind alle Elemente inkl. Logo etc. am gewohnten Platz. Wir sind wohl auch nicht alleine mit dem Problem: post143775.html?hilit=lieferschein%20bug%20backend#p143775 post133475.html?hilit=lieferschein%20bug%20backend#p133475 Bisher aber keine Antworten :cry:

Hallo, [quote=“staenderdrink”] In der Dokumenten-Template Zuordnung in den Shopeinstellungen ist mein eigenes Template ausgewählt. (ich nehme an, da dort nichts ist wird wohl aus Bare gezogen)[/quote] Ich würde dort mal Bare auswählen, oder aber die tpl`s in Dein Theme reinpacken und dann dort Dein Theme auswählen. [quote=“staenderdrink”] Die Dokumenterstellung funktioniert ja auch in allen Fällen, mit einer Ausnahme: Bei Bestellungen die übers Backend mit dem Plugin Backend-Bestellungen angelegt werden, fehlen im Lieferschein die Artikel. Sonst sind alle Elemente inkl. Logo etc. am gewohnten Platz.[/quote] Sollte obiges dann immer noch nicht funktionieren, liegt es wohl am dem besagten Plugin, was ich eher vermute. Das dann mal deaktivieren und schauen ob die Artikeldaten dann vorhanden sind.

Vielleicht ist das ja mit dem Bugfix behoben: v 1.0.2 30.12.2015 PT-3839 - Bugfix: Einfrieren, wenn ein Fehler beim Erstellen auftritt Vielen Dank an das Team von VIISON für die folgenden Bugfixes: PT-4733 - Bugfix: Positionen auf Lieferschein PT-4734 - Bugfix: Mehrwertsteuer auf Netto Rechnungen PT-4735 - Bugfix: Berechnung Gesamtbetrag auf Netto Rechnungen PT-4736 - Bugfix: Auswahl Lieferadresse PT-4737, PT-4738, PT-4739 - Bugfix: Unnötige Felder und Events entfernt PT-4740 - Bugfix: Netto Lieferkosten nur lesbar

1 Like

[quote=“artep”]Sollte obiges dann immer noch nicht funktionieren, liegt es wohl am dem besagten Plugin, was ich eher vermute. Das dann mal deaktivieren und schauen ob die Artikeldaten dann vorhanden sind.[/quote] Das hätte ja nix gebracht, da der Fehler nur bei Bestellungen vorliegt, die durch besagtes Plugin generiert werden. PROBLEM GELÖST! Das Problem wurde mit dem Bugfix 1.0.2 des Plugins “Backend-Bestellungen” behoben. Wir haben das Plugin aktualisiert und nun tauchen die Positionen in neu generierten Lieferscheinen von Backend-Bestellungen auf. Leider lassen sich alte Lieferscheine nicht durch Neugenerierung der Dokumente nicht “reparieren”. Wir hatten bisher bei Backendbestellungen per Grafiksoftware manuell die Posten aus der Rechnung in den Lieferschein kopiert. Das ist jetzt ja gottseidank vorbei.:sunglasses: