Backend Bestellungen funktionieren nicht mehr

Hallo,

mit den Bestellungen aus dem Backend gabs immer wieder mal Probleme, aber nach einer Aktualisierung vom Browser gings wieder. 

Seit heute geht nichts mehr.  Frown Es gab in letzter Zeit keine Änderungen, keine neuen Plugins. Auch eine Neuinstallation vom Plugin “Backend Bestellung” brachte keinen Erfolg.

Wenn wir eine Bestellung anlegen möchten, hängt es sich auf. Wir geben die Artikel ein und klicken auf “Erstellen” dann bleibt das System hängen und die Bestellung wird nicht angelegt. 

Keine Fehlermeldung in den Error Logs.  Undecided Nur eine von heute um 10:07 

[fcgid:warn] [pid 9876:tid 139811906049792] (32)Broken pipe: [client xx.xx.xx.xx:46978] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

Die hat aber vermutlich nichts mit den Bestellungen zu tun.

Was uns aber aufgefallen ist, geben wir nur einen Artikel als Bestellung ein, funkioniert alles wie es soll, bei mehreren Artikeln jedoch hängt sich alles auf.

Für uns ist diese Funktion wichtig, wir haben viele “Opas u. Omas”  Smile als Kunden, aber auch einige mittleren Alters die kein Internet, oder Erfahrungen mit Shops haben.

Lg

Siehe https://forum.shopware.com/discussion/comment/106944/#Comment_106944

Viele Grüße

1 Like

@Aquatuning GmbH schrieb:

Siehe https://forum.shopware.com/discussion/comment/106944/#Comment_106944

Viele Grüße

Danke, gut zu wissen das solche Fehler nicht in den Error Logs auftauchen. 

Fehler laut Firebug von Firefox in:

/engine/Library/ExtJs/ext-all.js?201707131430 line 21 > eval

TypeError: me.window is undefined
TypeError: me.getTotalCostsOverview(…) is undefined
TypeError: me.shippingStore is undefined
TypeError: A is undefined

Kann jemand was damit anfangen?

Warum tauchen Fehler immer einfach so aus dem Nichts auf.  Frown Komisch, in unserem Testshop (Spiegelung) funktionieren die Backend Bestellungen. 

Lg

DIe Anleitung von [@Aquatuning GmbH](http://forum.shopware.com/profile/11752/Aquatuning GmbH “Aquatuning GmbH”)‍ ist schon gut, du solltest am Besten im Netzwerk Tab dir den passenden Request anschauen. Die ExtJS Fehmerledung alleine hilft leider nicht, da wir die des Backends im Hintergrund benötigen. Dafür solltest du aber das erweiterte Error Debugging aktiviert haben!

LG Andre

1 Like

@AndreHerking schrieb:

DIe Anleitung von [@Aquatuning GmbH](http://forum.shopware.com/profile/11752/Aquatuning GmbH “Aquatuning GmbH”)‍ ist schon gut, du solltest am Besten im Netzwerk Tab dir den passenden Request anschauen. Die ExtJS Fehmerledung alleine hilft leider nicht, da wir die des Backends im Hintergrund benötigen. Dafür solltest du aber das erweiterte Error Debugging aktiviert haben!

http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html

LG Andre

Vielen Dank. Anleitung befolgt, aber unter Netzwerk nicht eine einzige Fehlermeldung.  Undecided Was uns aber eben aufgefallen ist, der Fehler tritt scheinbar nur bei Händler Accounts auf. Stellen wir den Testaccount auf Shopkunde, geht die Bestellung, stellen wir um auf Händler, hängt sich alles auf. Scheinbar funktionieren die Bestellungen aus dem Backend hin und wieder.

Da ändert man nichts, testet immer alles ausgiebig auf einer Testumgebung…alles für die Katz. Könnte man sich alles sparen wenn Fehler einfach so aus dem nichts auftauchen. Sieht leider so aus als werden wir diesen Fehler nicht beheben können. 

Vielleicht hat ja noch jemand eine Idee…letztendlich gibt es tausende Beiträge wo von Problemen mit diesem Plugin berichtet werden. Guckt man sich die Bewertungen an, sollte man das Plugin am besten erst gar nicht installieren, aber gibt es dafür eine Alternative?

  1. Fehlermeldungen aktivieren 
  2. Die Rückgabe des requests anschauen

Beide Schritte wurden verlinkt. Dann wirst du eine aussagekräftige Fehlermeldung bekommen und damit können wir dir mit Sicherheit helfen.

Viele Grüße

@Aquatuning GmbH schrieb:

  1. Fehlermeldungen aktivieren 
  2. Die Rückgabe des requests anschauen

Viele Grüße

Wenn Du mit “Fehlermeldung aktivieren” in der config meinst, das haben wir gemacht. 

Rückgabe des Requests anschauen, ist für mich ein spanisches Dorf. Undecided

Wir haben den Codeschnipsel in die Config eingebunden, zusätzlich sogar noch Cache geleert und Theme kompiliert. Bei Firebug keine neuen Fehlermeldungen, außer die, die ich vorhin schon gepostet habe. Blush

Lg

Langsam und noch einmal von vorne.  Smile Aber jetzt funktionieren auf einmal die Bestellungen wieder. Haben jetzt 8 Bestellungen als Händler und 3 als Shopkunde angelegt, verschiedene Artikel und Mengen, alles läuft wie es soll. Frown Kanns ja net sein, ich hau den Hut drauf.  Wearing-Sunglasses

Fehler gefunden, es lag einen SW Plugin.  Undecided Danke für eure rasche Hilfe.  Smile

 

@Vitago GmbH schrieb:

Fehler gefunden, es lag einen SW Plugin.  Undecided Danke für eure rasche Hilfe.  Smile

An welchem?

@Fl0 schrieb:

@Vitago GmbH schrieb:

Fehler gefunden, es lag einen SW Plugin.  Undecided Danke für eure rasche Hilfe.  Smile

An welchem?

Sorry, aber das weis ich jetzt nicht mehr genau. Wir haben über 70 Plugins installiert, davon sind 57 aktiv. Muss ich mal nachschauen, kann aber etwas dauern. 

Hallo Vitago,

 

welche  Zahlungsarten hinterlegt Ihr bei den Backendbestellungen?

Waren alle Rechnungem direkt vom Kunden bezahlbar, oder musstet Ihr was umstellen, das die BE Bestellungen auch bezahlbar sind?

 

Meine Kunden können die BE Bestellungen nicht bezahlen.

Es liegt auch keine Sperre im Riskmanagement vor.

 

Viele Grüße

Stanley

[@Vitago GmbH](http://forum.shopware.com/profile/21824/Vitago GmbH “Vitago GmbH”)‍

Konnte nachträglich ermittelt werden, an welchem Plugin es lag?

Wir haben derzeit ein ähnliches Problem, dass unser Kundenservice das Fenster immer doppelt öffnen muss, bevor das Tool die Kundendaten lädt und in Firefox bekommen wir auch bloß die oben beschriebenen Meldungen.

me.window is undefined
me.getTotalCostsOverview(…) is undefined

Der Chrome scheint gewisse Requests anders zu laden/ zu verarbeiten.
Für alle diejenigen, die auch noch nach 2 Jahren das Problem haben sollten: Versucht einmal den Firefox :wink:

Seit kurzem ohne ein Update des Plugins oder von Shopware bekommen wir einen Freeze des Fensters in Shopware, andere Tabs darin funktionieren noch:

Uncaught TypeError: A is undefined
    forEach ExtJS
    failure /backend/SwagBackendOrder/load/?f=m/CreateBackendOrder|m/DesktopTypes|m/Customer|m/Address|m/Article|m/Position|m/ShippingCosts|m/TotalCosts|v/main/Window|v/main/CustomerSearch|v/main/Toolbar|v/main/TotalCostsOverview|v/main/CustomerInformation/Shipping|v/main/CustomerInformation/Billing|v/main/CustomerInformation/Payment|v/main/CustomerInformation/CustomerInformation|v/main/ShippingCosts|v/main/AdditionalInformation|v/main/list/Positions|v/main/list/Grid|v/main/list/ArticleSearchField|v/main/discount/Window|store/CreateBackendOrder|store/DesktopTypes|store/Customer|store/Article|store/Position|store/ShippingCosts|store/TotalCosts|store/DiscountTypes|c/Main&no-cache=1610354208+1+1:2989
    ExtJS 9
    processResponse https://www.studio-ausruestung.de/backend/base?file=bootstrap&loggedIn=1610452031:3782
    ExtJS 6
    request https://www.studio-ausruestung.de/backend/base?file=bootstrap&loggedIn=1610452031:5133
    ExtJS 6
    onCreateOrder /backend/SwagBackendOrder/load/?f=m/CreateBackendOrder|m/DesktopTypes|m/Customer|m/Address|m/Article|m/Position|m/ShippingCosts|m/TotalCosts|v/main/Window|v/main/CustomerSearch|v/main/Toolbar|v/main/TotalCostsOverview|v/main/CustomerInformation/Shipping|v/main/CustomerInformation/Billing|v/main/CustomerInformation/Payment|v/main/CustomerInformation/CustomerInformation|v/main/ShippingCosts|v/main/AdditionalInformation|v/main/list/Positions|v/main/list/Grid|v/main/list/ArticleSearchField|v/main/discount/Window|store/CreateBackendOrder|store/DesktopTypes|store/Customer|store/Article|store/Position|store/ShippingCosts|store/TotalCosts|store/DiscountTypes|c/Main&no-cache=1610354208+1+1:2930
    fire ExtJS
    dispatch https://www.studio-ausruestung.de/backend/base?file=bootstrap&loggedIn=1610452031:4240
    fireEvent ExtJS
    handler /backend/SwagBackendOrder/load/?f=m/CreateBackendOrder|m/DesktopTypes|m/Customer|m/Address|m/Article|m/Position|m/ShippingCosts|m/TotalCosts|v/main/Window|v/main/CustomerSearch|v/main/Toolbar|v/main/TotalCostsOverview|v/main/CustomerInformation/Shipping|v/main/CustomerInformation/Billing|v/main/CustomerInformation/Payment|v/main/CustomerInformation/CustomerInformation|v/main/ShippingCosts|v/main/AdditionalInformation|v/main/list/Positions|v/main/list/Grid|v/main/list/ArticleSearchField|v/main/discount/Window|store/CreateBackendOrder|store/DesktopTypes|store/Customer|store/Article|store/Position|store/ShippingCosts|store/TotalCosts|store/DiscountTypes|c/Main&no-cache=1610354208+1+1:448
    ExtJS 4
ext-all.js:21:12619
    forEach ExtJS
    failure /backend/SwagBackendOrder/load/?f=m/CreateBackendOrder|m/DesktopTypes|m/Customer|m/Address|m/Article|m/Position|m/ShippingCosts|m/TotalCosts|v/main/Window|v/main/CustomerSearch|v/main/Toolbar|v/main/TotalCostsOverview|v/main/CustomerInformation/Shipping|v/main/CustomerInformation/Billing|v/main/CustomerInformation/Payment|v/main/CustomerInformation/CustomerInformation|v/main/ShippingCosts|v/main/AdditionalInformation|v/main/list/Positions|v/main/list/Grid|v/main/list/ArticleSearchField|v/main/discount/Window|store/CreateBackendOrder|store/DesktopTypes|store/Customer|store/Article|store/Position|store/ShippingCosts|store/TotalCosts|store/DiscountTypes|c/Main&no-cache=1610354208+1+1:2989
    ExtJS 9
    processResponse https://www.studio-ausruestung.de/backend/base?file=bootstrap&loggedIn=1610452031:3782
    ExtJS 6
    request https://www.studio-ausruestung.de/backend/base?file=bootstrap&loggedIn=1610452031:5133
    ExtJS 6
    onCreateOrder /backend/SwagBackendOrder/load/?f=m/CreateBackendOrder|m/DesktopTypes|m/Customer|m/Address|m/Article|m/Position|m/ShippingCosts|m/TotalCosts|v/main/Window|v/main/CustomerSearch|v/main/Toolbar|v/main/TotalCostsOverview|v/main/CustomerInformation/Shipping|v/main/CustomerInformation/Billing|v/main/CustomerInformation/Payment|v/main/CustomerInformation/CustomerInformation|v/main/ShippingCosts|v/main/AdditionalInformation|v/main/list/Positions|v/main/list/Grid|v/main/list/ArticleSearchField|v/main/discount/Window|store/CreateBackendOrder|store/DesktopTypes|store/Customer|store/Article|store/Position|store/ShippingCosts|store/TotalCosts|store/DiscountTypes|c/Main&no-cache=1610354208+1+1:2930
    fire ExtJS
    dispatch https://www.studio-ausruestung.de/backend/base?file=bootstrap&loggedIn=1610452031:4240
    fireEvent ExtJS
    handler /backend/SwagBackendOrder/load/?f=m/CreateBackendOrder|m/DesktopTypes|m/Customer|m/Address|m/Article|m/Position|m/ShippingCosts|m/TotalCosts|v/main/Window|v/main/CustomerSearch|v/main/Toolbar|v/main/TotalCostsOverview|v/main/CustomerInformation/Shipping|v/main/CustomerInformation/Billing|v/main/CustomerInformation/Payment|v/main/CustomerInformation/CustomerInformation|v/main/ShippingCosts|v/main/AdditionalInformation|v/main/list/Positions|v/main/list/Grid|v/main/list/ArticleSearchField|v/main/discount/Window|store/CreateBackendOrder|store/DesktopTypes|store/Customer|store/Article|store/Position|store/ShippingCosts|store/TotalCosts|store/DiscountTypes|c/Main&no-cache=1610354208+1+1:448
    ExtJS 4

 

In var/log wird nichts geschrieben.