Artikel Upload Plugin Fehlermeldung

Hi Patrick, bin bißchen verwirrt. Kann ich das via Plugin Manager runterladen ? Dort werden mir nämlich keine neuen Updates angezeigt. Auch im Store ist nur die alte „2.0.1“ Version. Wo genau kann ich das runterladen ? Viele Grüße hoschi

hi, würde mich über kurze Info freuen ob das Update nun zur Verfügung steht oder nicht. viele Grüße Hoschi

ich muss nochmal nachfragen da ich noch immer keine neuen Updates im Plugin Manager sehen kann… Steht das Update nun zur Verfügung oder nicht ?!

Hi, Also aktuell ist die 2.0.1 im Store. In der ist dein Problem schon gefixt. Heute Abend wird es aber wieder ein Update auf die 2.0.2 geben. Gruß Patrick

2.0.1 ist die version die das Problem noch hat … bei mir jedenfalls. Dann warte ich mal auf die 2.0.2.

Hi, ist nun aktuell. http://store.shopware.de/sonstiges/arti … oad-plugin Deinstalliere am besten das alte, kompletten Cache leeren und dann das neue rein. Gruß Patrick

RecursiveDirectoryIterator::\_\_construct(/html/shopware/files/articleUploads/8166997808a69499e6a4cbf2137c2df7d7fec217/) [recursivedirectoryiterator.--construct]: failed to open dir: No such file or directory in Shopware/Plugins/Community/Frontend/SwagSimpleUpload/Bootstrap.php on line 460 Stack trace: #0 Shopware/Plugins/Community/Frontend/SwagSimpleUpload/Bootstrap.php(460): RecursiveDirectoryIterator-\>\_\_construct() #1 Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Frontend\_SwagSimpleUpload\_Bootstrap-\>onSendMail(Object(Enlight\_Event\_EventArgs)) #2 Enlight/Event/EventManager.php(156): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Event\_EventArgs)) #3 engine/core/class/sOrder.php(879): Enlight\_Event\_EventManager-\>notify('Shopware\_Module...', Array) #4 engine/core/class/sOrder.php(788): sOrder-\>sendMail(Array) #5 [internal function]: sOrder-\>sSaveOrder() #6 Shopware/Proxies/sOrderProxy.php(11): call\_user\_func\_array(Array, Array) #7 Enlight/Hook/HookManager.php(173): Shopware\_Proxies\_sOrderProxy-\>executeParent('sSaveOrder', Array) #8 Shopware/Proxies/sOrderProxy.php(23): Enlight\_Hook\_HookManager-\>executeHooks(Object(Shopware\_Proxies\_sOrderProxy), 'sSaveOrder', Array) #9 Shopware/Controllers/Frontend/Checkout.php(574): Shopware\_Proxies\_sOrderProxy-\>sSaveOrder() #10 Shopware/Controllers/Frontend/Checkout.php(248): Shopware\_Controllers\_Frontend\_Checkout-\>saveOrder() #11 Enlight/Controller/Action.php(135): Shopware\_Controllers\_Frontend\_Checkout-\>finishAction() #12 Enlight/Controller/Dispatcher/Default.php(521): Enlight\_Controller\_Action-\>dispatch('finishAction') #13 Enlight/Controller/Front.php(214): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #14 Shopware/Bootstrap.php(79): Enlight\_Controller\_Front-\>dispatch() #15 Enlight/Application.php(192): Shopware\_Bootstrap-\>run() #16 shopware.php(74): Enlight\_Application-\>run() #17 {main} ich dreh noch ab… schon wieder der selbe kram was nun ?

Hi, du hast vorher das Plugin deinstalliert, den Cache gelöscht und dann das neue Plugin aus dem Store wieder hochgeladen? Lösche einmal den Inhalt der Ordner /engine/Shopware/Proxies/ und /engine/Shopware/Models/Attribute Gruß Patrick

step 1 -habe das alte Plugin deinstalliert -habe es anschließend gelöscht -kompletten Cache geleert -die 2.0.2 Version für IONCUBE 4.0.6 runtergeladen -das Plugin hochgeladen, aktiviert und wie das alte konfiguriert. -nochmal cache gelöscht. -Kompletten Browerverlauf gelöscht -FEHLER step2 -habe die zwei Order nun geleert -Caches gelöscht -FEHLER aber immerhin klappt die checkbox nun.

Hi Hoschi, ich konnte den Fehler nachvollziehen und habe es weitergegeben. Sobald ich was neues weiß melde ich mich. Gruß Patrick

Hi, neue Version ist im Store. http://store.shopware.de/sonstiges/arti … oad-plugin Gruß Patrick

1 Like

Hi Patrick, habs nun angetestet und … finally… it works ! Werde es die kommenden Tage nochmal ausführlich durchtesten. Möchte dir nochmal persönlich für deinen Einsatz und deine Geduld danken. Ich bin sehr erleichtert das es nun mit deiner Hilfe endlich funktioniert aber auch sehr frustriert wg. dem Bugtracking was ich für ein kostenpflichtiges Produkt machen musste was mich viele Stunden gekostet hat. eigentlich habe ich mir ein Kommentarplatz im Quellcode verdient. z.b. Version 2.0.3 powered by HOSCHI ich denke das Thema kann dann geschlossen werden. Danke nochmal viele Grüße Hoschi

Hi Hoschi, es freut mich zu hören, das es nun endlich bei dir läuft. Es scheint sich bei dir um eine nicht ganz alltägliche Konfiguration zu handeln, daher hat es leider etwas länger gedauert. Das gesamte Plugin wurde bei diesem Prozess aber so geändert, dass es in Zukunft “robuster” ist. Ich sprech mal mit unserem Programmierer :wink: Ich wünsche also viel Spaß mit dem Plugin und mach dann hier mal dicht. Gruß Patrick