Anmeldung nur sporadisch möglich nach update auf 4.3.0

Wir nutzen eine gekauften Shopware Shop. Nach Update von 4.2.3 auf 4.3.0 schien ersteinmal alles ok zu sein nun tritt folgender fehler beim Anmelden als Gast oder Kunde auf: Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. sSaveRegister #00: Fields are missing NO SESSION-COOKIE - b405229fb931f2a69c22040140a434469be67af1 - Array ( [0] => billing#2->salutation [1] => billing#2->firstname [2] => billing#2->lastname [3] => billing#2->street [4] => billing#2->streetnumber [5] => billing#2->zipcode [6] => billing#2->city ) in engine/core/class/sAdmin.php on line 4421 Stack trace: #0 engine/core/class/sAdmin.php(2243): sAdmin->validateRegistrationFields(Array) #1 Shopware/Controllers/Frontend/Register.php(140): sAdmin->sSaveRegister() #2 Shopware/Controllers/Frontend/Register.php(125): Shopware_Controllers_Frontend_Register->saveRegister() #3 Enlight/Controller/Action.php(159): Shopware_Controllers_Frontend_Register->saveRegisterAction() #4 Enlight/Controller/Dispatcher/Default.php(528): Enlight_Controller_Action->dispatch(‘saveRegisterAct…’) #5 Enlight/Controller/Front.php(228): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #6 Shopware/Kernel.php(141): Enlight_Controller_Front->dispatch() #7 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(472): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #9 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(243): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #10 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(260): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #11 Shopware/Components/HttpCache/AppCache.php(132): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #12 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(189): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #13 Shopware/Components/HttpCache/AppCache.php(113): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #14 shopware.php(109): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #15 {main} woran kann dieses liegen? Danke und Gruß Danny Voigt

Hallo, hast du das Plugin „Custom Register“ installiert, wenn ja deaktiviere dies einmal testweise. Wir hatten ein ähnliches Problem bei einem Supportkunden in Zusammenhang mit diesem Plugin, wenn dort keine Einstellungen vorgenommen sind. Alternativ solltest du einmal prüfen ob du ggf. Plugins verwendest die in den Bestellprozess eingreifen. Viele Grüße Moritz

1 Like

Wir nutzen den Registration Configurator von Shopware. Vielen Dank genau an diesem hat es gelegen. Nun funktioniert es wieder. Eigentlich eine glatte 6 minus bei einem Plugin das von Shopware kommt.

Schick mir mal bitte eine PM zu dem Thema mit Verweis auf den Thread, dann schau ich morgen mal nach einem fix, bzw. Update für das Plugin.

Nach Deakivierung des Plugins „Registration Configurator“ funktioniert bei uns der Checkout auch wieder. Wir hatten mit dem Plugin die Felder Telefonnummer und Geburtsdatum ausgeblendet. Ein Fix wäre wichtig da wir ungern die - für uns unnötige - Telefonnummer der Kunden abfragen wollen.

Hallo, Telefonnummer kann man im Standard deaktivieren. Schau mal in die Grundeinstellungen Sebastian

Dort habe ich es auch deaktiviert, ich würde nur gerne das Feld auch ausblenden. Umso weniger Felder umso weniger denkt der Kunde im Checkout nach. Würd mich über einen Fix freuen.

PUSH Ist hier etwas neues bekannt? Hatte gerade den selben Fehler unter 4.3.2 nach Update von 4.2.1