great2gethergreat2gether MemberComments: 48 Received thanks: 13 Member since: January 2014

Hallo zusammen,

wir haben gerade einen Kunden, der das Problem hat dass sich bei ihm das Einkaufswelten Element des Super Mega Slider nach erstmaligem Anlegen nicht bearbeiten läßt. Könnt ihr mir evtl. einen Tipp geben, wie man so einem Fehler am besten auf die Schliche kommt?

Hatte vielleicht schonmal jemand ein anderes Einkaufswelten Element, dass sich bei einigen oder auch nur einem Shop nach dem Anlegen nicht mehr bearbeiten lassen hat? Und wenn ja, woran lag es und wie konntet ihr es beheben? 

Vielen Dank im Voraus für jegliche Tipps und Hinweise.
P.S.: "Wende dich an den Hersteller" geht nicht, da ich sonst Selbstgespräche führen müsste. 

Tagged:

1 Answer

  • MrAleMrAle MemberComments: 158 Received thanks: 37 edited September 1 Member since: April 2019

    Er sucht ja in der Form nach dem Wert von der Klasse = 'mega_title_1_font_mobile'. Diese scheint leer zu sein denn er schimpft ja darüber das er nicht null "shown" kann.

    Wie sieht denn das Formular aus aus welchem sich das Plugin die Werte zieht?

     

    Sorry falls das dämlich klingt, aber will nur helfen.

    Quote
    Accepted Answer
    Thanked by 1great2gether
  • Accepted Answer

Answers

  • great2gethergreat2gether MemberComments: 48 Received thanks: 13 Member since: January 2014

    Da bin ich wieder mit einer Spur die ich gefunden habe. In der Chrome Console kommt dieser Fehler hier: 

     

    /backend/Emotion?file=app&no-cache=1598921219+1+1:1273 Uncaught TypeError: Cannot read property 'show' of null
        at i.typeSelect1Function (/backend/Emotion?file=app&no-cache=1598921219+1+1:1273)
        at i.g (ext-all.js?202008121209:formatted:1226)
        at h.fire (ext-all.js?202008121209:formatted:5668)
        at i.continueFireEvent (ext-all.js?202008121209:formatted:17300)
        at i.fireEvent (ext-all.js?202008121209:formatted:17285)
        at i.fireEvent (ext-all.js?202008121209:formatted:38871)
        at initComponent (/backend/Emotion?file=app&no-cache=1598921219+1+1:1212)
        at i.constructor (ext-all.js?202008121209:formatted:30273)
        at i.callParent (ext-all.js?202008121209:formatted:2490)
        at i.constructor (ext-all.js?202008121209:formatted:38350)

    wenn ich es aufklappe kommt noch das hier: 

    	typeSelect1Function	@	/backend/Emotion?fil…1598921219+1+1:1273
    g	@	ext-all.js?202008121209:formatted:1226
    fire	@	ext-all.js?202008121209:formatted:5668
    continueFireEvent	@	ext-all.js?202008121209:formatted:17300
    fireEvent	@	ext-all.js?202008121209:formatted:17285
    fireEvent	@	ext-all.js?202008121209:formatted:38871
    initComponent	@	/backend/Emotion?fil…1598921219+1+1:1212
    constructor	@	ext-all.js?202008121209:formatted:30273
    callParent	@	ext-all.js?202008121209:formatted:2490
    constructor	@	ext-all.js?202008121209:formatted:38350
    i	@	ext-all.js?202008121209:formatted:2884
    widget	@	ext-all.js?202008121209:formatted:3382
    create	@	ext-all.js?202008121209:formatted:30136
    lookupComponent	@	ext-all.js?202008121209:formatted:50127
    prepareItems	@	ext-all.js?202008121209:formatted:50107
    add	@	ext-all.js?202008121209:formatted:50140
    initItems	@	ext-all.js?202008121209:formatted:50037
    callParent	@	ext-all.js?202008121209:formatted:2490
    initItems	@	ext-all.js?202008121209:formatted:60649
    initComponent	@	ext-all.js?202008121209:formatted:50027
    callParent	@	ext-all.js?202008121209:formatted:2490
    initComponent	@	ext-all.js?202008121209:formatted:60642
    callParent	@	ext-all.js?202008121209:formatted:2490
    initComponent	@	ext-all.js?202008121209:formatted:60798
    callParent	@	ext-all.js?202008121209:formatted:2490
    initComponent	@	base?file=bootstrap&…dIn=1598921219:4437
    callParent	@	ext-all.js?202008121209:formatted:2490
    initComponent	@	ext-all.js?202008121209:formatted:73310
    callParent	@	ext-all.js?202008121209:formatted:2490
    initComponent	@	base?file=bootstrap&…edIn=1598921219:121
    callParent	@	ext-all.js?202008121209:formatted:2490
    initComponent	@	/backend/Emotion/loa…1598921219+1+1:4644
    constructor	@	ext-all.js?202008121209:formatted:30273
    callParent	@	ext-all.js?202008121209:formatted:2490
    constructor	@	ext-all.js?202008121209:formatted:38350
    i	@	ext-all.js?202008121209:formatted:2884
    eval	@	VM6672:3
    Manager.instantiate	@	base?file=bootstrap&…dIn=1598921219:3369
    (anonymous)	@	ext-all.js?202008121209:formatted:1261
    create	@	ext-all.js?202008121209:formatted:2215
    onOpenSettingsWindow	@	/backend/Emotion/loa…1598921219+1+1:8305
    fire	@	ext-all.js?202008121209:formatted:5668
    dispatch	@	base?file=bootstrap&…dIn=1598921219:3863
    fireEvent	@	ext-all.js?202008121209:formatted:38872
    openSettingsWindow	@	/backend/Emotion/loa…1598921219+1+1:2784
    fn	@	/backend/Emotion/loa…1598921219+1+1:4094
    eval	@	VM7695:7
    g	@	ext-all.js?202008121209:formatted:6106


    Und wenn  ich dann noch oben rechts in der Console auf den Link klicke komme ich hier raus: 

    image

    In der 6. Zeile von unten ist angeblich der Fehler, aber ich seh da nichts falsches dran. 

    Hat jeeetzt vielleicht jemand eine Idee? Smile

    Vielen Dank im Voraus

     

     


     

  • MrAleMrAle MemberComments: 158 Received thanks: 37 edited September 1 Member since: April 2019

    Er sucht ja in der Form nach dem Wert von der Klasse = 'mega_title_1_font_mobile'. Diese scheint leer zu sein denn er schimpft ja darüber das er nicht null "shown" kann.

    Wie sieht denn das Formular aus aus welchem sich das Plugin die Werte zieht?

     

    Sorry falls das dämlich klingt, aber will nur helfen.

    Quote
    Accepted Answer
    Thanked by 1great2gether
  • great2gethergreat2gether MemberComments: 48 Received thanks: 13 Member since: January 2014

    Er sucht ja in der Form nach dem Wert von der Klasse = 'mega_title_1_font_mobile'. Diese scheint leer zu sein denn er schimpft ja darüber das er nicht null "shown" kann.

    Wie sieht denn das Formular aus aus welchem sich das Plugin die Werte zieht?

    Hey MrAle - Danke für den Tipp.

    Ich hab die ganze Zeit nach Fehlern im eigentlichen Shopware System gesucht, vermutet dass es an der PHP Version oder was auch immer liegt aber dein Zaunpfahlwink brachte mich auf die richtige Spur.

    Einige Formularfelder wurden im Backend gar nicht angezeigt, und das ziemlich genau ab dieser Stelle. Da muss einfach etwas beim Update auf die neueste SW Version durcheinander gekommen sein. Als ich gesehen habe, dass das Formular unvollständig ist hab ich das Plugin neu installiert und schwups war alles wieder zu sehen und das Bearbeiten funktioniert auch wieder.

    Also - noch einmal vielen lieben Dank.
    Atilla
Sign In or Register to comment.