White Screen of Death

Guten Abend, bekomme ein White Screen of Death und als Fehler wird mir das hier angezeigt.

Fatal error : Namespace declaration statement has to be the very first statement or after any declare call in the script in /html/Test/custom/plugins/TcinnModernTheme/TcinnModernTheme.php on line 3
 

 

Weiß leider nicht was genau damit gemeint wird…
kann mir jemand helfen ?

Da solltest du wohl das Plugin (Tcinn Modern Theme) deinstallieren und dich an den Plugin Hersteller wenden.

Viele Grüße
https://www.digitvision.de

@EikeWarneke schrieb:

Da solltest du wohl das Plugin (Tcinn Modern Theme) deinstallieren und dich an den Plugin Hersteller wenden.

Viele Grüße

War eine Demo version, wieso sollte ich mich beim Hersteller melden ?

Wie lösche ich das Plugin, ohne das die Einstellungen die ich getätigt habe im Plugin verloren gehen ?

 

Danke

Man kann das Plugin einfach deaktivieren, dann gehen die Einstellungen nicht verloren.
Wenn das Backend auch nicht geöffnet werden kann, kann man das Plugin über die console auf dem Server deaktivieren: „bin/console sw:plugin:deactivate PLUGIN_NAME“
Oder dasselbe kann man über die Datenbank machen: Tabelle s_core_plugins, Feld active

1 Like

@waldicom schrieb:

Man kann das Plugin einfach deaktivieren, dann gehen die Einstellungen nicht verloren.
Wenn das Backend auch nicht geöffnet werden kann, kann man das Plugin über die console auf dem Server deaktivieren: “bin/console sw:plugin:deactivate PLUGIN_NAME”
Oder dasselbe kann man über die Datenbank machen: Tabelle s_core_plugins, Feld active

Danke hat geklappt.

Nun erscheint aber ein anderer fehler :confused:

Fatal error: Uncaught TypeError: Argument 1 passed to Shopware\Components\Theme\PathResolver::getDirectoryByArray() must be of the type array, null given, called in /html/Test/engine/Shopware/Components/Theme/Inheritance.php on line 348 and defined in /html/Test/engine/Shopware/Components/Theme/PathResolver.php:100 Stack trace: #0 /html/Test/engine/Shopware/Components/Theme/Inheritance.php(348): Shopware\Components\Theme\PathResolver->getDirectoryByArray(NULL) #1 /html/Test/engine/Shopware/Components/Theme/Inheritance.php(354): Shopware\Components\Theme\Inheritance->getTemplateDirectoriesRecursive(‘32’, Array) #2 /html/Test/engine/Shopware/Components/Theme/Inheritance.php(210): Shopware\Components\Theme\Inheritance->getTemplateDirectoriesRecursive(36, Array) #3 /html/Test/engine/Shopware/Models/Shop/Shop.php(699): Shopware\Components\Theme\Inheritance->getTemplateDirectories(Object(Shopware\Models\Shop\Template)) #4 /html/Test/engine/Shopware/Models/Shop/Shop.php(655): Shopware\Models\Shop\Shop->registerTheme(Object(Shopw in /html/Test/engine/Shopware/Components/Theme/PathResolver.php on line 100

So sieht of ein Problem mit der PHP Version. Vermutlich ist bei Dir PHP 7?. Welche Shopware Version verwendest Du?

Benutze 5.3

Nutzt du ein Theme welches auf dem frisch deaktivierten Theme-Plugin basiert? Dann kommt es natrülich zu dem Fehler, da er nicht mehr darauf zugreifen kann.

LG Andre

Ich kann kein theme auswählen bekomme einen ERROR…

Man der ganze Shop ist zerschossen -.-

 

Ich hab auch grad gesehen das alle Plugins deinstalliert sind, alle änderungen die ich gemacht habe sind also futsch…
Wie kann sowas eigentlich passieren ?
Also ich die Datenbank und die Daten in dem FTP auf mein PC gezogen habe, waren alle Plugins Aktiv.
normalerweise werden die ja Deaktiviert wenn die lizens abläuft, bei mir sind die aber deinstalliert -.-

woran liegt das ?