Update

Hallo, ich bin neu hier. ich habe ein problem und hoffe es im richtigen reiter verstaut zu haben :).

habe vor ein paar minuten das neue update durchführen wollen. jetzt stehe ich an den ich komme niergends mehr hinein. da hat sich irgendwo ein fehler hineingeschlichen.

bitte um hilfe.

lg simon

Hi Simon,

welches ist denn das “neue Update” ?

wir haben ein ähliches Problem bei dem Update von 5.2.12 auf 5.2.14.  -> Backend nicht mehr erreichbar, bzw. lädt nur den blau Hintergrund.

Das Problem haben wir schon auf verschiedenen Systeme, jeweils bei dem Update auf 5.2.14. Das Update läuft komplett und ohne Fehler durch.

Das Access Log erzeugt einen 503:

/backend/base?file=bootstrap&201701130845 HTTP/1.1" 503

Und folgendes im Shopware Log:

core.ERROR: SmartyException: Unable to load template snippet 'backend/base/attribute/field/Shopware.form.field.PremiumGrid.js' in 'backend/base/bootstrap.js' in /var/www/html/ ***/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php:127 Stack trace: #0 /var/www/html/*** /engine/Library/Smarty/sysplugins/smarty_internal_template.php(286): Smarty_Internal_TemplateBase->fetch(Object(Enlight_Template_Default), NULL, NULL, NULL, false, false, true) 
 #1 /var/www/html/***/var/cache/production_201701130845/templates/backend_de_DE_96a45/2f/d6/b2/2fd6b203f8673a11f95d36a0489eef9ea80f8c0c.snippet.bootstrap.js.php(501): Smarty_Internal_Template->getSubTemplate('backend/base/at...', NULL, 'backend_de_DE_9...', NULL, NULL, Array, 0) 
 #2 /var/www/html/***/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php(180): content_58807a5a974f89_59185302(Object(Enlight_Template_Default)) 
 #3 /var/www/html/***/engine/Library/Enlight/View/Default.php(274): Smarty_Internal_TemplateBase->fetch() 
 #4 /var/www/html/***/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default)) 
 #5 /var/www/html/***/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default)) 
 #6 /var/www/html/***/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render() 
 #7 /var/www/html/***/engine/Library/Enlight/Event/Handler/Default.php(91): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs)) 
 #8 /var/www/html/***/engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) 
 #9 /var/www/html/***/engine/Library/Enlight/Controller/Action.php(200): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs)) 
 #10 /var/www/html/***/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('indexAction') 
 #11 /var/www/html/***/engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) 
 #12 /var/www/html/***/engine/Shopware/Kernel.php(179): Enlight_Controller_Front->dispatch() 
 #13 /var/www/html/***/vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Enlight_Controller_Request_RequestHttp), 1, true) 
 #14 /var/www/html/***/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) 
 #15 /var/www/html/***/vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) 
 #16 /var/www/html/***/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) 
 #17 /var/www/html/***/shopware.php(117): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) 
 #18 {main} [] {"uid":"9bac0f1"}

 

hi, 5.2.14 da liegt mein problem. ich habe keine ahnung was ich machen kann. habe gerade den angefangen reiter gefunden wo sie sich mit dem problem beschäftigen. ich bin momentan nur froh wenn ich die homepage wieder zum laufen bekomme. 

Wir konnten das Probem mit einem Update über die Konsole beheben:

irgendwie bin ich zu blöd für das. wie soll ich den update starten? bitte um hilfe danke

jetzt kommt diese fehlermeldung. ich bin mit meinem latein am ende

@VitaAktiva schrieb:

image

jetzt kommt diese fehlermeldung. ich bin mit meinem latein am ende

Hallo,

hast du vielleicht keinen „Shop“ (Shop, Subshop oder Sprachshop) in deinem Shopware Shop hinterlegt? Die Meldung sagt ja, das die localeId nicht leer sein darf.

Beste Grüße

Sebastian

danke für die schnelle antwort. wie schaffe ich jetzt das localeld nicht leer ist?

danke simon

Hallo,

Da Du nicht mehr ins backend kommst gar nicht, außer in der Datenbank, aber da Du Neuling bist würde ich folgendes empfehlen:

Datensicherung einspielen mit einer Sicherung als der Shop noch funktionierte.

Wenn auch keine Datensicherung ?: Neu installieren und dann erstmal mit allen Einstellungen des Shops sehr intensiv  vertraut machen. Updates nur noch nach Datensicherungen einspielen, oder noch besser: in einer Testumgebung.

1 Like