Update vorbereiten - Fehlende Rechte obwohl 777? ERLEDIGT!!

Guten Morgen!

Wir wollten gestern ein Update von 5.2.9 auf 5.2.13 per Browser machen, was sonst immer problemlos geklappt hat - nun aber jetzt nicht mehr. Alle nicht mehr benötigten Dateien würden nicht mehr gelöscht und die Erfolgreich Meldung blieb aus, es war als ob das Update nur partiell ausgeführt wurde. Also wieder Backup eingespielt und erstamal schauen woran das gelegen haben könnte.

Statt per Browser upzudaten haben wir überlegt das Ganze über dem Backend vorzunehmen, allerding (siehe Screenshot) merkert er, dass zwei Verzeichnisse nicht beschreibbar sind obwohl auf 750 gesetzt. Kurzzeitig volle Rechte mit 777 geben, das führte dazu, dass nur noch mehrere Ordner in der Liste als nicht beschreibbar aufgeführt wurden, z.B. die 4 Unterordner von recovery.

  1. Hat jemanden eine Idee woran das liegen könnte und Tipps wir wir das entsprechend anpassen könnten?

  2. Um erfolreich ein Update per Browser duchzuführen müssen alle dafür in Backend gezeigten Voraussetzungen zwingend erfüllt sein? (Aktualität der Plugins ist klar)

Vielen Dank im Voraus

hamaca

 

Hast Du 777 rekursiv vergeben, also auch für die Unterordner, oder nur für den recovery/-Ordner selber?

777 ist aber allgemein aus Sicherheitsgründen keine gute Idee - hast Du mal die Rechte, Besitzer und Gruppe z.B. des recovery/-Ordners mit denen eines Ordners verglichen, den Shopware als ok einstuft? Vermutlich gibt es da irgendwo einen Unterschied.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

1 Like

Vielen Dank erstmal.

777 hatte ich nur kurz ausprobiert, aber nur für den recovery Ordner. Inzwishen habe ich folgendes gelesen: „Falls hier Shopware-Ordner bemängelt werden, setze deren Rechte auf 0755“ - das habe ich getan, allerdings ohne jegliche Änderung zu erzielen :frowning:

Direkt in recovery Odner gibt es schon eine  Menge Unterordner; ich bin mir nicht sicher ob sie auch dann alle auf 775 gesetzt werden müssen.

Leider habe ich keine Vergleichsmöglichkeit. Der Shop um den es hier geht ist noch im Aufbau und zwar auf einen Server im geschüztem Bereich. Wir haben auch eine zweiten Shop in Livebetrieb und merkwürdigerweise sind auch hier werden sind die gleichen Verzeichnisse nicht beschreibbar. Beide Shops liegen zwar auf den gleichen Server, wurden jedoch separat installiert und sind nicht Kopien voneinander.

Bei welchem Hoster bist du denn? All-Inkl?

Nein, Hosteurope.

Man lernt ja nie aus - nach diverse Stunden habe ich endeckt, dass der Pfad im Web-/FTP-Space auf dem Server nicht korrekt war. Nun funktioniert alles wie es sein soll und Updates laufen einwandfrei über’s Backend :slight_smile: