Update von 4.3.6 auf 5.1.1 funktioniert nicht

Hallo Shopware Gemeinde, da bei meinem aktuellen Hoster SW5 nicht läuft, habe ich mir jetzt einen neuen gesucht. Ich habe die Datenbank und die Dateien erfolgreich verschoben. Der Shop läuft soweit, ich kann alle Seiten aufrufen und habe auch erfolgreich eine Testbestellung gemacht. Mein Problem ist, ich kann nicht auf SW5 updaten. Weder über Softeareaktualisierung noch mit dem manuellen update funktioniert es. Wenn ich das manuelle update starten möchte, gebe ich in der Adresszeile …/shop/recovery/update/index.php ein. Wenn ich dann Starte wechselt die Adresszeile zu …/shop//index.php Die Ordner recovery und update sind vorhanden!

Jetzt hat sich doch noch ein Problem im Backend ergeben. Ich bekomme sporadisch folgende Fehlermeldung 503 - Service Unavailable Fatal error: Maximum execution time of 30 seconds exceeded in /www/htdocs/w013d23f/test89255.test-account.com/shop/engine/Shopware /Plugins/Default/Backend/SwagUpdate/Components/FileSystem.php on line 74 503 Service Unavailable

1 Like

Hallo, das Problem mit dem Update deutet ja erstmal auf fehlende Rewrite-Regeln hin. Der Update-Ordner hat ja auch eine .htaccess, ggf. ließt der Hoster die nur auf der ersten Ebene des Shops ein und keine weiteren. Das müsstest du aber mal vom Hoster prüfen lassen, generelle Probleme gibt es da so nicht. Die zweite Meldung sagt ja erstmal schon aus was das Problem ist. Irgendein Prozess braucht bei dir mehr als 30 Sekunden und das ist aber deine max_execution_time in PHP. Das müsstest du raufsetzen oder den Server schneller machen :wink: Moritz

bei mir funktionierte es erst, als ich die max_execution_time auf 120 gesetzt und die php version von 7.0.4 auf 5.4.45 hatte

1 Like

@testitio schrieb:

bei mir funktionierte es erst, als ich die max_execution_time auf 120 gesetzt und die php version von 7.0.4 auf 5.4.45 hatte

Danke, hat bei mir geholfen.