Unable to find a matching sales channel

Guten Morgen,

ich hatte bei meinem Provider zum Test eine SW6 Installation von vor ca. 5-6 Wochen installliert.
Jetzt wurde alles platt gemacht und ich habe mir den letzten Stand aus dem Master gezogen. Nach der Installation erscheint im Frontend:

Unable to find a matching sales channel 

In den Admin kann ich mich einloggen. Aber die Sales Channel werden ebenfalls nicht geladen.

Hat jemand eine Idee, wie ich das Problem lösen kann?

Danke & Gruß
Ottscho

Hey Ottscho,

guck mal in der Datenbank in der Tabelle sales_channel_domain nach … klingt danach das die Domain mit der du den Shop aufrufst nicht die hinterlegte in der Datenbank ist.

Gruß
René von wambo 

1 Like

Hallo,

ich hänge mich hier mal an da ich die gleiche Fehlermeldung habe. Shopware 6.1 RC3 ist seit ein paar Tagen installiert und ich bin aktuell am Einrichten. Jetzt war ich eben beim eingeben der Produkte. Bei 20 Stück funktionierte noch alles, jetzt habe ich 30 drin und nun kommt die Fehlermeldung:

Unable to find a matching sales channel for the request: https://www.luxusladen-24.de/". Please make sure the domain mapping is correct.

Ich habe wie oben geraten in der Tabelle sales_channel_domain nachgesehen. Da sind 2 Einträge drin, einmal mit und einmal ohne https

Was kann ich noch versuchen?

Vielen Dank
Michael

Hi zusammen,

könnte das wohl ein ähnlicher Fall sein wie meiner (siehe https://forum.shopware.com/discussion/64904/poah-kein-theme-vorhanden#latest ). Bei mir wurde das Problem verursacht, dass ich nach der Installation die Einstellung des Servers verändert habe - so war bei mir in der Tabelle sales_channel_domain der Pfad mit einem “public”-Teil eingetragen - das Verändern des Eintrages hat allerdings bei mir keinen Erfolg gebracht. Ich werde nun die Installation woh nochmals neu machen.

LG Sebastian

Nein, das passte bei mir alles bei der Installation. Es lief auch alles bis ich weitere Artikel eingegeben habe, das muss also irgendwie dabei passiert sein!?

In die Administration komme ich übrigens, die Fehlermeldung kommt nur beim Shop selbst. Egal ob im Wartungsmodus oder nicht.

niemand eine Idee was ich noch versuchen könnte?

Ich hatte das gleiche Problem.

Verkaufskanal aktiviert?  Wenn ja dann den Verkaufskanal löschen und neu anlegen. URL https + http eintragen

2 Likes

super, danke! hat funktioniert (neu anlegen)…

 

Hello, If I cannot access the site admin where do I delete and add in new sales channel

Google Translate:
Hallo, wenn ich nicht auf den Site-Admin zugreifen kann, wo lösche ich und füge einen neuen Vertriebskanal hinzu?