The provided name SwagPayPal is invalid and no app could be found

Hallo,
nach Update auf 6.4.14 ist das Log voll mit div. Fehlermeldungen:

[2022-08-04T08:06:49.373130+00:00] request.ERROR: Uncaught PHP Exception Shopware\Administration\Controller\Exception\AppByNameNotFoundException: „The provided name SwagPayPal is invalid and no app could be found.“ at /home/www.domain.com/vendor/shopware/administration/Controller/AdminExtensionApiController.php line 116 {„exception“:„[object] (Shopware\Administration\Controller\Exception\AppByNameNotFoundException(code: 0): The provided name SwagPayPal is invalid and no app could be found. at /home/www.domain.com/vendor/shopware/administration/Controller/AdminExtensionApiController.php:116)“}

The provided name SwagPayPal is invalid and no app could be found.
[2022-08-04T08:06:49.393924+00:00] request.ERROR: Uncaught PHP Exception Shopware\Administration\Controller\Exception\AppByNameNotFoundException: „The provided name SwagAmazonPay is invalid and no app could be found.“ at /home/www.domain.com/vendor/shopware/administration/Controller/AdminExtensionApiController.php line 116 {„exception“:„[object] (Shopware\Administration\Controller\Exception\AppByNameNotFoundException(code: 0): The provided name SwagAmazonPay is invalid and no app could be found. at /home/www.domain.com/vendor/shopware/administration/Controller/AdminExtensionApiController.php:116)“}

1 Like

Hallo, bei uns tritt der identische Fehler auf. Zudem lassen sich Bestellungen nicht abschließen. Nach Klick auf den Button erscheint ein 500er Fehler. Gibt es dazu schon eine Lösung? Der Fehler scheint bei allen Zahlarten aufzutreten. Wir nutzen unter anderem Paypal und Amazon Pay.

request.ERROR: Uncaught PHP Exception Shopware\Administration\Controller\Exception\AppByNameNotFoundException: „The provided name SwagPayPal is invalid and no app could be found.“

request.ERROR: Uncaught PHP Exception Shopware\Administration\Controller\Exception\AppByNameNotFoundException: „The provided name SwagAmazonPay is invalid and no app could be found.“

Bei uns kann man auch nicht mehr bestellen. Hast Du zufällig noch DHL Pickware im Einsatz um DHL-Label zu erstellen? Das macht bei uns ganz große Probleme seit dem Update.
Anscheinend fehlen ganze Tabellenspalten in der Datenbank und nichts geht mehr.

Nein, DHL nutzen wir nicht. Alles andere scheint zu funktionieren. Mich irritiert eher die Fehlermeldung, Plugin ist da und korrekt registriert. Das scheint eher was in SW selbst oder im Paypal Plugin fehlerhaft zu sein. Datenbank habe ich insofern noch nicht nachgesehen.

Ich habe den Fehler ebenfalls in v6.4.14.0 in Verbindung mit PayPal 5.3.0 festgestellt. Es scheint aber die Funktionalität nicht einzuschränken, zumindest ist mir nichts aufgefallen…

Interessanterweise tritt der Fehler auch in einer komplett frischen Shopware Installation auf. Ich habe den Fehler dem Shopware Support gemeldet, die daraufhin ein Issue erstellt haben: