SW 5.6 nach Update falsche Emails bei Bestellstatus Änderungen

Hallo,

Habe von 5.5.0. auf 5.6.2 updated.

Wenn ich den Bestellstatus ändere z.B. in “in Bearbeitung” kommt das Popup Fenster mit der entsprechenden Email Vorlage. Der Mailinhalt sieht gut aus. Dann sende ich die Email und erwarte, dass der Empfänger den Inhalt bekommt den ich gesehen habe.  (Siehe Screenshot)

Aber dem ist nicht so.

Der Inhalt der Email ist das was in der Mailvorlage Dokumenten-E-Mails - Standardvorlage steht. (Siehe Screenshot)
Also " Hallo Herr xy, Vielen Dank für Ihre Bestellung…"

Wie kann ich das wieder so hinbiegen, dass das E-Mail mit der richtigen Vorlage gesendet wird?

Danke
Martin

 

 

Empfangene Email:

 

 

Hallo,

habe genau das selbe Problem. VOrlage “in Bearbeitung” sendet falsche E-Mail. Hast du es lösen können? Hat wer eine Idee? Wir benutzen das Plugin Custom Products - hat das vielleicht damit zu tun?

 

Hallo,

wahrscheinlich der gleiche Fehler wie in unzählig weiteren Themen dazu, siehe: https://forum.shopware.com/discussion/63769/update-auf-5-6-2-status-emails-falsch oder https://forum.shopware.com/discussion/63366/mailversand-beim-bestell-zahlungstatus-aendern-funktioniert-nicht (beide Themen über die Forumssuche gefunden).

Wird also weiterhin wahrscheinlich mit Shopware Version 5.6.3 behoben.

Grüße

Sebastian

1 Like

Hallo Sebastian,

Vielen Dank für den Hinweis. Das hat tatsächlich geholfen. https://forum.shopware.com/discussion/63366/mailversand-beim-bestell-zahlungstatus-aendern-funktioniert-nicht

Habe als Workaround den Haken rausgenommen wie unten beschrieben.

@Moritz Naczenski schrieb:

Nein, das Problem ist, dass er das Html vom Dokumentenversand nimmt, wenn die Statusmail kein HTML hat. Wenn du das bei der Dokumentenvorlage rausnimmst, versendet er das auch nicht.

Hab es selbst nicht getestet, aber ein Kollege schrieb das vorhin und hat das auch geprüft.

//Edit: Habs gerade nochmal getestet - du musst bei der sORDERDOCUMENTS einfach den Haken rausnehmen.

Eigentlich habe ich mit dem “Kaufmännischen” nichts zu tun, und gucke daher auch nicht in die EMails. Dieses “Problem” hatte ich daher auch nicht auf dem Schirm. Zufällig hatte ich gerade dennoch eine Statusänderung gesehen… und siehe da: Auch falsch.

Bei einer personell quantitativ so ausgestatteten Firma wie Shopware sollte man doch erwarten können, dass Änderungen auch wirklich getestet werden. OK - es kann sich ein Fehler einschleichen. Bei solchen gravierenden  Bugs sollte man aber erwarten können, dass zeitnah  eine Bugfix-Version erscheint.
Wenn ich mich aber auf GIT so umgucke, wird aber weiter munter für 5.6.3 commited => also auch diese Woche wieder keine Release?

Wird SW5 in 2019 noch ein Lebenszeichen von sich geben?
5.6.2 stammt ja noch aus dem September, und früher wurde mal kommuniziert, spätestens alle 6 Wochen eine Bugfix-Version…

Edit: Was hat es eigentlich mit dem Bereich “Dokumenten-E-Mails” auf sich?
Die Doku schweigt sich zu diesen Vorlagen auch gekonnt aus.  Undecided

Wahrscheinlich kommt die Version in der nächsten Woche, wenn alles gut geht.

2 Likes