Shopware PHP8.2 Kompatibilität

Hallo liebe SW5 Forum-Menschen :five: :tada: :blue_heart:

das nächste Shopware Update (5.7.17) soll PHP 8.2 kompatibel sein. Es wäre schön, wenn wir schon jetzt ein paar Leute finden, die bereit sind, das zu testen :blush: :v:

Hinweis: Die Composer-Installation wird nicht funktionieren, wenn PHP8.2 genutzt wird, da es noch Libraries gibt, die keine PHP8.2-Unterstützung haben.
Ihr könnt aber unter jeder anderen PHP-Version installieren und einfach auf 8.2 umstellen.

Wir freuen uns auf euer Feedback!
Einen schönen Tag noch :wave:

2 Likes

Ich könnte das gern testen, aber im Plesk-Paket wird PHP 8.2 noch gar nicht angeboten. Mal die nächsten Tage schauen …

1 Like

Moin, was ist denn aktuell die maximal offiziell unterstützte php Version für 5.7.18?
Laut Composer: ~8.3.0 ?

Moin @Mike_W

die letzte Version 5.7.19 unterstützt PHP 7.4 - PHP 8.2

Siehe shopware/composer.json at v5.7.19 · shopware5/shopware · GitHub

Der aktuelle Entwicklungsstand erlaubt allerdings auch PHP 8.3.

Viele Grüße aus Schöppingen
Michael Telgmann

1 Like