Shopware Domain Wechsel bei world4you

Hallo,

Wir hatten uns entschlossen für unseren neuen Shop (ist noch in der Entwicklungsphase) doch eine andere Domain zu wählen.

Also von www.phoenix-der-gesundheit.at auf www.phoenix-der-lebenskraft.at

Mein Hoster ist world4you.

Ich hatte den Domain Wechsel bei world4you beantragt.

Über die neue Domain komme ich nun aber weder ins backend noch in das frontend…

Ich habe bei world4you angefragt was da los ist und folgende Antwort bekommen:  Es müssen auch bei der Datenbank und bei der Installation die Pfade angepasst werden, da sich der Name der der Domain ja geändert hat.

Ich weis jetzt nicht wirklich was ich da machen kann… Bitte um Hilfe.

Ich habe zwar einige Anleitungen bezüglich Domain Wechsel gefunden, die setzten aber voraus, dass man in das Backend kommt, was bei mir nicht der Fall ist.

Lg Andreas

 

 

 

 

PS: kann es sein, dass dies etwas mit der SSL Verschlüsselung zu tun hat - die ich für die alte Domain schon aktiviert und am Laufen hatte?

In MySQL Tabelle s_core_shops gehen und die Spalten host und hosts anpassen. Das geht mit phpMyAdmin.

Bei URL-Änderung, muss im Shopware-Account die Shop-Registrierung geändert werden!

1 Like

Hallo Frank,

vielen Herzlichen Dank, es funktioniert.

Ich hatte schon befürchtet, dass ich nun alles neu aufsetzen und konfigurieren muss.

Lg Andreas

Möglicherweise habe ich mich auch zu früh gefreut - ich bin nach der Änderung in der DB kurz ins Frontend und ins Backend gekommen - habe an den Einstellungen nichts geändert und nun ist abermal weder Frontend noch Backend erreichbar.

Hast Du die URL-Registrierung im Shopware-Account schon gemacht? 

1 Like

Habe irgendwie meine HTACCESS Datei in Verdacht…

 

RewriteCond %{HTTPS} !=on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


RewriteEngine on

#RewriteBase /shopware/

# HTTPS config for the backend
#RewriteCond %{HTTPS} !=on
#RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]
RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L]

RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/)
RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

# Fix missing authorization-header on fast_cgi installations
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]



    # Restrict access to VCS directories
    RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$)

    # Restrict access to root folder files
    RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$

    # Restrict access to shop configs files
    RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$

    # Restrict access to theme configurations
    RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$


# Staging environment
#SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging

# Development environment
#SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev
#SetEnv SHOPWARE_ENV dev

DirectoryIndex index.html
DirectoryIndex index.php
DirectoryIndex shopware.php

# Disables download of configuration

    # Deny all requests from Apache 2.4+.
    
          Require all denied
    

    # Deny all requests from Apache 2.0-2.2.
    
        Deny from all
    


# Enable gzip compression

    AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml



    
        ExpiresActive on
        ExpiresDefault "access plus 1 month"
    

    
        Header append Cache-Control "public"
        Header unset ETag
    

    FileETag None


# Match generated files like:
# 1429684458_t22_s1.css
# 1429684458_t22_s1.js

    
        Header set Cache-Control "max-age=31536000, public"
    

    
        ExpiresActive on
        ExpiresDefault "access plus 1 year"
    


# Disables auto directory index

    #Options -Indexes



    #Options -MultiViews


# AddType x-mapp-php7 .php
# AddHandler x-mapp-php7.php


    Header append X-Frame-Options SAMEORIGIN
    # Uncomment the following line to enable HSTS (https://en.wikipedia.org/wiki/HTTP_Strict_Transport_Security) and force clients to use HTTPS for at least one year (31536000 seconds)
    # Header always set Strict-Transport-Security "max-age=31536000"

 

Hast Du die URL-Registrierung im Shopware-Account schon gemacht? 

 

Noch nicht, mach ich gleich - dachte, dass sich das nur auf die Funktion der Plugins auswirkt…

 

Hast Du die verändert? Ich sehe, auf die Schnelle, keinen Bezug zu Deiner URL? Probier doch mal über ssh, den Cache zu löschen.

1 Like

Hallo Frank,

also ich habe jetzt bei Shopware die Domain geändert…

Es schaut so aus, zur Zeit komme ich wieder ins Backend und auch ins Frontend :slight_smile:

Habe keine Ahnung an was es gelegen hatte.

Möglicherweise hatte es etwas mit dem Cache zu tun… Oder mit der Domain Umstellung im Shopware Acount…

Jedenfalls geht es wieder und hoffe, dass es so bleibt :slight_smile:

 

Vielen Dank !!

 

Lg Andreas